Γενικό Λύκειο > Πολυδιάστατοι πίνακες

ασκησεις στους πινακες

(1/1)

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ:
Καλημέρα σε όλους τους συναδέλφους.
Θα ήθελα να ρωτήσω αν είναι λάθος το να υλοποιεί ένα παιδί πολλά ερωτήματα μαζί.

π.χ. θέλουμε να βρόυμε το άθροισμα κατά γραμμές σε ένα δισδιάστατο πίνακα και το max

max<-Γ[1,1]
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 16
    S<-0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 30
        ΑΝ Γ[i,j]>max ΤΟΤΕ
           max<-Γ[i,j]
        ΤΕΛΟΣ_ΑΝ
        S<-S + Γ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

petrosp13:
Γιατί να είναι λάθος;;
Απλά προτείνω να τοποθετεί σχόλια δίπλα σε κάποιες γραμμές κώδικα για να είναι εμφανές ότι υλοποιεί διαφορετικά ερωτήματα συγχρόνως

bugman:
Λείπει η έξοδος (και η είσοδος)...αλλά μπορεί να είναι οκ για την άσκηση...
Δεν εμφανίζει τα αποτελέσματα!

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση