Μπορώ να γράψω: ΑΝ (i mod 12 =0) <> ΨΕΥΔΗΣ ΤΟΤΕ...

Ξεκίνησε από iokollias, 17 Απρ 2022, 02:43:29 ΜΜ

« προηγούμενο - επόμενο »

iokollias

Αφορμή για την ερώτηση στάθηκε το Β1 θέμα του 2017...(συμπλήρωση κενών)
Η προφανής λύση είναι:
  Ι <-- 4
  ΟΣΟ Ι<=40 ΕΠΑΝΑΛΑΒΕ
    ΑΝ Ι MOD 12 <>0 ΤΟΤΕ
      ΓΡΑΨΕ Ι
    ΤΕΛΟΣ_ΑΝ
    Ι <-- Ι+4
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Ένας μαθητής μου έγραψε:
  Ι <-- 4
  ΟΣΟ Ι<=40 ΕΠΑΝΑΛΑΒΕ
    ΑΝ (Ι MOD 12=0) <> ΨΕΥΔΗΣ ΤΟΤΕ
      ΓΡΑΨΕ Ι
    ΤΕΛΟΣ_ΑΝ
    Ι <-- Ι+4
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Γιατί είναι λάθος (αν είναι)???

petrosp13

Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

iokollias

Η Γλωσσομάθεια μου δίνει λάθος...θα στείλω μια σημείωση στον κ. Νικολαΐδη...

andreas_p


Κανένας

Παράθεση από: iokollias στις 17 Απρ 2022, 05:34:17 ΜΜΗ Γλωσσομάθεια μου δίνει λάθος...θα στείλω μια σημείωση στον κ. Νικολαΐδη...
Φαίνεται να μην λειτουργεί ο τελεστής <> με τον λογικό τύπο
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου "Μανώλης Γλέζος"
https://eclass03.sch.gr/courses/D21100/

evry

Πράγματι δεν δέχεται το ΑΛΗΘΗΣ <> ΨΕΥΔΗΣ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr