Σύνθετη Αν σε Απλή

Ξεκίνησε από merobot, 08 Φεβ 2022, 03:12:54 ΜΜ

« προηγούμενο - επόμενο »

merobot

Θα ήθελα βοήθεια με τον παρακάτω αλγόριθμο.Πως μπορώ να τον μετατρέψω σε μια απλή Αν?
Αν χ<1000 τοτε
χ<- χ-100
Αλλιώς
χ<- χ+100
Τέλος_Αν

petrosp13

Θα πρέπει να σκεφτείς ποια συνθήκη αφορά η κάθεμια από τις 2 περιπτώσεις (Αν-Αλλιώς) και να δημιουργήσεις 2 δομές απλής επιλογής
Αλλά θέλει πολύ μεγάλη προσοχή γιατί η μεταβλητή της συνθήκης αλλάζει τιμή εντός της δομής
Ύπουλη άσκηση
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

merobot

Γίνεται να μου δώσετε ένα παράδειγμα πάσω στον αλγόριθμο γιατί δεν το πολύ κατάλαβα?Ευχαριστώ εκ των προτέρων

astakos1010

x<- x + 100
An x<1100 τοτε
   χ<- χ - 200
Τέλος_αν

ripper

Παράθεση από: merobot στις 08 Φεβ 2022, 03:12:54 ΜΜ
Θα ήθελα βοήθεια με τον παρακάτω αλγόριθμο.Πως μπορώ να τον μετατρέψω σε μια απλή Αν?
Αν χ<1000 τοτε
χ<- χ-100
Αλλιώς
χ<- χ+100
Τέλος_Αν


Παίξε με λογική μεταβλητή, εάν «μπήκες» στην πρώτη αν.

akouts

#5
Χ <- Χ - 100
ΑΝ Χ >= 900 ΤΟΤΕ
  Χ <- Χ + 200
ΤΕΛΟΣ_ΑΝ

epsilonXi

μεταβολή <- 100
Αν χ<1000 τοτε
  μεταβολή <- -100
Τέλος_Αν
χ <- χ + μεταβολή

Κανένας

Παράθεση από: akouts στις 20 Φεβ 2022, 01:48:45 ΜΜΧ <- Χ - 100
ΑΝ Χ >= 1000 ΤΟΤΕ
  Χ <- Χ + 200
ΤΕΛΟΣ_ΑΝ
Διόρθωση:

Χ <- Χ - 100
ΑΝ Χ >= 900 ΤΟΤΕ
  Χ <- Χ + 200
ΤΕΛΟΣ_ΑΝ
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου "Μανώλης Γλέζος"
https://eclass03.sch.gr/courses/D21100/

akouts

Παράθεση από: Κανένας στις 21 Φεβ 2022, 04:32:15 ΜΜΔιόρθωση:

Χ <- Χ - 100
ΑΝ Χ >= 900 ΤΟΤΕ
  Χ <- Χ + 200
ΤΕΛΟΣ_ΑΝ
Σωστός, μου ξέφυγε!!!!!
Διορθώνω!!