Γενικό Λύκειο > Εντολή ΑΝ

Άσκηση σε πολλαπλή δομή επιλογής

(1/1)

thCnd:
Καλημέρα,
θα ήθελα να ρωτήσω πώς λύνεται μία άσκηση με κλαδική συνάρτηση όπου το x ανήκει στα διαστήματα (-5,0],     (0,5]     και για κάθε άλλο x.

Εγώ σκέφτηκα τη λύση
Αν x > -5 και x <=o τότε
    Εντολές
Αλλιώς_αν x > 0 και x <=5 τότε
    Εντολές
Αλλιώς
    Εντολές
Τέλος_αν

Ευχαριστώ εκ των προτέρων  :)

Βασίλης Παπαχρήστος:
Μια χαρά λύση!
Κουβέντα να γίνεται, μια άλλη προσέγγιση θα ήταν η ακόλουθη:

Αν x <= -5 τότε
  Εντολές 1
Αλλιώς_αν x <= 0 τότε
  Εντολές 2
Αλλιώς_αν x <= 5 τότε
  Εντολές 3
Αλλιώς
  Εντολές 1
Τέλος_αν

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση