Αποστολέας Θέμα: Δεν μπορώ να δω τον βοηθητικό δίσκο  (Αναγνώστηκε 187 φορές)

mandarinos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 132
Δεν μπορώ να δω τον βοηθητικό δίσκο
« στις: 30 Σεπ 2021, 10:21:19 πμ »
Καλημέρες!

Το πρόβλημά μου είναι το εξής:
Στα νέα μηχανήματα που έφεραν (μεταξύ άλλων και) στο δικό μου σχολείο, στον server (Lenovo ThinkStation p330), έχω έναν εκκινήσιμο δίσκο m.2 των 256 GBytes, ο οποίος φιλοξενεί το Linux (Mint 20.1). (Όλα καλά μ' αυτόν, κι όλα καλά με το LTSP / τα scripts της ΤΣ. Κανένα παράπονο.) Επίσης, έχω στον server κι έναν δίσκο της παλιάς σχολής, hdd των 2 TBytes, ο οποίος προφανώς τοποθετήθηκε εκεί γιά βοηθητικές δουλειές. Αυτόν τον hdd, τώρα, θέλω:

(α) να τον κάνω κοινόχρηστο στο δίκτυο (γιά ανταλλαγή αρχείων με τον server του 2ου εργαστηρίου - όπου θα τοποθετήσω έναν άλλον σαβουρόδισκο σε παρεμφερή διάταξη),
(β) να τον κάνω αποθετήριο γιά τα images των δίσκων των clients (βασικά ένα πρότυπο image, που θα το αντιγράφω στους υπόλοιπους με τον Clonezilla μέσω του δικτύου - το πέτυχα, κι ετοιμάζω το how-to προσεχώς!)...

...αλλά δεν μπορώ να δω τα περιεχόμενά του, ή να γράψω κάτι σ' αυτόν. Και τούτο, επειδή δεν μπορώ να τον κάνω mount με τίποτε!!!

Η πλάκα είναι πως ο Clonezilla τον βλέπει μιά χαρά, καθώς και ο ίδιος ο server. (Δες συνημμένη εικόνα.) Καθώς και η λειτουργία Timeshift. Αλλά εγώ να τον χρησιμοποιήσω ως συνηθισμένο δίσκο γιά αποθήκευση αρχείων, απλά αδύνατον.

Βέβαια, δεν κάθησα με σταυρωμένα τα χέρια, αλλά έκανα τις εξής ενέργειες:

- Εγκατέστησα το gdisk (οδηγίες εδώ: https://www.explorelinux.com/convert-disk-mbr-to-gpt-on-linux/ ), ώστε να δω αν είναι GPT ή MBR, και να τον μετατρέψω ανάλογα. (Δεν έχει δεδομένα ούτως ή άλλως, οπότε δεν με πείραζε και να σβηστεί.) Βρέθηκε πως είναι GPT και σημειώνεται ως /dev/sda1.
- Έψαξα το fstab, όπου δεν ήταν γραμμένος.
- Εγκατέστησα το gparted, του τράβηξα ένα φορμάρισμα σε etx4 (έτσι ήταν φορμαρισμένος και πριν), τον καθόρισα πάλι ως GPT, και έδωσα εντολή ν' αλλάξει το UUID του.
- Μπήκα με sudo nano στο fstab, και κατέγραψα και τον hdd. Μετά απ' αυτά, το fstab μου είναι το εξής:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p5 during installation
UUID=f6f0c68d-0a88-410e-8200-78325163a6a6 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=F746-FBC7  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
#σαβουρόδισκος 2 TBytes
#UUID=A828A174-F166-4790-BCC2-745AB6C782A3   /dev/sda1   ext4

(Το σημειωμένο UUID είναι κοπυπαστάδα από το gdisk, που το ξανακάλεσα δεύτερη φορά μετά τις δουλειές του gparted.)

- Έκανα reboot τον υπολογιστή, διαπίστωσα ότι αργεί λίγο παραπάνω η εκκίνηση, αλλά ...πάλι δεν τον βλέπει στα ίσα ο ΗΥ!

Όπως βλέπετε, στο fstab τον έχω commented-out. Όσο είχα ενεργή τη δήλωσή του, είχα δοκιμάσει να δώσω στο τέλος της γραμμής παραμέτρους 0 0 και 0 1, αλλά πάλι τίποτε. (Την τελευταία φορά ξαναδοκίμασα χωρίς αυτές, πάλι χωρίς αποτέλεσμα.)
Επίσης, με χειροκίνητο mount, πάλι τίποτε. Με εντολή: sudo mount /dev/sda1, βγάζει διαγνωστικό: mount: dev/sda1: can't find in /etc/fstab. Αλλά και που τον είχα δηλωμένον στο fstab, πάλι έβγαζε διαγνωστικό λάθους.

Τί(ς) πταίει;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6147
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Δεν μπορώ να δω τον βοηθητικό δίσκο
« Απάντηση #1 στις: 30 Σεπ 2021, 10:38:26 πμ »
Στα σχολεία της περιοχής μου τους ίδιους δίσκους που λες τους φορμάρω ως εξής:

Κώδικας: [Επιλογή]
# lsblk --fs
NAME FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                   
├─sda1
│    ntfs   windows
│                 5DD6E0C0585DE521                                   
└─sda2
     ext4   srv   7628113a-5bca-4165-8b36-79b55f552faa  802,7G     0% /srv
sr0                                                                   
nvme0n1
│                                                                     
├─nvme0n1p1
│    ext4   linux 4f68bce3-e8cd-4db1-96e7-fbcaf984b709  207,2G     4% /
└─nvme0n1p2
     swap   swap  0657fd6d-a4ab-43c4-84e5-0933c84b4f4f                [SWAP]

# parted -l
Model: ATA ST2000DM008-2FR1 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  1074GB  1074GB  primary  ntfs
 2      1074GB  2000GB  927GB   primary  ext4


Model: INTEL SSDPEKKF256G8L (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  247GB  247GB   primary  ext4            boot
 2      247GB   256GB  8599MB  primary  linux-swap(v1)

Το partition "windows" είναι εντελώς άδειο, αφήνω χώρο μήπως κάποτε στο μέλλον εγκαταστήσουν dual boot windows.

Για το /etc/fstab, χρησιμοποιώ το παρακάτω σε όλες μου τις εγκαταστάσεις, και αποσχολιάζω τις γραμμές που χρειάζομαι. Προφανώς έχω δώσει τις κατάλληλες ετικέτες (labels) στα σχετικά partitions:

Κώδικας: [Επιλογή]
# cat /etc/fstab
# Static file system information. Documentation=man:fstab(5) man:ext4(5)
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
LABEL=linux     /               ext4    errors=remount-ro  0    1
#LABEL=EFI      /boot/efi       vfat    umask=0077      0       2
#LABEL=home     /home           ext4    defaults        0       2
LABEL=srv       /srv            ext4    defaults        0       2
LABEL=swap      none            swap    sw              0       0

mandarinos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 132
Απ: Δεν μπορώ να δω τον βοηθητικό δίσκο
« Απάντηση #2 στις: 30 Σεπ 2021, 11:19:27 πμ »
Έπιασε!!!

Και με LABEL, και με UUID. (Μόνο που στη δεύτερη περίπτωση η εκκίνηση αργεί μερικά δευτερόλεπτα παραπάνω.) Έπρεπε να βάλω στο τέλος της γραμμής δήλωσης του hdd τα: defaults 0 2, καθώς και πρώτα-πρώτα-πρώτα να ρίξω μιά ματιά στο man fstab. (Είμαι απαράδεκτος!  :) )

Άλκη, ευχαριστώ τα μάλα!

Οκ, τον έχω τώρα τον hdd! Προχωράω στις επόμενες εργασίες που θέλω.