Γενικό Λύκειο > Δομή επιλογής

ΕΡΩΤΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ

(1/3) > >>

Jimbo:
Η
    ΑΝ Σ1 ΚΑΙ Σ2 ΤΟΤΕ
        ΕΝΤΟΛΕΣ.....
          ..........

γράφεται με απλές συνθήκες ως
   ΑΝ Σ1 ΤΟΤΕ
      ΑΝ Σ2 ΤΟΤΕ
         ΕΝΤΟΛΕΣ....
            .......

η παρακάτω δομή επιλογής πως μετατρέπεται σε απλές συνθήκες
ΑΝ Σ1 Η Σ2 ΤΟΤΕ
        ΕΝΤΟΛΕΣ.....


          ..........

gpapargi:
Αν και δεν πολυκαταλαβαίνω το λόγο για να τεντώσουμε τόσο το σκοινί  :) ένα τρόπος που μου ήρθε είναι ο εξής:

λ<-ψευδής
Αν Σ1 τότε
  λ<-Αληθής
Τέλος_αν
Αν Σ2 τότε
  λ<-Αληθής
Τέλος_αν
Αν λ = αληθής τότε
  εντολές
Τέλος_αν

ntzios kostas:
Οταν λέμε απλές συνθήκες εννοούμε να μη χρησιμοποιούνται λογικοί τελεστές. Οπότε γράφεται:

αν Σ1 τότε
......αν Σ2 τότε
.............Ε1
......αλλιώς
.............Ε2
......Τέλος_αν
αλλιώς
......Ε2
Τέλος_αν

evry:
Δεν είμαι σίγουρος αλλά μήπως εννοεί το παρακάτω;

Αν Σ1 ή Σ2 τότε
  Εντολές
Τέλος_αν

ότι είναι ισοδύναμο με

Αν Σ1 Τότε
  Εντολές
Αλλιώς_Αν Σ2 Τότε
  Εντολές
Τέλος_Αν

Νομίζω το πιο πάνω ισοδυναμεί καλύτερα γιατί δείχνει και το short-circuit evaluation

Jimbo:
Πιστεύω και εγώ οτι  πιο κοντά είναι η απάντηση του evry.
AN Σ1 ΤΟΤΕ
ΕΝΤ
ΤΕΛΟΣ_ΑΝ
ΑΝ Σ2 ΤΟΤΕ
ΕΝΤ
ΤΕΛΟΣ_ΑΝ


Ευχαριστώ πολύ  :)

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση