ΘΕΜΑ Β

Ξεκίνησε από gpapargi, 06 Ιουν 2014, 09:08:17 ΠΜ

« προηγούμενο - επόμενο »

SuperTz

Το Β2 πιστεύω ότι γίνεται και με ΓΙΑ:
Για i από 1 μέχρι 200

P.Tsiotakis

Παράθεση από: SuperTz στις 06 Ιουν 2014, 11:42:14 ΠΜ
Το Β2 πιστεύω ότι γίνεται και με ΓΙΑ:
Για i από 1 μέχρι 200

απο τετραδιο μαθητη σελ 24
γινεται και με Για φυσικα

Λαμπράκης Μανώλης

Παράθεση από: Tzo στις 06 Ιουν 2014, 11:41:11 ΠΜ
Συμφωνώ κι εγώ αυτό βρήκα. Με τη διόρθωση στο τελευταίο βέβαια, που νομίζω κι εγώ πως είναι Π[θ], Π[κ]

ναι....σωστά

stavrax

Αν το b2 το κανει κανεις με μεχρις οτου πειραζει? τι λετε?

P.Tsiotakis

Παράθεση από: stavrax στις 06 Ιουν 2014, 12:13:57 ΜΜ
Αν το b2 το κανει κανεις με μεχρις οτου πειραζει? τι λετε?

αν η ψευδογλώσσα υπολογίζει σωστά το s γιατι να είναι λάθος;;

vistrian

νομίζω ότι είναι σωστό και αυτό

Για κ από 1 μέχρι 29
  θ ← κ + 1
  Για ι από κ μέχρι 30
    Αν Π[ι] > Π[θ] τότε
      θ ← ι
    Τέλος_αν
  Τέλος_επανάληψης
  Αντιμετάθεσε Π[θ], Π[κ]
Τέλος_επανάληψης
VR in Computing

Aris_v

1. κ
2. >
3. i
4. Π[κ]
5. Π[θ]

kLee

Παράθεση από: vistrian στις 06 Ιουν 2014, 01:39:23 ΜΜ
νομίζω ότι είναι σωστό και αυτό

Για κ από 1 μέχρι 29
  θ ← κ + 1
  Για ι από κ μέχρι 30
    Αν Π[ι] > Π[θ] τότε
      θ ← ι
    Τέλος_αν
  Τέλος_επανάληψης
  Αντιμετάθεσε Π[θ], Π[κ]
Τέλος_επανάληψης
Και εγώ έτσι νομίζω...καμιά άλλη άποψη γι αυτή τη λύση?
Ανδροκλής Πολυμένης

Πληροφορικός

vistrian

Παράθεση από: vistrian στις 06 Ιουν 2014, 01:39:23 ΜΜ
νομίζω ότι είναι σωστό και αυτό

Για κ από 1 μέχρι 29
  θ ← κ + 1
  Για ι από κ μέχρι 30
    Αν Π[ι] > Π[θ] τότε
      θ ← ι
    Τέλος_αν
  Τέλος_επανάληψης
  Αντιμετάθεσε Π[θ], Π[κ]
Τέλος_επανάληψης

Είσοδος
1
2
3
4
5
6
7
8
9
10


Έξοδος
10
9
8
7
6
5
4
3
2
1
VR in Computing

P.Tsiotakis

Το εμφωλευμενο για βρίσκει το max
Οποιαδήποτε σχετική αρχικοποίηση του θ ειναι σωστη
Πχ το 30

parasxoum

είναι λάθος στο διάγραμμα να χρησιμοποιηθεί Αρχή_Επανάληψης...Μέχρις_Ότου;

petrosp13

Στο συγκεκριμένο, όχι
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

alpapanto

Παράθεση από: petrosp13 στις 06 Ιουν 2014, 02:26:13 ΜΜ
Στο συγκεκριμένο, όχι
???
γιατί να είναι σωστό?
έχεις συνθήκη στην αρχή της επανάληψης, επιστρέφεις στη συνθήκη από εντολή...

petrosp13

Και κάποιοι το έκαναν ορθώς με Για
Το ίδιο είναι και τα 3 στο συγκεκριμένο παράδειγμα
Αν χρειάζονταν περίεργες μετατροπές, τότε ναι
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

freedomst

Παράθεση από: alpapanto στις 06 Ιουν 2014, 02:33:33 ΜΜ
???
γιατί να είναι σωστό?
έχεις συνθήκη στην αρχή της επανάληψης, επιστρέφεις στη συνθήκη από εντολή...

Επιστρέφεις στην επανάληψη από το ψευδής. Δηλαδή, εκτελείς μέχρι να ισχύσει η συνθήκη, είναι και γνωστό πλήθος επαναλήψεων οπότε σίγουρα εκτελείται τουλάχιστον μία φορά. Άρα, όλο το διάγραμμα μπορεί να γραφεί με την ισοδύναμη Μέχρις_ότου.
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"