Γενικό Λύκειο > Εξετάσεις 2017-2018

Θέμα Δ

(1/14) > >>

evry:
Εδώ σχολιάζουμε το θέμα Δ

mikezante:
Και εδώ

--- Κώδικας: ---ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πληθος, ι, μ, μαξ, αθρ, λ, ΕΠ[20, 12]
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], τεμπ2
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ[20], τεμπ
  ΛΟΓΙΚΕΣ: flag
ΑΡΧΗ
                                                                             !Δ2
  flag <- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ πληθος
  ΜΕΧΡΙΣ_ΟΤΟΥ πληθος > 0 ΚΑΙ πληθος <= 20
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΔΙΑΒΑΣΕ Π[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                                                             !Δ3
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΓΡΑΨΕ Π[ι]
    ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 12
      ΚΑΛΕΣΕ Υ_Ε(μαξ)
      ΕΠ[ι, μ] <- μαξ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                                                             !Δ4
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    αθρ <- 0
    ΓΙΑ μ ΑΠΟ 1 ΜΕΧΡΙ 12
      αθρ <- αθρ + ΕΠ[ι, μ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΟ[ι] <- αθρ/12
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ πληθος
    ΓΙΑ λ ΑΠΟ πληθος ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
      ΑΝ Π[λ - 1] > Π[λ] ΤΟΤΕ
        τεμπ2 <- Π[λ - 1]
        Π[λ - 1] <- Π[λ]
        Π[λ] <- τεμπ2
        τεμπ <- ΜΟ[λ - 1]
        ΜΟ[λ - 1] <- ΜΟ[λ]
        ΜΟ[λ] <- τεμπ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ πληθος
    ΑΝ ΜΟ[ι] > 7 ΤΟΤΕ
      ΓΡΑΨΕ Π[ι]
      flag <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ flag = ΨΕΥΔΗΣ ΤΟΤΕ
   ΓΡΑΨΕ "Κανένας ποταμός με ρύπους πάνω απο 7"
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ Υ_Ε(ρ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ρ, τιμη
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ τιμη
    ΑΝ τιμη > ρ ΤΟΤΕ
      ρ <- τιμη
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ τιμη = 0
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


 
--- Τέλος κώδικα ---

Διορθωμενο

Λαμπράκης Μανώλης:
στο Δ4 θέλει τα ονόματα αλφαβητικά ... εκεί πρέπει να γίνει η ταξινόμηση νομίζω...εγω τα εβαλα σε νεο πίνακα ....

Λαμπράκης Μανώλης:
άκυρο αυτό που λέω βγαίνει πιο ευκολα ετσι .. σωστόοοςςς

gthal:
Θέλω να δω πώς θα βαθμολογηθεί με μόλις 4 μονάδες το Δ4 (μου πήρε όσο όλα τα υπόλοιπα σε έκταση - πολλά βήματα).
Προφανώς έχουν κάποια άλλη λύση στο νου τους...

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση