Γενικό Λύκειο > Εξετάσεις 2020-2021

ΘΕΜΑ Δ

(1/2) > >>

evry:
Λύσεις /Σχόλια / Παρατηρήσεις / προβλήματα αναφορικά με το Θέμα Δ

grdereken:
Λύση στο Δ4 με μεταφορά κάθε γραμμής σε μονοδιάστατο πίνακα αντί να γίνει ταξινόμηση πάνω στο δισδιάστατο
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6 !μεταφορά γραμμής Ιης σε μονοδιάστατο
       ΕΠ[J] <- ΕΠΙΔ[Ι, J]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 6 !Ταξινόμηση Iης γραμμής
       ΓΙΑ J ΑΠΟ 6 ΜΕΧΡΙ K ME_BHMA -1
         ΑΝ ΕΠ[J] > ΕΠ[J-1] TOTE 
          T <- ΕΠ[J]
          ΕΠ[J] <- ΕΠ[J-1]
          ΕΠ[J-1] <- T
        ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

     ΓΡΑΨΕ ΟΝ[Ι]
     ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ ΕΠ[j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

juandojas:
Αρκετοί μαθητές - από συνήθεια και έχοντας μάθει τυφλοσούρτη κάποιες μεθοδολογίες - στην ταξινόμηση του Δ4, πέρα από τα στοιχεία του 2διάστατου αντιμετέθεταν παράλληλα και τα στοιχεία του μονοδιάστατου με τα ονόματα. Κατά τα άλλα, η ταξινόμηση κάθε γραμμής στον 2διάστατο είναι σωστή. Προφανώς, ο πίνακας με τα ονόματα - στις πρώτες 6 θέσεις του - θα έχει χαλάσει. Πόσο άραγε θα αφαιρεθεί για αυτό το λάθος; Έχω 3 τέτοιες περιπτώσεις μαθητών μου!

epsilonXi:
κάποιος λύνει πρώτα το Δ4 και μετά στο Δ3 εξετάζει για κάθε αθλητή αν η 5η και η 6η επίδοσή του είναι μηδενική!
 :)

Γιαννούλης Γιώργος:
Αυτό θα ήταν πραγματικά ωραία λύση, αν ήθελε να το τερματίσει τελείως θα ελέγχει μόνο την 5η αν είναι 0. :D

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση