Γενικό Λύκειο > Εξετάσεις 2019-2020

Σχολιασμός θεμάτων Ανάπτυξης Εφαρμογών με το Παλιό Σύστημα

(1/3) > >>

evry:
Ανάπτυξη Εφαρμογών (τελευταία θέματα 2020)
ΤΕΛΟΣ ΕΠΟΧΗΣ!

ΔΗΜΗΤΡΗΣ Χ:
Στο θεμα β1 του παλιου συστήματος, νομίζω ότι σωστο θα ειναι κατά την μετατροπή από για σε μεχρις οτου να μπει και εντολή αν
δηλαδή

διαβασε χ
αν χ< -3 τοτε
     κ<-- -3
     αρχη_επανάληψης
          γραψε κ
          κ<-- κ-1
     μεχρις_οτου κ< χ
τελος αν

διαφορετικα θα κανει απειρες επαναλήψεις ενώ η για δεν εκτελείται
βεβαια ισως να  θεωρείται σωστο και χωρις αυτό αλλα νομιζω πως χρειαζεται

andreas_p:
Διάβασε χ
κ <-  -3 ! η εντολή αυτή θα εκτελεστεί ΣΙΓΟΥΡΑ
Αν κ >= χ  τότε
      Αρχή_επανάληψης
          Γραψε κ
          κ <- κ-1
     Μεχρις_οτου κ< χ
Τελος_αν

ΔΗΜΗΤΡΗΣ Χ:
Οκ. Συμφωνω.
Και σωστη και η συνθηκη αν χ<= -3

giannakos:
Καλησπέρα σας.
Θα ήθελα να ρωτήσω για το ερώτημα Α4.
 Ένας μαθητής μου, στην μετατροπή της πολλαπλής επιλογής σε απλές έγραψε:

--- Κώδικας: ---ΑΝ χ <= 1 ΤΟΤΕ
        α <-- 1
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 1 ΤΟΤΕ
        α <-- 2
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 10 ΤΟΤΕ
        α <-- 3
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 100 ΤΟΤΕ
        α <-- 4
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ α

--- Τέλος κώδικα ---
Σίγουρα δεν εκτελούνται οι ίδιες εντολές με το δοσμένο τμήμα προγράμματος, όμως εμφανίζονται οι ίδιες τιμές.
Θα χάσει μονάδες?

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση