Γενικό Λύκειο > Εξετάσεις 2018-2019

Θέμα 3

(1/3) > >>

evry:
Εδώ σχολιάζουμε το θέμα 3

progmat:

--- Κώδικας: ---ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΓ_2019
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΡ_ΕΠ, ΜΑΧ, ΜΜΑΧ, ΠΛ1, ΠΛ2, ΠΛ3
  ΧΑΡΑΚΤΗΡΕΣ: ΤΙΤΛΟΣ, ΤΜΑΧ, ΚΑΤΜΑΧ

ΑΡΧΗ
  ΜΑΧ <- 0
  ΠΛ1 <- 0
  ΠΛ2 <- 0
  ΠΛ3 <- 0
  ΔΙΑΒΑΣΕ ΤΙΤΛΟΣ
  ΟΣΟ ΤΙΤΛΟΣ <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ ΑΡ_ΕΠ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΑΡ_ΕΠ > 0
    ΑΝ ΑΡ_ΕΠ > ΜΑΧ ΤΟΤΕ
      ΜΑΧ <- ΑΡ_ΕΠ
      ΤΜΑΧ <- ΤΙΤΛΟΣ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΑΡ_ΕΠ <= 100 ΤΟΤΕ
      ΠΛ1 <- ΠΛ1 + 1
    ΑΛΛΙΩΣ_ΑΝ ΑΡ_ΕΠ <= 1000 ΤΟΤΕ
      ΠΛ2 <- ΠΛ2 + 1
    ΑΛΛΙΩΣ
      ΠΛ3 <- ΠΛ3 + 1
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ ΤΙΤΛΟΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΤΟ ΒΙΝΤΕΟ ΜΕ ΤΟΝ ΜΕΓΑΛΥΤΕΡΟ ΑΡ_ΕΠ ΕΙΝΑΙ ', ΤΜΑΧ
  ΓΡΑΨΕ 'ΧΑΜΗΛΗ ΚΑΤΗΓΟΡΙΑ', ΠΛ1
  ΓΡΑΨΕ 'ΜΕΣΑΙΑ ΚΑΤΗΓΟΡΙΑ', ΠΛ2
  ΓΡΑΨΕ 'ΥΨΗΛΗ ΚΑΤΗΓΟΡΙΑ', ΠΛ3
  ΜΜΑΧ <- ΠΛ1
  ΚΑΤΜΑΧ <- 'ΧΑΜΗΛΗ'
  ΑΝ ΠΛ2 > ΜΜΑΧ ΤΟΤΕ
    ΜΑΧ <- ΠΛ2
    ΚΑΤΜΑΧ <- 'ΜΕΣΑΙΑ'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΠΛ3 > ΜΜΑΧ ΤΟΤΕ
    ΜΑΧ <- ΠΛ3
    ΚΑΤΜΑΧ <- 'ΥΨΗΛΗ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ΚΑΤΜΑΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

--- Τέλος κώδικα ---

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ:
Στον ελεγχο εγκυροτητας η συνθηκη ειναι >=0 .... λεει να μην ειναι αρνητικος

P.Tsiotakis:
μηδενικές επισκέψεις δεν καταμετρώνται

petrosp13:
Το πινακάκι έχει παγίδα, προσοχή
Τα αν πρέπει να έχουν διπλές συνθήκες και όχι Αλλιώς

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση