Γενικό Λύκειο > Εξετάσεις 2011-2012

Θέμα Α1.3

<< < (2/9) > >>

Stefevan:

--- Παράθεση από: Juan στις 01 Ιουν 2012, 05:35:08 μμ ---Αν στο πρόβλημα 'διάβασε 1000 τιμές στην είσοδο και βρες τη μέγιστη', αποθηκεύσεις τις τιμές σε πίνακα, δεν αυξάνεις την απαιτούμενη μνήμη του προγράμματος;

--- Τέλος παράθεσης ---
Προφανώς.. αφού τις κρατάς όλες....

Εμένα πάντως δεν το χει παρει το μάτι μου πουθενά. Αλλά με βάση αυτό που λέει το σχολικό ποια είναι η πιο πιθανή απάντηση? Και μόνο ότι είναι μειονέκτημα η χρήση πίνακα... Και μιλάει για πίνακα μόνο, δεν μπλέκει τις μεταβλητές

ipoulis:

--- Παράθεση από: Juan στις 01 Ιουν 2012, 05:35:08 μμ ---Αν στο πρόβλημα 'διάβασε 1000 τιμές στην είσοδο και βρες τη μέγιστη', αποθηκεύσεις τις τιμές σε πίνακα, δεν αυξάνεις την απαιτούμενη μνήμη του προγράμματος;

--- Τέλος παράθεσης ---
Φυσικά και την αυξάνει αλλά ξαναλέω ότι αυτό συνιστά ασκοπη χρήση πίνακα.
Μπορώ να βρω ένα πρόγραμμα που την αυξάνει και ένα που δεν την αυξάνει.
Άρα??

George:
Να κάνω μια   ερώτηση
Γιατί το δεύτερο πρόγραμμα έχει  αυξημένες απαιτήσεις  σε μνήμη σε σχέση με το πρώτο?

ΠΡΟΓΡΑΜΜΑ ΠΧ1
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: Α, Β
ΑΡΧΗ
   ΔΙΑΒΑΣΕ Α, Β
   ΕΚΤΥΠΩΣΕ Α, Β
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ ΠΧ2
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: Α[2]
ΑΡΧΗ
   ΔΙΑΒΑΣΕ Α[1], Α[2]
   ΕΚΤΥΠΩΣΕ Α[1], Α[2]
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ipoulis:
Συμφωνούμε ότι δεν έχει.
Το θέμα με το Σ-Λ τι απαντάμε.

Μου έκανε εντύπωση ότι από ένα σύνολο μαθητών μόνο ο καλύτερος (ταλέντο στην Πληροφορικής)
απάντησε Λάθος.

netnick:

--- Παράθεση από: George στις 01 Ιουν 2012, 06:09:32 μμ ---Να κάνω μια   ερώτηση
Γιατί το δεύτερο πρόγραμμα έχει  αυξημένες απαιτήσεις  σε μνήμη σε σχέση με το πρώτο?

ΠΡΟΓΡΑΜΜΑ ΠΧ1
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: Α, Β
ΑΡΧΗ
   ΔΙΑΒΑΣΕ Α, Β
   ΕΚΤΥΠΩΣΕ Α, Β
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ ΠΧ2
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: Α[2]
ΑΡΧΗ
   ΔΙΑΒΑΣΕ Α[1], Α[2]
   ΕΚΤΥΠΩΣΕ Α[1], Α[2]
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

--- Τέλος παράθεσης ---
Δεν μπορώ να διαφωνήσω άμεσα (θέλει λίγο προσοχή, αν και νομίζω ότι έχει γενικά κάποιο πρόβλημα) αλλά θεωρώ το παράδειγμα άστοχο. Σύγκρινε ένα απο τα 2 τμήματα με το παρακάτω :
ΔΙΑΒΑΣΕ Χ
ΓΡΑΨΕ Χ
ΔΙΑΒΑΣΕ Χ
ΓΡΑΨΕ Χ

ή κάπως έτσι τέλος πάντων για 10 ή 100 μεταβλητές.
Υπάρχει μια κάποια διαφορά.
Αυτό θα ήθελε να εννοήσει η επιτροπή...

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

[*] Προηγούμενη σελίδα

Μετάβαση στην πλήρη έκδοση