Γενικό Λύκειο > Εξετάσεις 2011-2012

Θέμα Β

(1/4) > >>

gpapargi:
Εδώ μιλάμε για θέμα Β

karagige:
Ερώτηση για διορθωτές: Αν στο διάγραμμα ροής (Β2) αντί για αρχή_επανάληψης...μέχρις_ότου γραφτεί με αντίστοιχη για...από...μέχρι ή όσο...επανάλαβε, πώς θα βαθμολογηθεί; Ευχαριστώ πολύ...

geoAlex:
Θέμα Β1
Αν τρέξουμε τον αλγόριθμο θα πέρναμε τις παρακάτω τιμές ( μπλέ οι τιμές που θα εμφανιστούν)

Κ Χ   ι 1 -1 0       1 -1        -1 -1       1           2  -1        -1 1       2           3  -2        -2 2       4          4  -8        -8 4       5           5  -40        -40 5       7     Τερματισμός βρόγχου Όσο


Θέμα Β2

ν ← 0
s ← 0
Αρχή_επανάληψης
  Αν ν mod 2 = 1 τότε
    χ ← -1
  αλλιώς
    χ ← 1
  Τέλος_αν
  s ← s + χ/(2*ν + 1)
  ν ← ν + 1
Μέχρις_ότου ν = 99
π ← 4*s
Εκτύπωσε π

Νίκος Αδαμόπουλος:

--- Παράθεση από: karagige στις 01 Ιουν 2012, 03:01:00 μμ ---Ερώτηση για διορθωτές: Αν στο διάγραμμα ροής (Β2) αντί για αρχή_επανάληψης...μέχρις_ότου γραφτεί με αντίστοιχη για...από...μέχρι ή όσο...επανάλαβε, πώς θα βαθμολογηθεί; Ευχαριστώ πολύ...

--- Τέλος παράθεσης ---

Εξαρτάται από τη λύση...! Καλύτερα να δώσεις συγκεκριμένη λύση για να τη σχολιάσουμε...

karagige:
s ← 0
για ν από 0 μέχρι 98
  Αν ν mod 2 = 1 τότε
    χ ← -1
  αλλιώς
    χ ← 1
  Τέλος_αν
  s ← s + χ/(2*ν + 1)
τέλος_επανάληψης
π ← 4*s
Εκτύπωσε π

ή

ν ← 0
s ← 0
όσο ν<>99 επανάλαβε
  Αν ν mod 2 = 1 τότε
    χ ← -1
  αλλιώς
    χ ← 1
  Τέλος_αν
  s ← s + χ/(2*ν + 1)
  ν ← ν + 1
τέλος_επανάληψης
π ← 4*s
Εκτύπωσε π

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση