Γενικό Λύκειο > Εξετάσεις 2011-2012

Θέμα Α

(1/20) > >>

gpapargi:
Εδώ μιλάμε για θέμα Α

geoAlex:
Θέμα Α1
1. Λάθος     (δες σελίδα 56).
2. Λάθος     (δες σελίδα 174).
3. Σωστή    (δες σελίδα 191).
4. Λάθος     (δες σελίδα 56).
5. Σωστό    (δες σελίδα 60).

Θέμα Α2
Για τους τύπους δεδομένων δες σελίδα 148.

Χ <- 'ΑΛΗΘΗΣ'     Χαρακτήρας     ΑΛΗΘΗΣ
Χ<- 11.0-13.0     Πραγματική      -2.0         Λειτουργία εντολής εκχώρησης δες σελ 154.
Χ<- 7>4              Λογική             ΑΛΗΘΗΣ
Χ<- ΨΕΥΔΗΣ       Λογική              ΨΕΥΔΗΣ
Χ<- 4                  Ακέραια            4

Θέμα Α3.α
Α[3] <- 3+Α[6]
Α[9]<- Α[7]-2
Α[8]<- Α[3]-5
Α[4]<- 5+Α[9]
Α[5]<- (Α[3]+Α[7]) div 2  ή (Α[2]+Α[7]) div 2


Θέμα Α3.β
   Για i από 1 μέχρι 5
        αντιμετάθεσε Α[ι], Α[11-ι]
   Τέλος_επανάληψης

θέμα Α4.α
   ι <- 99
   Όσο ι >= 1 επανάλαβε
       χ<- ι^2
      εμφάνισε χ
      ι <- ι – 2
   Τέλος_επανάληψης

Θέμα Α4.β
   ι <- 99
   Αρχή_επανάληψης
       χ <- ι^2
      εμφάνισε χ
      ι <- ι – 2
   Μέχρις_ότου ι < 1

Θέμα Α5
Δες σελίδα 60 σχολικού.

merlin:
Ένας μαθητής στο Α3.β. έγραψε:

Για ι από 1 μέχρι 5
      αντιμετάθεσε Α[ι],Α[Α[ι]]
Τέλος_επανάληψης

Αν και εξαρτάται από την υλοποίηση του αλγορίθμου (π.χ. με διαδικασία swap), δε μπορώ παρά να τον συγχαρώ για την πρωτοτυπία του. Ελπίζω να μην του κόψουν μονάδες πάντως...

petrosp13:
Δεν θα του κόψεις κανένας μονάδες! Καταπληκτικό!

kkkerm:
Νομίζω ότι έχουν γίνει λάθακια ... στη λύση που πρότεινε ο geoAlex

Χ <- 'ΑΛΗΘΗΣ'     Χαρακτήρας     ΑΛΗΘΗΣ  :)
Χ<- 11.0-13.0     Πραγματική      -2.0   
Χ<- 7>4              Λογική             ΑΛΗΘΗΣ
Χ<- ΨΕΥΔΗΣ       Λογική              ΨΕΥΔΗΣ  :)
Χ<- 4                  Ακέραια            4

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση