Γενικό Λύκειο > Εξετάσεις 2003-2004

ΛΑΘΟΣ ΣΤΟ 2ο ΘΕΜΑ ΕΠΑΝΑΛ 04???

(1/1)

nekis:
 :furious3:
Αγαπητοί συναγωνιστές ΚΑΛΗ ΧΡΟΝΙΑ
Κοιτώντας λίγο τα θέματα των Επαναληπτικών φέτος, νομίζω ότι ξέθαψα ... πατάτα από το χωράφι.
Το θέμα έχει ώς εξής:
Δίνεται ο παρακάτω αλγόριθμος :
Αλγόριθμος Αριθμοί_ ΜΕΡΣΕΝ
  Διάβασε Α
  Β <--4
  C <--2
  Aρχή_επανάληψης
     Β <--(Β ^ 2)-2
     Εμφάνισε Β
     C <--C + 1
  Μέχρις_ότου C > (A -1)
  D <--(2 ^ A) -1
  E <--B MOD D
  Εμφάνισε D
  Αν E = 0 τότε
     F<--(2 ^ (C -1)) * D
     Εμφάνισε "Τέλειος αριθμός:", F
     G<--0
     Όσο F > 0 επανάλαβε
        G<--G + 1
        F<--F DIV 10
     Τέλος_επανάληψης
     Εμφάνισε G
  Τέλος_αν
Τέλος Αριθμοι_ΜΕΡΣΕΝ
Ο αλγόριθμος έχει την εκχώρηση D<-- (2 ^ A)-1 και στη συνέχεια E<--B MOD D. Το D όμως είναι πραγματικό και δεν μπορεί να είναι όρισμα MOD. Έχω δίκιο ή είμαι τρελλός???

gpapargi:
Καλή χρονιά. Εύχομαι σε όλους υγεία.

Ο 2^Α -1 (με Α ακέραιο θετικό δηλαδή φυσικό αριθμό εκτός από 0) είναι ακέραιος.

Αν καταλαβαίνω καλά εννοείς "που το ξέρουμε ότι ο χρήστης θα εισάγει φυσικό;"

Οι αριθμοί mersenne είναι αντικείνενο της θεωρίας αριθμών. Είναι οι αριθμοί της μορφής 2^p -1. Επειδή το ενδιαφέρον είναι το να βρεις πότε παραγοντοποιούνται (και δεν είναι πρώτοι) στα πιο πολλά βιβλία ορίζονται ως οι αριθμοί της μορφής 2^p -1 με p πρώτο αριθμό. Γενικά δηλαδή κάποιος που ξέρει το αντικείμενο θα εισάγει Α φυσικό.

Πάντως η άσκηση σου δίνει την είσοδο ακέραια και θετική και ζητάει την έξοδο. Οπότε δε βλέπω πρόβλημα ως προς τις εξετάσεις.

Αν δεν έδινε είσοδο, τότε θα λέγαμε ότι προυποθέτει είσοδο φυσικό μη μηδενικό αριθμό

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση