Γενικό Λύκειο > Δομή επανάληψης

Εύρεση min max

<< < (6/6)

Γιαννούλης Γιώργος:

--- Παράθεση από: ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ στις 08 Ιαν 2015, 04:34:06 μμ ---Για μένα ο καλύτερος τρόπος είναι ο παρακάτω:

 Διάβασε χ
min ←  χ
max← χ
Για i από 2 μέχρι Κ
    Διάβασε χ
    Αν (χ < min) τότε
      min ← χ
    Τέλος_αν
    Αν (χ>max) τότε
      max ← χ
    Τέλος_αν
  Τέλος_επανάληψης
  Εκτύπωσε min, max

--- Τέλος παράθεσης ---

Οι 2 τρόποι δεν είναι ισοδύναμοι...
Αν Κ < 1 τότε θα βγάλουν άλλα αποτελέσματα.

Αν ήθελες να το κάνεις πραγματικά ισοδύναμο θα έπρεπε να γράψεις:

--- Κώδικας: ---Αν Κ>=1 τοτε
    Διάβασε χ
    min ←  χ
    max← χ
Τελος_Αν
Για i από 2 μέχρι Κ
    Διάβασε χ
    Αν (χ < min) τότε
      min ← χ
    Τέλος_αν
    Αν (χ>max) τότε
      max ← χ
    Τέλος_αν
  Τέλος_επανάληψης
  Εκτύπωσε min, max

--- Τέλος κώδικα ---

Προσωπικά η επιπλέον πολυπλοκότητα στο γράψιμο του κώδικα είναι ασύμφορη σε επίπεδο χρόνου εξετάσεων, σε σχέση με τη λύση που δόθηκε από τον μαθητή. Το ποιες είναι οι προσωπικές μας απόψεις δεν αφορά την βαθμολογία. Η λύση που έδωσε είναι ορθότατη (προφανώς δεν κόβονται μονάδες). Αν την αφορούσε θα ήθελα να δω πως σε δισδιάστατο πίνακα θα βρούμε το min χωρις να το συγκρίνουμε 2 φορές.

Πλοήγηση

[0] Λίστα μηνυμάτων

[*] Προηγούμενη σελίδα

Μετάβαση στην πλήρη έκδοση