Γενικό Λύκειο > Εντολή ΓΙΑ...ΑΠΟ...ΜΕΧΡΙ

Ερώτηση για "σπάσιμο" Για

(1/2) > >>

jkapsi:
Γεια σας, έχω μια ερώτηση σχετικά με τη δομή επανάληψης Για. Κάναμε μια πολύ απλή άσκηση αναζήτησης σε έναν πίνακα 1200 ονομάτων και μια μαθήτρια με ρώτησε αν μπορεί να κάνει το παρακάτω:


--- Κώδικας: Bash ---κ<-1200Για ι από 1 μέχρι κ   Αν Ον[ι]=όνομα τότε      π<-ι      κ<-ι   Τέλος_ανΤέλος_επανάληψης
Με το που θα βρεθεί δηλαδή η τιμή στον πίνακα, το κ γίνεται μικρότερο του ι, αφού το ι θα αυξηθεί στο τέλος του βρόγχου και η επανάληψη σταματά.
Ξέρω πως δεν μπορούμε να αλλάξουμε τον μετρητή (ι) μέσα στη Για, αλλά με την τιμή τ2 (κ) τι γίνεται; Επιτρέπεται μια τέτοια αλλαγή;
Καταλαβαίνω πως μπορεί να είναι δυσνόητη για τους μαθητές και αποτρεπτική, αλλά είναι τυπικά επιτρεπτη;
Ευχαριστώ

petrosp13:
Απαγορεύεται να αλλάζει η τιμή οποιασδήποτε παραμέτρου της επανάληψης εντός της επανάληψης
Είτε η μεταβλητή, είτε η αρχική τιμή, είτε η τελική τιμή, είτε το βήμα
Αν θέλει να το κάνει αυτό, καταλαβαίνει ότι θέλει να σταματήσει την επανάληψη της πρόωρα, άρα οδηγείται υποχρεωτικά σε μια από τις άλλες δυο δομές

danaos75:
Επειδή με ενδιαφέρει άμεσα το θέμα γιατί έχω μαθητή που επιμένει να σταματάει τις επαναλήψεις των Για είτε αλλάζοντας το i είτε αλλάζοντας το k στο παραπάνω παράδειγμα και η αλήθεια είναι ότι δεν βρήκα πουθενά να αναφέρεται στο βιβλίο ότι απαγορεύεται κάτι τέτοιο.  petrosp13 που ακριβώς το στηρίζεις αυτό που λες;

Νίκος Αδαμόπουλος:

--- Παράθεση από: danaos75 στις 13 Απρ 2014, 09:17:22 μμ ---Επειδή με ενδιαφέρει άμεσα το θέμα γιατί έχω μαθητή που επιμένει να σταματάει τις επαναλήψεις των Για είτε αλλάζοντας το i είτε αλλάζοντας το k στο παραπάνω παράδειγμα και η αλήθεια είναι ότι δεν βρήκα πουθενά να αναφέρεται στο βιβλίο ότι απαγορεύεται κάτι τέτοιο.  petrosp13 που ακριβώς το στηρίζεις αυτό που λες;


--- Τέλος παράθεσης ---

http://dide.ilei.sch.gr/keplinet/education/docs/aepp_yp_2010.pdf

danaos75:
φίλε Νίκο σε ευχαριστώ  :),

τον διάβασα τον σύνδεσμο που αναφέρεις χθές το βράδυ σε άλλο θέμα στο forum και ξέχασα να το αναφέρω εδώ.
Νομίζω πως δεν αφήνει αμφιβολία για το τι πρέπει να κάνουν οι μαθητές στις εξετάσεις.

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση