Γενικό Λύκειο > Εντολή ΟΣΟ...ΕΠΑΝΑΛΑ

ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ

(1/2) > >>

petros93:
Γεια σας.
Η καθηγήτριά μας, μας έβαλε σε διαγώνισμα την εξής άσκηση:

Να διαβάζετε το πολύ 10 αριθμούς και να υπολογίζετε-εμφανίζετε το πλήθος, το άθροισμα και το μέσο όρο τους. Επίσης η επανάληψη τερματίζεται όταν θα διαβαστεί ο αριθμός 0 (μηδέν).

Θα ήθελα την γνώμη σας αν την έκανα σωστά ή όχι (αν όχι τι λάθος έκανα?). Ακολουθεί η λύση την οποία έδωσα:

σ<- 0
ι<- 0
διάβασε χ
όσο (ι<10) και (χ<>0) επανάλαβε
   σ<- σ+χ
   ι<- ι+1
   διάβασε χ
τέλος_επανάληψης
μο<- σ/ι
εμφάνισε ι, σ, μο



 
Ευχαριστώ...

papet:
Προτού προχωρήσεις σε διαίρεση με το πλήθος των αριθμών, θα μπορούσες να σιγουρευτείς ότι δεν δόθηκε ως πρώτος αριθμός το 0.

petrosp13:
Υπάρχει ένα μικρό προβληματάκι στο ότι όταν φτάσει το ι στο 10, θα διαβάσει και ενδέκατο βαθμό και μετά θα σταματήσει

petros93:
Δηλαδή papet έπρεπε να γίνει κάπως έτσι ?

σ<- 0
ι<- 0
διάβασε χ
όσο (ι<10) και (χ<>0) επανάλαβε
   σ<- σ+χ
   ι<- ι+1
   διάβασε χ
τέλος_επανάληψης
Αν ι<>0 τότε
μο<- σ/ι
εμφάνισε ι, σ, μο
τέλος_αν

petros13 το προβληματάκι που ανάφερεις πως λύνεται ??

petrosp13:
Βάλε ένα "Αν" μέσα στην επανάληψη
Αν ι <10 τότε
Διάβασε χ

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση