Γενικό Λύκειο > Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ

Υπολογισμός Μέσου Όρου άγνωστου πλήθους αριθμών

(1/1)

Blahadoni Despoina:
Ασκηση
Να γραφει Αλγοριθμος που θα διαβαζει Θερμοκρασιες που δινονται απο πληκτρολογιο και θα δινει τον Μεσο ορο (Στο τελος της ακολουθειας των αριθμων θα δινεται μεταβλητη της επιλογης σας .

Μπορειται να με βοηθησετε σας παρακαλω να καταλαβω πως θα αναπτυξω αυτον τον Αλγοριθμο.
Σας ευχαριστω πολυ. :)

Sergio:
Δέσποινα, διέγραψα το μήνυμά σου από το θέμα που το έβαλες και άνοιξα καινούργιο θέμα με τον κατάλληλο τίτλο.

Η ερώτησή σου δεν έχει σχέση με το θέμα που την καταχώρησες, αφού εκείνο αφορά σε προβληματισμούς σχετικά με την εντολή επίλεξε ενώ η δική σου ερώτηση στην υλοποίηση του μηχανισμού για υπολογισμό του μέσου όρου άγνωστου πλήθους αριθμών.

Άρης Βερνάρδος:
Θα το θέσω με λίγο καλύτερη διατύπωση:
Να γραφεί αλγόριθμος που να διαβάζει άγνωστο πλήθος θερμοκρασιών και να υπολογίζει και να εμφανίζει το μέσο όρο τους. Η εισαγωγή των στοιχείων να σταματάει μόλις δοθεί μία συγκεκριμένη τιμή (την οποία καλείστε να επιλέξετε).
Σε τέτοιες περιπτώσεις επιλέγουμε μία τιμή η οποία να μην είναι σωστή για το πρόβλημα. Π.χ. εδώ που έχουμε να κάνουμε με θερμοκρασίες θα μπορούσαμε να επιλέξουμε την τιμή -999. Σ' αυτά τα προβλήματα, η τιμή αυτή ονομάζεται συχνά και "τιμή φρουρός" (σχ. βιβλίο, σελ. 175). Ακολουθεί η λύση:

Αλγόριθμος Θερμοκρασίες
Sum <-- 0
Π <-- 0
Διάβασε Θ
Όσο Θ <> -999 επανάλαβε
        Π <-- Π + 1
        Sum <-- Sum + Θ
        Διάβασε Θ
Τέλος_επανάληψης
!Εξασφάλιση καθοριστικότητας αλγορίθμου
Αν Π > 0 τότε
        ΜΟ <-- Sum / Π
        εμφάνισε ΜΟ
αλλιώς
        εμφάνισε "Δεν δώσατε θερμοκρασίες!"
Τέλος_αν
Τέλος Θερμοκρασίες

Εύχομαι να σε βοήθησα.

P.Tsiotakis:
Σε όσα έγραψε ο φίλος μου Άρης, θα παραθέσω την επίλυση και με τη χρήση της δομής επανάληψης Μέχρις_ότου:

Αλγόριθμος Θερμοκρασίες_αλλιώς
Sum <-- 0
Π <-- 0
Αρχή_επανάληψης
 Διάβασε Θ
 Αν Θ <> -999 τότε
   Π <-- Π + 1
   Sum <-- Sum + Θ
 Τέλος_αν
Μέχρις_ότου Θ = -999
Αν Π <> 0 τότε  ! καθοριστικότητα
 ΜΟ <-- Sum / Π
 Εμφάνισε ΜΟ
Αλλιώς
 Εμφάνισε "Δεν δώσατε θερμοκρασίες!"
Τέλος_αν
Τέλος Θερμοκρασίες_αλλιώς

Όπου η δομή επιλογής εντός του βρόχου χρειάζεται γιατί δεν επιθυμούμε να επεξεργαστούμε την τιμή "φρουρό". Όμως, παρατηρούμε οτι αυτή η δομή επιλογής περιλαμβάνεται στην πρώτη υλοποίηση στην δομή Όσο!!

Άρα, το συμπέρασμα είναι πως η δομή Όσο είναι ισχυρότερη δομή επανάληψης.

Με εκτίμηση,

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση