Αποστολέας Θέμα: ΟΕΦΕ 2014  (Αναγνώστηκε 9638 φορές)

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 570
  • There can be only one...may it be AEPP.
Απ: ΟΕΦΕ 2014
« Απάντηση #30 στις: 16 Μαΐ 2014, 10:51:57 μμ »
Δεν έχω δεί ακόμα τις προτεινόμενες λύσεις των θεμάτων, αλλά αυτή είναι η δική μου άποψη για την Διαδικασία ΚΡΑΤΗΣΗ στο Θέμα Δ, το οποίο και θεωρώ το πιό δύσκολο κομμάτι σε όλο το διαγώνισμα.
Κώδικας: [Επιλογή]
ΔΙΑΔΙΚΑΣΙΑ ΚΡΑΤΗΣΗ(ΠΛ, ΓΡ, ΣΤ, Θ, ΕΓΙΝΕ_ΚΡΑΤΗΣΗ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΠΛ, ΓΡ, ΣΤ, Ι, Ξ
  ΧΑΡΑΚΤΗΡΕΣ: Θ[15, 20]
  ΛΟΓΙΚΕΣ: ΕΓΙΝΕ_ΚΡΑΤΗΣΗ, ΦΛΑΓΚ
ΑΡΧΗ
  ΕΓΙΝΕ_ΚΡΑΤΗΣΗ <- ΨΕΥΔΗΣ
  ΑΝ Θ[ΓΡ, ΣΤ] = "Δ" ΤΟΤΕ
    Ι <- 1
    ΟΣΟ Ι <= ΠΛ ΚΑΙ ΕΓΙΝΕ_ΚΡΑΤΗΣΗ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΦΛΑΓΚ <- ΨΕΥΔΗΣ
      Ξ <- ΣΤ
      ΟΣΟ Ξ <= ΣΤ + ΠΛ ΚΑΙ ΦΛΑΓΚ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
        ΑΝ Θ[ΓΡ, Ξ] = "Κ" ΤΟΤΕ
          ΦΛΑΓΚ <- ΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
        Ξ <- Ξ + 1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ ΦΛΑΓΚ = ΨΕΥΔΗΣ ΤΟΤΕ
        ΕΓΙΝΕ_ΚΡΑΤΗΣΗ <- ΑΛΗΘΗΣ
        ΓΙΑ Ξ ΑΠΟ ΣΤ ΜΕΧΡΙ ΣΤ + ΠΛ
          Θ[ΓΡ, Ξ] <- "Κ"
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ
        ΣΤ <- ΣΤ - 1
      ΤΕΛΟΣ_ΑΝ
      Ι <- Ι + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
:P
Νομίζω δουλεύει.
Δεν δουλεύει :'(
« Τελευταία τροποποίηση: 22 Μαΐ 2014, 10:33:13 μμ από nikolasmer »
Μερεντίτης Νικόλαος
Πληροφορικός

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2337
Απ: ΟΕΦΕ 2014
« Απάντηση #31 στις: 17 Μαΐ 2014, 12:05:16 πμ »
Εξωγήινο θέμα και όποιος το άγγιξε, χαρά στο κουράγιο του
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 570
  • There can be only one...may it be AEPP.
Απ: ΟΕΦΕ 2014
« Απάντηση #32 στις: 17 Μαΐ 2014, 12:11:50 πμ »
Εξωγήινο θέμα και όποιος το άγγιξε, χαρά στο κουράγιο του


Θα συμφωνήσω Πέτρο!!!
Μερεντίτης Νικόλαος
Πληροφορικός

Giorgos_fbrs

  • Νέος
  • *
  • Μηνύματα: 3
Απ: ΟΕΦΕ 2014
« Απάντηση #33 στις: 21 Μαΐ 2014, 06:38:33 μμ »
Καλησπερα...Αν μπορει και θελει καποιος ας μου στειλει τα θεματα στο παρακατω email γιατι δεν βλεπω να ανεβαινουν στο ιντερνετ πριν τις εξετασεις..

Ευχαριστω.

Geofbrs@gmail.com

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 570
  • There can be only one...may it be AEPP.
Απ: ΟΕΦΕ 2014
« Απάντηση #34 στις: 22 Μαΐ 2014, 01:38:32 πμ »
Για την ιστορία, η παραπάνω διαδικασία δεν δουλέυει γιατί, όπως ανέφερε και ο φίλος μου ο Βασίλης ο Παπαχρήστος
Καλησπέρα Νικόλα.

Δε νομίζω ότι δουλευει η λυση που παρεθεσες για τη διαδικασια στο Δ θεμα του ΟΕΦΕ.
Στη μεσα επαναληψη πρεπει να εχεις Ξ<=ΣΤ+ΠΛ-1 και επισης δεν ασχολεισαι καθολου με το γεγονος οτι μπορει να ξεπερασεις τα ορια του πινακα.

Φιλικα
Βασιλης
Το διόρθωσα λιγάκι αλλά έχω πάλι την εντύπωση ότι είναι πατάτα.
Κώδικας: [Επιλογή]
ΔΙΑΔΙΚΑΣΙΑ ΚΡΑΤΗΣΗ(ΠΛ, ΓΡ, ΣΤ, Θ, ΕΓΙΝΕ_ΚΡΑΤΗΣΗ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΠΛ, ΓΡ, ΣΤ, Ι, Ξ
  ΧΑΡΑΚΤΗΡΕΣ: Θ[15, 20]
  ΛΟΓΙΚΕΣ: ΕΓΙΝΕ_ΚΡΑΤΗΣΗ, ΦΛΑΓΚ
ΑΡΧΗ
  ΕΓΙΝΕ_ΚΡΑΤΗΣΗ <- ΨΕΥΔΗΣ
  ΑΝ Θ[ΓΡ, ΣΤ] = "Δ" ΤΟΤΕ
    Ι <- 1
    ΟΣΟ Ι <= ΠΛ ΚΑΙ ΕΓΙΝΕ_ΚΡΑΤΗΣΗ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΦΛΑΓΚ <- ΨΕΥΔΗΣ
      Ξ <- ΣΤ
      ΟΣΟ Ξ <= ΣΤ + ΠΛ - 1 ΚΑΙ ΣΤ + ΠΛ - 1 <= 20 ΚΑΙ ΣΤ > 0 ΚΑΙ ΦΛΑΓΚ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
        ΑΝ Θ[ΓΡ, Ξ] = "Κ" ΤΟΤΕ
          ΦΛΑΓΚ <- ΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
        Ξ <- Ξ + 1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ ΦΛΑΓΚ = ΨΕΥΔΗΣ ΚΑΙ ΣΤ + ΠΛ - 1 <= 20 ΚΑΙ ΣΤ > 0 ΤΟΤΕ
        ΕΓΙΝΕ_ΚΡΑΤΗΣΗ <- ΑΛΗΘΗΣ
        ΓΙΑ Ξ ΑΠΟ ΣΤ ΜΕΧΡΙ ΣΤ + ΠΛ - 1
          Θ[ΓΡ, Ξ] <- "Κ"
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ
        ΣΤ <- ΣΤ - 1
      ΤΕΛΟΣ_ΑΝ
      Ι <- Ι + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Μερεντίτης Νικόλαος
Πληροφορικός

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 69
    • Νικηφόρος Μανδηλαράς (blog)
Η ΔΙΑΔΙΚΑΣΙΑ ΣΤΟ Δ ΘΕΜΑ ΟΕΦΕ 2014
« Απάντηση #35 στις: 22 Μαΐ 2014, 10:16:49 μμ »
ΔΙΑΔΙΚΑΣΙΑ ΚΡΑΤΗΣΗ(ΕΙΣΙΤΗΡΙΑ,ΣΕΙΡΑ,ΘΕΣΗ,Θ,ΕΓΙΝΕ_ΚΡΑΤΗΣΗ)
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ:ΕΙΣΙΤΗΡΙΑ,ΣΕΙΡΑ,ΘΕΣΗ,Α,Β,Ι,Κ,Μ
 ΧΑΡΑΚΤΗΡΕΣ:Θ[15,20]
 ΛΟΓΙΚΕΣ:ΕΓΙΝΕ_ΚΡΑΤΗΣΗ,ΟΛΕΣ_ΔΙΑΘΕΣΙΜΕΣ
ΑΡΧΗ
! ΤΟ Α ΘΑ ΔΕΙΧΝΕΙ ΤΟ ΑΡΙΣΤΕΡΟ ΟΡΙΟ ΤΗΣ ΠΡΩΤΗΣ ΘΕΣΗΣ ΤΗΣ ΚΡΑΤΗΣΗΣ
ΑΝ ΘΕΣΗ-ΕΙΣΙΤΗΡΙΑ<=0 ΤΟΤΕ
 Α<-1
ΑΛΛΙΩΣ
 Α<-ΘΕΣΗ-ΕΙΣΙΤΗΡΙΑ+1
ΤΕΛΟΣ_ΑΝ
! ΤΟ Β ΘΑ ΔΕΙΧΝΕΙ ΤΟ ΔΕΞΙ ΟΡΙΟ ΤΗΣ ΠΡΩΤΗΣ ΘΕΣΗΣ ΤΗΣ ΚΡΑΤΗΣΗΣ
ΑΝ ΘΕΣΗ+ΕΙΣΙΤΗΡΙΑ>20 ΤΟΤΕ
 Β<-21-ΕΙΣΙΤΗΡΙΑ
ΑΛΛΙΩΣ
 Β<-ΘΕΣΗ
ΤΕΛΟΣ_ΑΝ
Μ<-0
ΓΙΑ Ι ΑΠΟ Α ΜΕΧΡΙ Β
 ΟΛΕΣ_ΔΙΑΘΕΣΙΜΕΣ<-ΑΛΗΘΗΣ
 ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ Ι+ΕΙΣΙΤΗΡΙΑ-1
  ΑΝ Θ[ΣΕΙΡΑ,Κ]='Κ' ΤΟΤΕ
   ΟΛΕΣ_ΔΙΑΘΕΣΙΜΕΣ<-ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ ΟΛΕΣ_ΔΙΑΘΕΣΙΜΕΣ=ΑΛΗΘΗΣ ΤΟΤΕ
  Μ<-Ι
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Μ<>0 ΤΟΤΕ
 ΕΓΙΝΕ_ΚΡΑΤΗΣΗ<-ΑΛΗΘΗΣ
 ΓΙΑ Ι ΑΠΟ Μ ΜΕΧΡΙ Μ+ΕΙΣΙΤΗΡΙΑ-1
  Θ[ΣΕΙΡΑ,Ι]<-'Κ'
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΛΛΙΩΣ
 ΕΓΙΝΕ_ΚΡΑΤΗΣΗ<-ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Νικηφόρος Μανδηλαράς
ΓΕΛ Νάξου
https://eclass03.sch.gr/courses/D21100/

Giorgos_fbrs

  • Νέος
  • *
  • Μηνύματα: 3
Απ: ΟΕΦΕ 2014
« Απάντηση #36 στις: 23 Μαΐ 2014, 10:29:22 μμ »
Καλησπερα! Μπορει αν δεν βαριεται κανεις να μου πει αν η παρακατω λυση ειναι σωστη για την ΔΙΑΔΙΚΑΣΙΑ?
Να διευκρινισω οτι δεν εχω λαβει την περιπτωση (και δεν ξερω αν χρειαζεται) οπου ο χρηστης πχ ζηταει 6 θεσεις και θελει να ξεκινανε απο την 18η θεση αρα αναγκαστικα θα πρεπει να καλυφτουν προς τα πισω...

(Επισης ειμαι μαθητης της Γ Λυκειου)




ΔΙΑΔΙΚΑΣΙΑ ΚΡΑΤΗΣΗ( ΠΛΘ, ΣΕΙΡΑ, Α, ΕΓΙΝΕ_ΚΡΑΤΗΣΗ)
.
.
.


ΑΡΧΗ
ΕΓΙΝΕ_ΚΡΑΤΗΣΗ<-- ΑΛΗΘΗΣ
ΥΠΑΡΧΟΥΝ<--ΑΛΗΘΗΣ
i<--A
ΟΣΟ i<= ΠΛΘ+Α   ΚΑΙ  ΥΠΑΡΧΟΥΝ=ΑΛΗΘΗΣ ΕΠΑΝΑΛΑΒΕ
   ΑΝ Θ[ΣΕΙΡΑ, i] = "Κ" ΤΟΤΕ
      ΥΠΑΡΧΟΥΝ<-- ΨΕΥΔΗΣ
     ΘΕΣΗ_ΚΑΤΗΛ<-- i
      ΚΑΛΗΦΘΥΚΑΝ<-- ΘΕΣΗ_ΚΑΤΗΛ - Α
   ΤΕΛΟΣ_ΑΝ
   i<-- i + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΟΧΙ(ΥΠΑΡΧΟΥΝ) ΤΟΤΕ
   ΓΙΑ Κ ΑΠΟ (Α-1) ΜΕΧΡΙ (Α-1+ΚΑΛΗΦΘΥΚΑΝ-ΠΛΘ) ΜΕ_ΒΗΜΑ -1
      ΑΝ Θ[ΣΕΙΡΑ, Κ] = "Κ" ΤΟΤΕ
         ΕΓΙΝΕ_ΚΡΑΤΗΣΗ<-- ΨΕΥΔΗΣ
      ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΑΝ
ΑΝ ΥΠΑΡΧΟΥΝ ΤΟΤΕ
   ΓΙΑ Κ ΑΠΟ Α ΜΕΧΡΙ Α+ΠΛΘ
      Θ[ΣΕΙΡΑ, Κ]<-- "Κ"
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΛΛΙΩΣ
   ΑΝ ΕΓΙΝΕ_ΚΡΑΤΗΣΗ= ΑΛΗΘΗΣ ΤΟΤΕ
      ΓΙΑ Κ ΑΠΟ Α ΜΕΧΡΙ (ΘΕΣΗ_ΚΑΤΗΛ-1)
         Θ[ΣΕΙΡΑ, Κ] <-- "Κ"
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ Κ ΑΠΟ (Α-1) ΜΕΧΡΙ (Α-1+ΚΑΛΗΦΘΥΚΑΝ-ΠΛΘ) ΜΕ_ΒΗΜΑ -1
         Θ[ΣΕΙΡΑ, Κ] <-- "Κ"
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Giorgos_fbrs

  • Νέος
  • *
  • Μηνύματα: 3
Απ: ΟΕΦΕ 2014
« Απάντηση #37 στις: 23 Μαΐ 2014, 10:33:14 μμ »
Ωχ τωρα ειδα οτι πρεπει να βαλουμε περιορισμο και για το οριο των θεσεων...αρα η παραπανω λυση πρεπει να εχει ενα μικρο ελλατωματακι  ???



« Τελευταία τροποποίηση: 24 Μαΐ 2014, 06:09:44 μμ από Giorgos_fbrs »