Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γενικές εξετάσεις => Γ΄ Λυκείου => Εξετάσεις 2018-2019 => Μήνυμα ξεκίνησε από: evry στις 12 Ιουν 2019, 09:35:18 πμ

Τίτλος: Θέμα 3
Αποστολή από: evry στις 12 Ιουν 2019, 09:35:18 πμ
Εδώ σχολιάζουμε το θέμα 3
Τίτλος: Απ: Θέμα 3
Αποστολή από: progmat στις 12 Ιουν 2019, 11:07:51 πμ
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΓ_2019
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΡ_ΕΠ, ΜΑΧ, ΜΜΑΧ, ΠΛ1, ΠΛ2, ΠΛ3
  ΧΑΡΑΚΤΗΡΕΣ: ΤΙΤΛΟΣ, ΤΜΑΧ, ΚΑΤΜΑΧ

ΑΡΧΗ
  ΜΑΧ <- 0
  ΠΛ1 <- 0
  ΠΛ2 <- 0
  ΠΛ3 <- 0
  ΔΙΑΒΑΣΕ ΤΙΤΛΟΣ
  ΟΣΟ ΤΙΤΛΟΣ <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ ΑΡ_ΕΠ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΑΡ_ΕΠ > 0
    ΑΝ ΑΡ_ΕΠ > ΜΑΧ ΤΟΤΕ
      ΜΑΧ <- ΑΡ_ΕΠ
      ΤΜΑΧ <- ΤΙΤΛΟΣ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΑΡ_ΕΠ <= 100 ΤΟΤΕ
      ΠΛ1 <- ΠΛ1 + 1
    ΑΛΛΙΩΣ_ΑΝ ΑΡ_ΕΠ <= 1000 ΤΟΤΕ
      ΠΛ2 <- ΠΛ2 + 1
    ΑΛΛΙΩΣ
      ΠΛ3 <- ΠΛ3 + 1
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ ΤΙΤΛΟΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΤΟ ΒΙΝΤΕΟ ΜΕ ΤΟΝ ΜΕΓΑΛΥΤΕΡΟ ΑΡ_ΕΠ ΕΙΝΑΙ ', ΤΜΑΧ
  ΓΡΑΨΕ 'ΧΑΜΗΛΗ ΚΑΤΗΓΟΡΙΑ', ΠΛ1
  ΓΡΑΨΕ 'ΜΕΣΑΙΑ ΚΑΤΗΓΟΡΙΑ', ΠΛ2
  ΓΡΑΨΕ 'ΥΨΗΛΗ ΚΑΤΗΓΟΡΙΑ', ΠΛ3
  ΜΜΑΧ <- ΠΛ1
  ΚΑΤΜΑΧ <- 'ΧΑΜΗΛΗ'
  ΑΝ ΠΛ2 > ΜΜΑΧ ΤΟΤΕ
    ΜΑΧ <- ΠΛ2
    ΚΑΤΜΑΧ <- 'ΜΕΣΑΙΑ'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΠΛ3 > ΜΜΑΧ ΤΟΤΕ
    ΜΑΧ <- ΠΛ3
    ΚΑΤΜΑΧ <- 'ΥΨΗΛΗ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ΚΑΤΜΑΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Τίτλος: Απ: Θέμα 3
Αποστολή από: ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ στις 12 Ιουν 2019, 11:12:42 πμ
Στον ελεγχο εγκυροτητας η συνθηκη ειναι >=0 .... λεει να μην ειναι αρνητικος
Τίτλος: Απ: Θέμα 3
Αποστολή από: P.Tsiotakis στις 12 Ιουν 2019, 11:13:20 πμ
μηδενικές επισκέψεις δεν καταμετρώνται
Τίτλος: Απ: Θέμα 3
Αποστολή από: petrosp13 στις 12 Ιουν 2019, 11:35:28 πμ
Το πινακάκι έχει παγίδα, προσοχή
Τα αν πρέπει να έχουν διπλές συνθήκες και όχι Αλλιώς
Τίτλος: Απ: Θέμα 3
Αποστολή από: evry στις 12 Ιουν 2019, 11:43:16 πμ
Καλή παρατήρηση!
Εκτός αν βάλεις το πρώτο Αν..τότε να διαχειριστεί τα μηδενικά βίντεο
Το πινακάκι έχει παγίδα, προσοχή
Τα αν πρέπει να έχουν διπλές συνθήκες και όχι Αλλιώς
Τίτλος: Απ: Θέμα 3
Αποστολή από: merlin στις 12 Ιουν 2019, 11:57:19 πμ
Ή πιο απλά ξεκινάς με έλεγχο αυτών που είναι >1000 και βάζεις τετελευταίο  το Αλλιως_αν επισκ>0, χωρίς να βάλεις Αλλιώς.
Τίτλος: Απ: Θέμα 3
Αποστολή από: akouts στις 12 Ιουν 2019, 04:48:30 μμ
Δεν καταμετρώνται μεν, θα πρέπει να γίνονται δεκτές δε. Δεν θα πρέπει όποιος δώσει 0 να εξαναγκασθεί να ξαναδώσει τιμή.
μηδενικές επισκέψεις δεν καταμετρώνται
Τίτλος: Απ: Θέμα 3
Αποστολή από: Sergio στις 12 Ιουν 2019, 09:36:16 μμ
Καλή παρατήρηση!
Εκτός αν βάλεις το πρώτο Αν..τότε να διαχειριστεί τα μηδενικά βίντεο
δλδ?
Τίτλος: Απ: Θέμα 3
Αποστολή από: evry στις 12 Ιουν 2019, 10:19:10 μμ
δλδ?
Όταν κατέβεις Αθήνα για καμιά μπύρα θα σου εξηγήσω :D
Τίτλος: Απ: Θέμα 3
Αποστολή από: giannakos στις 12 Ιουν 2019, 10:20:10 μμ
Καλησπέρα και από εμένα.
Θα ήθελα να ρωτήσω το εξής:
Στο πρόγραμμα που δίνετε ως λύση, αν δοθεί την πρώτη φορά η λέξη 'ΤΕΛΟΣ' στην μεταβλητή ΤΙΤΛΟΣ, τότε δεν θα κάνει καμμία επανάληψη και η μεταβλητή ΤΜΑΧ δεν θα έχει αρχική τιμή.

Οπότε στην εντολή
ΓΡΑΨΕ 'ΤΟ ΒΙΝΤΕΟ ΜΕ ΤΟΝ ΜΕΓΑΛΥΤΕΡΟ ΑΡ_ΕΠ ΕΙΝΑΙ ', ΤΜΑΧ
υπάρχει λάθος.

Δεν θα έπρεπε μετά το διάβασε ΤΙΤΛΟΣ να υπάρχει ΤΜΑΧ <-- τίτλος ?

Ευχαριστώ
Τίτλος: Απ: Θέμα 3
Αποστολή από: pvs στις 12 Ιουν 2019, 10:25:58 μμ
Καλησπέρα και από εμένα.
Θα ήθελα να ρωτήσω το εξής:
Στο πρόγραμμα που δίνετε ως λύση, αν δοθεί την πρώτη φορά η λέξη 'ΤΕΛΟΣ' στην μεταβλητή ΤΙΤΛΟΣ, τότε δεν θα κάνει καμμία επανάληψη και η μεταβλητή ΤΜΑΧ δεν θα έχει αρχική τιμή.

Οπότε στην εντολή
ΓΡΑΨΕ 'ΤΟ ΒΙΝΤΕΟ ΜΕ ΤΟΝ ΜΕΓΑΛΥΤΕΡΟ ΑΡ_ΕΠ ΕΙΝΑΙ ', ΤΜΑΧ
υπάρχει λάθος.

Δεν θα έπρεπε μετά το διάβασε ΤΙΤΛΟΣ να υπάρχει ΤΜΑΧ <-- τίτλος ?

Ευχαριστώ
Κατά τη γνώμη μου από τη στιγμή που στο ερώτημα με την εύρεση μεγίστου αναφέρει ότι θεωρείστε ότι υπάρχει μόνο ένα αυτό σημαίνει ότι θα δοθεί τουλάχιστον μία σωστή εισαγωγή
Τίτλος: Απ: Θέμα 3
Αποστολή από: Σάκης Δημόπουλος στις 15 Ιουν 2019, 12:05:34 πμ
https://www.youtube.com/watch?v=pfyrhzNbp4U&t=6s
Τίτλος: Απ: Θέμα 3
Αποστολή από: pvs στις 16 Ιουν 2019, 10:19:12 πμ
Γ4. Να υπολογίζει για καθεμία από τις τρεις κατηγορίες επισκεψιμότητας το πλήθος των βίντεο που καταχωρίστηκαν σε αυτή.
Να εμφανίζει για κάθε κατηγορία: το όνομά της και το πλήθος των βίντεο που περιλαμβάνει. Μονάδες6

Σε ότι αφορά το ερώτημα Γ4 μαθητής μου έδωσε την παρακάτω απάντηση, δεν πήρε δηλαδή τον τελευταίο έλεγχο και έβαλε σκέτο αλλιώς με αποτέλεσμα όταν οι επισκέψεις είναι 0 να προστίθενται στη υψηλή.  Από τις 6 μονάδες θα πάρει μόνο τις 3 για την εμφάνιση των ονομάτων των κατηγορίων ή θα "τσιμπήσει" και από τον κώδικα της πολλαπλής. Πάντως αρκετοί μαθητές όπως έχω καταλάβει σε αυτό το ερώτημα έχουν φτιάξει την πολλαπλή μόνο με το δεξί όριο ΑΝ ΕΠ<=100 ΤΟΤΕ....

ΑΝ ΕΠΙΣΚΕΨΕΙΣ >= 1 ΚΑΙ ΕΠΙΣΚΕΨΕΙΣ <= 100 ΤΟΤΕ
      ΠΛ1 <- ΠΛ1 + 1
    ΑΛΛΙΩΣ_ΑΝ ΕΠΙΣΚΕΨΕΙΣ >= 101 ΚΑΙ ΕΠΙΣΚΕΨΕΙΣ <= 1000 ΤΟΤΕ
      ΠΛ2 <- ΠΛ2 + 1
    ΑΛΛΙΩΣ
      ΠΛ3 <- ΠΛ3 + 1
ΤΕΛΟΣ_ΑΝ

έξω από την επανάληψη έγραψε
ΓΡΑΨΕ 'ΧΑΜΗΛΗ', ΠΛ1
ΓΡΑΨΕ 'ΜΕΣΑΙΑ', ΠΛ2
ΓΡΑΨΕ 'ΥΨΗΛΗ', ΠΛ3
Τίτλος: Απ: Θέμα 3
Αποστολή από: petrosp13 στις 16 Ιουν 2019, 10:39:07 πμ
Εγώ θα έκοβα το πολύ  μια μονάδα