Σχολιασμός θεμάτων Ανάπτυξης Εφαρμογών με το Παλιό Σύστημα

Ξεκίνησε από evry, 24 Ιουν 2020, 10:08:06 ΠΜ

« προηγούμενο - επόμενο »

evry

Ανάπτυξη Εφαρμογών (τελευταία θέματα 2020)
ΤΕΛΟΣ ΕΠΟΧΗΣ!
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

ΔΗΜΗΤΡΗΣ Χ

Στο θεμα β1 του παλιου συστήματος, νομίζω ότι σωστο θα ειναι κατά την μετατροπή από για σε μεχρις οτου να μπει και εντολή αν
δηλαδή

διαβασε χ
αν χ< -3 τοτε
     κ<-- -3
     αρχη_επανάληψης
          γραψε κ
          κ<-- κ-1
     μεχρις_οτου κ< χ
τελος αν

διαφορετικα θα κανει απειρες επαναλήψεις ενώ η για δεν εκτελείται
βεβαια ισως να  θεωρείται σωστο και χωρις αυτό αλλα νομιζω πως χρειαζεται

andreas_p

Διάβασε χ
κ <-  -3 ! η εντολή αυτή θα εκτελεστεί ΣΙΓΟΥΡΑ
Αν κ >= χ  τότε
      Αρχή_επανάληψης
          Γραψε κ
          κ <- κ-1
     Μεχρις_οτου κ< χ
Τελος_αν

ΔΗΜΗΤΡΗΣ Χ


giannakos

Καλησπέρα σας.
Θα ήθελα να ρωτήσω για το ερώτημα Α4.
Ένας μαθητής μου, στην μετατροπή της πολλαπλής επιλογής σε απλές έγραψε:
ΑΝ χ <= 1 ΤΟΤΕ
        α <-- 1
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 1 ΤΟΤΕ
        α <-- 2
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 10 ΤΟΤΕ
        α <-- 3
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 100 ΤΟΤΕ
        α <-- 4
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ α

Σίγουρα δεν εκτελούνται οι ίδιες εντολές με το δοσμένο τμήμα προγράμματος, όμως εμφανίζονται οι ίδιες τιμές.
Θα χάσει μονάδες?


ApoAntonis

τα προτελευταία, τα τελευταία θα είναι των επαναληπτικών  >:D

P.Tsiotakis

Επαναληπτικές παλαιό ημερήσια
Επαναληπτικές παλαιό εσπερινά
Επαναληπτικές παλαιό ομογενείς
:D

και special εμφάνιση στο Doctor Strange in the Multiverse of Madness

Sergio

Τείνει να γίνει συνήθεια, κάθε χρονιά Ολυμπιακών Αγώνων, να έχουμε και δύο (τουλάχιστον) σετ θεμάτων (Παλιό - Νέο).  Φέτος Ολυμπιακούς δεν έχουμε αλλά η παράδοση συνεχίστηκε :)  Υπομονή τώρα μέχρι το 2024 !!  >:D
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

P.Tsiotakis

Παράθεση από: giannakos στις 24 Ιουν 2020, 06:32:56 ΜΜ
Καλησπέρα σας.
Θα ήθελα να ρωτήσω για το ερώτημα Α4.
Ένας μαθητής μου, στην μετατροπή της πολλαπλής επιλογής σε απλές έγραψε:
ΑΝ χ <= 1 ΤΟΤΕ
        α <-- 1
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 1 ΤΟΤΕ
        α <-- 2
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 10 ΤΟΤΕ
        α <-- 3
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 100 ΤΟΤΕ
        α <-- 4
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ α

Σίγουρα δεν εκτελούνται οι ίδιες εντολές με το δοσμένο τμήμα προγράμματος, όμως εμφανίζονται οι ίδιες τιμές.
Θα χάσει μονάδες?


Θεωρώ πως δεν πρέπει να χάσει μονάδες. Η μαγεία του μαθήματος.

bagelis


gthal

Παράθεση από: P.Tsiotakis στις 25 Ιουν 2020, 10:44:21 ΠΜ
Θεωρώ πως δεν πρέπει να χάσει μονάδες. Η μαγεία του μαθήματος.
Βέβαια δεν πρέπει να χάσει μονάδες.
Παναγιώτη, επειδή δε βρίσκω το μήνυμα που έλεγες τι θα έβαζες αν ήσουν στην ΚΕΕ, σου απαντώ εδώ ότι μου άνοιξες την όρεξη   :laugh:
Αν μπορούμε να ψηφίσουμε τα μέλη της ΚΕΕ, έχεις μια ψήφο από μένα  ;D
Φιλικά,
Γιώργος Θαλασσινός

Vangelis

Ο Παναγιώτης δεν γίνεται να πάει για θεματοδότης λόγω του βοηθήματος που έχει γράψει. Διαφορετικά θα ήταν μόνιμος!

akalest0s

Παράθεση από: giannakos στις 24 Ιουν 2020, 06:32:56 ΜΜΈνας μαθητής μου, στην μετατροπή της πολλαπλής επιλογής σε απλές έγραψε:
ΑΝ χ <= 1 ΤΟΤΕ
        α <-- 1
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 1 ΤΟΤΕ
        α <-- 2
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 10 ΤΟΤΕ
        α <-- 3
ΤΕΛΟΣ_ΑΝ
ΑΝ χ > 100 ΤΟΤΕ
        α <-- 4
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ α

Σίγουρα δεν εκτελούνται οι ίδιες εντολές με το δοσμένο τμήμα προγράμματος, όμως εμφανίζονται οι ίδιες τιμές.
Θα χάσει μονάδες?
Τι σκέφτηκε ο μπαγάσας! Γιατί να κοπούν μονάδες; Μια χαρά legit που λένε σήμερα..
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK