Γενικό Λύκειο > Γενικές εξετάσεις

Άσκηση στο τετράδιο μαθητή!

(1/3) > >>

maria.k.:
Σήμερα έπεσε στο μάτι μου η δραστηριότητα ΔΤ1 από το
κεφάλαιο 6  (σελίδα 58)του τετραδίου μαθητή.
Στην άσκηση αυτή μετατρέπεται ενα τμήμα αλγορίθμου με GOTO σε
αντίστοιχο τμήμα δομημένου προγραμματισμού...

Μια λύση που σκέφτομαι είναι η εξής:

ΟΣΟ συνθήκη 1 και ΟΧΙ (συνθήκη 3) ΕΠΑΝΑΛΑΒΕ
      ΕΝΤΟΛΗ 2
      ΕΝΤΟΛΗ 5
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΕΝΤΟΛΗ 4


Αλλά όσο την κοιτάω, τόσο λάθος μου φαίνεται...
Γιατί η ΕΝΤΟΛΗ 2 πρέπει να εκτελείται μόνο στην περίπτωση που ισχύει η συνθήκη 2, ανεξάρτητα από το
αν ισχύει η συνθήκη 3....
Αλλά... δεν μου έρχεται κάποια λύση στο μυαλό....
Μήπως μπορεί κανείς να βοηθήσει???

maria.k.:
Για να γίνω πιο σαφής αναρτώ και την εκφώνηση:

ΑΡΧΗ
   ΟΣΟ συνθήκη 1 ΕΠΑΝΑΛΑΒΕ
       ΕΝΤΟΛΗ 2
      ΑΝ  συνθήκη 3 ΤΟΤΕ
         ΕΝΤΟΛΗ 4
         ΠΗΓΑΙΝΕ ΣΤΟ ΤΕΛΟΣ   ! Σημείο 1
      ΑΛΛΙΩΣ
         ΕΝΤΟΛΗ 5
      ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ


Και μόλις τώρα βρήκα το παρακάτω .pdf που προτείνει σαν λύση την ακόλουθη:

1) Στο σημείο 1 απλά να γίνεται η συνθήκη 1 ψευδής!!!

Όμως τότε δεν πηγαίνει στο ΤΕΛΟΣ!!!!!!!!!!!!!!!
Πηγαίνει ξανά στην ΟΣΟ, όπου η αντίστοιχη συνθήκη είναι ψευδής και τότε πηγαίνει στο ΤΕΛΟΣ!!!!!!!!!!!!

Άσκηση "ταμάμ" για τις φετινές εξετάσεις!!!!!!!!!!!!!!!!

maria.k.:
Το .pdf που βρήκα είναι:


http://users.hol.gr/~ddriggas/Lyseis.pdf

gpapargi:
Αν και θεωρώ εντελώς άστοχο ένα τέτοιο θέμα (και είχε προκαλέσει σαματά όταν είχε πέσει), ο κώδικας είναι φτυστός η σειριακή αναζήτηση που έχει το βιβλίο. Δες από εκεί την ιδέα και παίξε με τη λογική μεταβλητή.

Stefevan:
gpapargi εννοείς την άσκηση με τα βήματα που ήταν το παράδειγμα στο πλαίσιο με την goto στο σχολικό??

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση