Αποστολέας Θέμα: Ερώτηση για Σ Λ  (Αναγνώστηκε 2927 φορές)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2372
Απ: Ερώτηση για Σ Λ
« Απάντηση #45 στις: 21 Απρ 2021, 09:32:46 πμ »
Σε αυτή την περίπτωση που έδωσες, θα εκτελεστούν και οι δυο δομές απλής επιλογής ενώ δεν θα έπρεπε
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 882
Απ: Ερώτηση για Σ Λ
« Απάντηση #46 στις: 21 Απρ 2021, 10:20:16 πμ »
Ίσα ίσα η συνθήκη ελέγχεται μόνο μία φορά στην αρχή. Δεν τροποποιείται μετά ότι και να περιέχεται μέσα στο σώμα της ΑΝ είτε στο αληθής είτε στο ψευδής.
Κώδικας: [Επιλογή]
Α <- 1
ΑΝ Α>0 ΤΟΤΕ
   Α <- Α-2
ΑΛΛΙΩΣ
   Α <- Α+1
ΤΕΛΟΣ_ΑΝ
Προφανώς στη συνθήκη το Α λογίζεται ως 1 άσχετα αν μετά θα πάρει την τιμή -1 (που προφανώς επειδή δεν θα είναι >0 ΔΕΝ θα εκτελεστεί η ΑΛΛΙΩΣ).
Ίσως δεν κατάλαβα τι ακριβώς θες να πεις.

καλημέρα .. και εγώ νομίζω πως θα εκτελεστούν και οι δύο δομές απλής επιλογής αν ειναι τη μορφής
Α <- 1
ΑΝ Α>0 ΤΟΤΕ
   Α <- Α-2
ΤΕΛΟΣ_ΑΝ
ΑΝ Α<=0 ΤΟΤΕ
   Α <- Α+1
ΤΕΛΟΣ_ΑΝ

ΕΓΩ ΘΑ ΕΓΡΑΦΑ ΤΟ ΑΚΟΛΟΥΘΟ

ΕΛΕΓΧΟΣ<--ΑΛΗΘΗΣ
Α<--1
ΑΝ Α>0 ΤΟΤΕ
    Α<--Α-2
    ΕΛΕΓΧΟΣ<--ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
ΑΝ Α<=0 ΚΑΙ ΕΛΕΓΧΟΣ=ΑΛΗΘΗΣ ΤΟΤΕ
    Α<--Α+1
ΤΕΛΟΣ_ΑΝ

Η ΤΟ ΑΚΟΛΟΥΘΟ

Α<--1
ΤΕΜΡ<--Α
ΑΝ ΤΕΜΡ>0 ΤΟΤΕ
   Α<--Α-2
ΤΕΛΟΣ_ΑΝ
ΑΝ ΤΕΜΡ<=0 ΤΟΤΕ
   Α<--Α+1
ΤΕΛΟΣ_ΑΝ

ssimaiof

  • Πληροφορικοί Δυτικής Μακεδονίας
  • *
  • Μηνύματα: 37
Απ: Ερώτηση για Σ Λ
« Απάντηση #47 στις: 21 Απρ 2021, 11:19:44 πμ »
Το μήνυμά μου δεν είναι ξεκομμένο από το προηγούμενο. Αν δείτε το αρχικό μου μήνυμα για την τυποποίηση το έχω ξεκάθαρα :
Κώδικας: [Επιλογή]
Τ <- Συνθήκη
ΑΝ Τ ΤΟΤΕ
  Εντολές_Α
ΤΕΛΟΣ_ΑΝ
ΑΝ ΟΧΙ Τ ΤΟΤΕ
  Εντολές_Ψ
ΤΕΛΟΣ_ΑΝ
Οπότε προφανώς και γίνεται :
Κώδικας: [Επιλογή]
Α <- 1
Τ <- Α>0
ΑΝ Τ ΤΟΤΕ
   Α <- Α-2
ΤΕΛΟΣ_ΑΝ
ΑΝ ΟΧΙ Τ ΤΟΤΕ
   Α <- Α+1
ΤΕΛΟΣ_ΑΝ
Γιατί θα εκτελεστούν και τα δύο ;
Σταύρος Σημαιοφορίδης