Αποστολέας Θέμα: ΜΕΤΑΤΡΟΠΗ ΜΕΧΡΙΣ_ΟΤΟΥ ΣΕ ΓΙΑ - ΕΡΩΤΗΣΗ  (Αναγνώστηκε 2632 φορές)

demy8

  • Θαμώνας
  • ***
  • Μηνύματα: 35
ΜΕΤΑΤΡΟΠΗ ΜΕΧΡΙΣ_ΟΤΟΥ ΣΕ ΓΙΑ - ΕΡΩΤΗΣΗ
« στις: 17 Νοε 2013, 02:15:20 μμ »
Γεια σας ήθελα να ρωτήσω για 2 ασκήσεις αν είναι δυνατή η μετατροπή τους σε για.
α.   α ← 0
       i ← 1
      Αρχή_επανάληψης
           α ← α + i ^ 2
           i ← i + 2
      Μέχρις_ότου i div 7 > 5
      Εμφάνισε α
 
β. Διάβασε Χ
  α ← 30
  Αρχή_επανάληψης
    α ← α + α div 6
    Εμφάνισε α
  Μέχρις_ότου (α > Χ)

οι λύσεις που σκέφτηκα είναι οι εξής:
α.
α←0
Για ι από 1 μέχρι 42 με_βήμα 2
     α←α+ι^2
Τέλος_επανάληψης
Εμφάνισε α

β.
Διάβασε χ
α←30
κ ← α + α div 6
Για α από κ μέχρι χ + α div 6 με_βήμα α div 6
     Εμφάνισε α
Τέλος_επανάληψης

Στο διερμηνευτή δουλεύουν και βγάζουν τα ίδια αποτελέσματα με τις αρχικές, αλλά δεν είμαι σίγουρη οτι είναι αποδεκτές...
Για την πρώτη έχω δει ως λύση οτι δεν γίνεται, αλλά είναι γνωστή η τελική τιμή δεν καταλαβαίνω γιατί να μην γίνεται.
Για την δεύτερη με προβληματίζει το γεγονός οτι το βήμα δεν είναι σταθερό..

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 571
  • There can be only one...may it be AEPP.
Απ: ΜΕΤΑΤΡΟΠΗ ΜΕΧΡΙΣ_ΟΤΟΥ ΣΕ ΓΙΑ - ΕΡΩΤΗΣΗ
« Απάντηση #1 στις: 17 Νοε 2013, 06:25:49 μμ »
Οι απαντήσεις που δίνεις θεωρώ πως είναι ολόσωστες. Το πρώτο παίζει κανονικότατα. Το δεύτερο, έχεις δίκαιο έχει μεταβαλλόμενο βήμα οπότε σύμφωνα με τη φιλοσοφία του μαθήματος δεν ισχύει. Άρα η δεύτερη επανάληψη δεν δύναται να μετατραπεί σε Για (Αν και στο Διερμηνευτή τρέχει και παράγονται αποτελέσματα).
Μερεντίτης Νικόλαος
Πληροφορικός

demy8

  • Θαμώνας
  • ***
  • Μηνύματα: 35
Απ: ΜΕΤΑΤΡΟΠΗ ΜΕΧΡΙΣ_ΟΤΟΥ ΣΕ ΓΙΑ - ΕΡΩΤΗΣΗ
« Απάντηση #2 στις: 18 Νοε 2013, 09:35:08 πμ »

Αρα στα παιδιά να πω οτι  και το δεύτερο μπορεί να μετατραπεί σε για, αλλά στα πλαίσια του συγκεκριμένου μαθήματος επειδή το βήμα δεν είναι σταθερό λέμε  οτι δε γίνεται;

ευχαριστώ πολύ για την απάντηση.

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 882
Απ: ΜΕΤΑΤΡΟΠΗ ΜΕΧΡΙΣ_ΟΤΟΥ ΣΕ ΓΙΑ - ΕΡΩΤΗΣΗ
« Απάντηση #3 στις: 18 Νοε 2013, 11:37:21 πμ »
Καλημέρα... αυτές τις απορίες τις είχα και εγώ (αν δεν κάνω λάθος είναι από το βοήθημα του αγαπητού συναδέλφου Παναγιώτη Τσιωτάκη)...πάντως και στην πρώτη περίπτωση, η τελική τιμή μεταβάλλεται σε κάθε επανάληψη, απλά εμείς μπορούμε να βρούμε  πότε σταματάει η επανάληψη... οπότε ίσως και αυτό μήπως στα πλαίσια του μαθήματος δεν είναι επιτρεπτό ?? γενικά αρχική/τελική τιμή και βήμα δεν πρέπει να είναι σταθερά ?? ...ευχαριστώ

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: ΜΕΤΑΤΡΟΠΗ ΜΕΧΡΙΣ_ΟΤΟΥ ΣΕ ΓΙΑ - ΕΡΩΤΗΣΗ
« Απάντηση #4 στις: 18 Νοε 2013, 04:01:48 μμ »
ο σκοπός των ασκήσεων αυτών είναι να πούμε στους μαθητές πως αν πρέπει να τρέξουμε τον αλγόριθμο για να δούμε πλήθος επαναλήψεων τότε μάλλον ο βρόχος με Όσο/Μέχρις_ότου δεν είχε σχεδιαστεί για τη δομή ΓΙΑ
διαφορετικά είναι κουιζ...

το δεύτερο όμως όπως επισημάνθηκε, αλλάζει το μετρητή του Για, οπότε απορρίπτεται εκ προιμίου

demy8

  • Θαμώνας
  • ***
  • Μηνύματα: 35
Απ: ΜΕΤΑΤΡΟΠΗ ΜΕΧΡΙΣ_ΟΤΟΥ ΣΕ ΓΙΑ - ΕΡΩΤΗΣΗ
« Απάντηση #5 στις: 19 Νοε 2013, 09:45:56 πμ »
σας ευχαριστώ πολύ!!

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 882
Απ: ΜΕΤΑΤΡΟΠΗ ΜΕΧΡΙΣ_ΟΤΟΥ ΣΕ ΓΙΑ - ΕΡΩΤΗΣΗ
« Απάντηση #6 στις: 09 Δεκ 2013, 08:50:22 μμ »
Να ρωτήσω και εγώ μία παρόμοια μετατροπή (από το βοήθημα του Παναγιώτη)

Διάβασε λ
Όσο λ<=8 επανάλαβε
      Εμφάνισε λ
      λ<--λ+2
Τέλος_επανάληψης

μπορούμε να το μετατρέψουμε σε Για??

Διάβασε λ
Για ι από λ μέχρι 8 με_βήμα 2
        Εμφάνισε ι 
Τέλος_επανάληψης

μπορούμε να κάνουμε αυτή τη μετατροπή ?? στο για μπορούμε αν δεν κάνω λάθος να έχουμε μεταβλητή σε αρχική,τελική τιμή, βήμα, αρκεί να μην μεταβάλλονται στο εσωτερικό της για

ευχαριστώ