Αποστολέας Θέμα: ΑΠΟΡΙΕΣ!  (Αναγνώστηκε 4290 φορές)

aleremain

  • Θαμώνας
  • ***
  • Μηνύματα: 28
ΑΠΟΡΙΕΣ!
« στις: 14 Ιαν 2008, 05:57:28 μμ »
Eχω απορια 2 ασκησεις και ψαχνω ενα πραγμα για θεωρια

1)
Να γραφει αλγοριθμος ο οποιος θα διαβαζει το ονομα και το βαθμο ενος αγνωστου πληθους αριθμο μαθητων, στην συνεχεια θα υπολογιζει το ονομα με το μεγαλυτερο βαθμο και το πληθος των μαθητων που εχουν βα8μο μικροτερο του 9,5 , το μεσο ορο των βαθμων ολων των μαθητων.Ο αλγοριθμος οταν θα τερματιζει οταν θα δοθει σαν εισοδος αρνητικος ή μηδεν!


2)

Ι<---1
Σ<--0
ΟΣΟ Ι<=10 ΚΑΙ Σ<=1000
ΔΙΑΒΑΣΕ Χ
Σ<--Σ+Χ
Ι<---Ι+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Μεχρι ποτε το προγραμμα θα εκτελειται?


3)Υπαρχει καμια λυμενη ασκηση για μετατροπες εμφολευμενες δομες επαναληψης ΑΠΟ ΣΕ ΟΣΟ, ΑΠΟ ΣΕ ΜΕΧΡΙ κτλ?

πχ κατι τετοιο

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3
  ΓΙΑ J AΠΟ 1 ΜΕΧΡΙ 3
    ΓΡΑΨΕ Ι,J   B) '*'
 TEΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΥΤΗ ΣΕ ΟΣΟ!


Ευχαριστω πολυ!


P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: ΑΠΟΡΙΕΣ!
« Απάντηση #1 στις: 14 Ιαν 2008, 08:21:26 μμ »
για το 1
Αλγόριθμος μελέτη
  μ ← 0
  όλοι ← 0
  Σ ← 0
  Διάβασε β
  μεγ ← β  ! ή  -1
  Όσο β > 0 επανάλαβε
    Διάβασε ον
    Αν (β < 9.5) τότε
       μ ← μ + 1
    Τέλος_αν
    Αν (β > μεγ) τότε
       μεγ ← β
       ονμεγ ← ον
    Τέλος_αν
    Σ ← Σ + β
    όλοι ← όλοι + 1
    Διάβασε β
  Τέλος_επανάληψης
  Εκτύπωσε ονμεγ, μ
  Αν όλοι <> 0 τότε
    μο ← Σ / όλοι
    Εκτύπωσε μο
  Τέλος_αν
Τέλος μελέτη


για το 2
"μέχρι να δοθούν 10 αριθμοί ή το άθροισμά τους να ξεπερνά την τιμή 1000"
αυτό ζητάει;

για το 3
θέμα 1Ε:
http://users.kor.sch.gr/ptsiotakis/aepp/aepp_panel_epanesp_2005.htm

aleremain

  • Θαμώνας
  • ***
  • Μηνύματα: 28
Απ: ΑΠΟΡΙΕΣ!
« Απάντηση #2 στις: 14 Ιαν 2008, 11:43:50 μμ »
για το 2 ναι αυτο ζηταει!