Αποστολέας Θέμα: Θέμα 1 γ  (Αναγνώστηκε 9640 φορές)

panosz

  • Θαμώνας
  • ***
  • Μηνύματα: 30
  • Γράψτε το προσωπικό σας σλόγκαν!
Θέμα 1 γ
« στις: 31 Μάι 2007, 04:52:36 μμ »
Καλησπέρα,
Μαθητής μου αντί για δομή πολλαπλής επιλογής, δημιουργησε εμφωλευμένη δομή επιλογή.
Σωστό ή λάθος ??

Ευχαριστώ για το χρόνο σας
Panos

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #1 στις: 31 Μάι 2007, 04:55:42 μμ »
rikse kwdika

fragile

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 66
  • ΑΔΡΑΞΤΕ ΤΗΝ ΗΜΕΡΑ
Απ: Θέμα 1 γ
« Απάντηση #2 στις: 31 Μάι 2007, 04:56:52 μμ »
Πιστεύω ότι είναι λάθος

Π.Χ.

Αν (Α>0).
   Αν (Α=0).
 
   Τέλος-Αν
Τέλος_Αν

Αν έκανε αυτό τότε είναι σίγουρα ΛΑΘΟΣ.....

Στείλε την δομή αν δεν είναι αυτή ώστε να το συζητήσουμε
fragile..........

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #3 στις: 31 Μάι 2007, 04:58:55 μμ »
Αν α>0 τότε
 αν α<0

lol lathos einai tyflwthika xaxaxa
afou an einai a>0 den tha mpei na elegksei to a<0..

nai an einai etsi einai lathos..

dwse kwdika

apapag

  • Θαμώνας
  • ***
  • Μηνύματα: 29
Απ: Θέμα 1 γ
« Απάντηση #4 στις: 31 Μάι 2007, 05:07:12 μμ »
@panag_z

Θεωρώ ότι μπορεί να γραφτεί ισοδύναμα και με εμφωλευμένα ΑΝ αρκεί αυτά να ακολουθούν την ίδια λογική αλληλουχία των ελέγχων της τιμής του Α με αυτή που δίνεται.
Δηλαδή:
ΑΝ Α>0 ΤΟΤΕ
Νάσια Παπαγιάννη
Ηλ/γος Μηχ/κος και Μηχ/κος Υπολογιστών

apapag

  • Θαμώνας
  • ***
  • Μηνύματα: 29
Απ: Θέμα 1 γ
« Απάντηση #5 στις: 31 Μάι 2007, 05:09:30 μμ »
Προφανώς το προηγούμενο post έφυγε πριν την ώρα του...
Οπότε το παρακάτω είναι σωστό, αλλά όχι και το πιο κομψό.  ;)
   ΑΝ Α>0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Θετικός"
   ΑΛΛΙΩΣ
        ΑΝ Α=0 ΤΟΤΕ
           ΕΚΤΥΠΩΣΕ "Μηδέν"
        ΑΛΛΙΩΣ
           ΕΚΤΥΠΩΣΕ "Αρνητικός"
        ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΑΝ
Νάσια Παπαγιάννη
Ηλ/γος Μηχ/κος και Μηχ/κος Υπολογιστών

fragile

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 66
  • ΑΔΡΑΞΤΕ ΤΗΝ ΗΜΕΡΑ
Απ: Θέμα 1 γ
« Απάντηση #6 στις: 31 Μάι 2007, 05:13:02 μμ »
Νάσια (πιστεύω να μην σε ενοχλεί που σε αποκαλώ με το μικρό σου)

Και εγώ θεωρώ ότι μπορεί να γραφτεί με Εμφωλευμένα Αν, αλλά το θέμα είναι τι έγραψε ο μαθητής γι' αυτό του ζήτησα τον κώδικα. Πάντως το αποτέλεσμα με εμφωλευμένα αν είναι κατά ομολογία πιο δύσχρηστο με την λύση με πολλαπλό αν. Κοίτα και την περίπτωση της επίλεξε. Και με αυτή γίνεται.

Αυτή είναι η ομοργιά της ΑΕΠΠ άσχετα αν μερικοί την υποβαθμίζουν συνεχώς.

Fragile

fragile..........

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #7 στις: 31 Μάι 2007, 05:13:33 μμ »
an a > 0 tote emfanise "thetikos"
an a= tote emfanise "mhden"
an a < 0 tote emfanise "arnitikos"

ALLA ME

an a>0 tote
 Emfanise "thetikos"
 An a = 0 tote
 Emfanise "mhden"
  an a<0 tote
   Emfanise "arnitikos"
  telos_an
 telos_an
telos_an
AUTO EINAI SAFOS LATHOS AFOU THA ELEGKSEI OLA TA AN META TO PRWTO AN ISXUEI TO PRWTO..
KSEKINAME ME TO 2 AN 2>0 TOTE EMFANIZEI THETIKOS KAI ELEGXEI TA ALLA POU ANAGKASTIKA EINAI PSEUDI..
DINOUME 0...AN A>0 DEN MPAINEI KAN STO PRWTO AN KAI FEUGEI STO TELOS ARA DEN ELEGXEI TA MESA AN..TO IDIO THA GINEI AN THA DWSEIS TIMI -2 KAI GENIKA ARNITIKI

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3192
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα 1 γ
« Απάντηση #8 στις: 31 Μάι 2007, 05:18:28 μμ »

Νάσια, είναι σωστό αφού στην ουσία έχουν το ίδιο διάγραμμα ροής με την πολλαπλή επιλογή

Παναγιώτης

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: Θέμα 1 γ
« Απάντηση #9 στις: 31 Μάι 2007, 05:25:37 μμ »
Νάσια νομίζω επίσης οτι ειναι σωστό
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

apapag

  • Θαμώνας
  • ***
  • Μηνύματα: 29
Απ: Θέμα 1 γ
« Απάντηση #10 στις: 31 Μάι 2007, 05:49:24 μμ »
Αυτό που ήθελα να τονίσω και εγώ απαντώντας σε αυτό το thread είναι ότι είναι σωστό και με τα εμφωλευμένα...
Απλά, όπως λέει και ο fragile (και το βιβλίο), η χρήση εμφωλευμένων ΑΝ μπορεί να οδηγήσει σε πιο πολύπλοκους και δυσνόητους αλγορίθμους... (μπορεί να έγινα εγώ δυσνόητη, όμως...  ;))
Νάσια Παπαγιάννη
Ηλ/γος Μηχ/κος και Μηχ/κος Υπολογιστών

panosz

  • Θαμώνας
  • ***
  • Μηνύματα: 30
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα 1 γ
« Απάντηση #11 στις: 31 Μάι 2007, 05:57:51 μμ »
Ο μαθητής μου έκανε αυτό:
ΑΝ Α>0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Θετικός"
   ΑΛΛΙΩΣ
        ΑΝ Α=0 ΤΟΤΕ
           ΕΚΤΥΠΩΣΕ "Μηδέν"
        ΑΛΛΙΩΣ
           ΕΚΤΥΠΩΣΕ "Αρνητικός"
        ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΕΚΤΥΠΩΣΕ "....."

Ευχαριστώ για το χρόνο σας
Panos

apapag

  • Θαμώνας
  • ***
  • Μηνύματα: 29
Απ: Θέμα 1 γ
« Απάντηση #12 στις: 31 Μάι 2007, 06:20:09 μμ »
Έγραψες ένα ΤΕΛΟΣ_ΑΝ παραπάνω (φαντάζομαι κατά λάθος...)
Κατά τα άλλα είναι σωστό.
Νάσια Παπαγιάννη
Ηλ/γος Μηχ/κος και Μηχ/κος Υπολογιστών

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #13 στις: 31 Μάι 2007, 06:20:29 μμ »
σωστο..

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #14 στις: 31 Μάι 2007, 06:22:35 μμ »
nasia sou eklepsan to nick https://savannah.cern.ch/users/apapag   :P :P :P :P :P