Αποστολέας Θέμα: Διαγώνισμα 14 - Υποπρογράμματα  (Αναγνώστηκε 10189 φορές)

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1465
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Διαγώνισμα 14 - Υποπρογράμματα
« στις: 15 Μάρ 2007, 03:22:52 μμ »
2ο Διαγώνισμα στα υποπρογράμματα απο την ομάδα εργασίας :

Ηλίας Καρυοφύλης, Παύλος Κεφαλάκης, Αντώνης Μανουσάκης, Γιώργος Νικολακάκης, Γιώργος Παπαργύρης
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

olga_2703

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: Διαγώνισμα 14 - Υποπρογράμματα
« Απάντηση #1 στις: 27 Μάι 2008, 09:31:22 μμ »
Καλησπέρα, είμαι καινούρια στο forum και η απορία μου είναι αν μπορώ να βρω κάπου τις λύσεις του διαγωνίσματος.
Ευχαριστώ

Παππάς Παναγιώτης

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Διαγώνισμα 14 - Υποπρογράμματα
« Απάντηση #2 στις: 28 Μάι 2008, 05:14:25 μμ »
καλησπέρα σε όλους
Καταρχήν να ευχαριστήσω τον συνάδελφο για το διαγώνισμα. Πολύ καλή δουλειά.
Συνάμα ήθελα να κάνω και μια ερώτηση:
στο θέμα 2, στην Διαδικασία Δ1, η μεταβλητή Γ που χρησιμοποιείται στην δήλωση της διαδικασίας
χρησιμοποιείται ταυτόχρονα και στην κλήση της συνάρτησης ΥΠΟΛΟΓΙΣΜΟΣ μέσα στο σώμα της διαδικασίας.
Συνεπώς η μεταβλητή αυτή είναι για την Διαδικασία Δ1 ταυτόχρονα τυπική και πραγματική παράμετρος; :-\

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3178
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Διαγώνισμα 14 - Υποπρογράμματα
« Απάντηση #3 στις: 28 Μάι 2008, 06:11:44 μμ »
Θα το διατύπωνα ως εξής:

Είναι τυπική παράμετρος για τη Δ1.

Επίσης, χρησιμοποιείται ως πραγματική παράμετρος για την κλήση της συνάρτησης ΥΠΟΛΟΓΙΣΜΟΣ στο σώμα εντολών της Δ1..

Όλγα, δεν υπάρχουν καταγραμμένες λύσεις, μπορείς ωστόσο να ξεκινήσεις συζήτηση για κάποιο θέμα του διαγωνίσματος...

oo52yu

  • Νέος
  • *
  • Μηνύματα: 1
    • oo52yu@otenet.gr
Απ: Διαγώνισμα 14 - Υποπρογράμματα
« Απάντηση #4 στις: 23 Απρ 2013, 02:53:43 μμ »
2ο Διαγώνισμα στα υποπρογράμματα απο την ομάδα εργασίας :

Ηλίας Καρυοφύλης, Παύλος Κεφαλάκης, Αντώνης Μανουσάκης, Γιώργος Νικολακάκης, Γιώργος Παπαργύρης

Καλησπέρα συγχαρητήρια για την καταπληκτική σας δουλειά. Που μπορώ να βρω απαντήσεις του διαγωνίσματος;
Ευχαριστώ

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Διαγώνισμα 14 - Υποπρογράμματα
« Απάντηση #5 στις: 23 Απρ 2013, 03:50:49 μμ »
Δεν τις είχαμε βγάλει.

Έχε υπόψη σου πάντως ότι εκείνη το συγκεκριμένο διαγώνισμα φτιάχτηκε από ένα πρόδρομο της ομάδας διαγωνισμάτων από το στέκι. Τότε οι ομάδες έφτιαχναν ένα-δυο διαγωνίσματα ανά κεφάλαιο. Την επόμενη χρονιά έγινε ένα ανά κεφάλαιο, στη συνέχεια 2 το χρόνο και τελικά φτάσαμε στη σημερινή μορφή με ένα διαγώνισμα το χρόνο και λίγο πιο μετά τις λύσεις.

programmer

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Διαγώνισμα 14 - Υποπρογράμματα
« Απάντηση #6 στις: 09 Φεβ 2015, 08:49:55 πμ »
το 3 και 4 θεμα και αλλη μια απλη ασκηση που βρηκα καπου.

programmer

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Διαγώνισμα 14 - Υποπρογράμματα
« Απάντηση #7 στις: 09 Φεβ 2015, 08:52:10 πμ »
ΠΡΟΓΡΑΜΜΑ ΠΑΡΟΟΟΟΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, ΥΛΜ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΡΧ[100], ΕΚΑ[100]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΔΙΑΒΑΣΕ ΑΡΧ[Ι], ΕΚΑ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ "ΑΠΟΚΛΕΙΣΤΙΚΑ ΣΤΟΝ ΑΡΧΙΛΟΧΟ:"
  ΓΡΑΨΕ " ___________________________"
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ ΧΑΡ(ΕΚΑ, ΑΡΧ[Ι]) = 0 ΤΟΤΕ
      ΓΡΑΨΕ ΑΡΧ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ " ___________________________"
  ΓΡΑΨΕ " ___________________________"
  ΓΡΑΨΕ "  ΕΚΑΤΟΝΤΑΠΥΛΙΑΝΗ ΚΑΙ ΑΡΧΙΛΟΧΟ"
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ ΧΑΡ(ΑΡΧ, ΕΚΑ[Ι]) = 0 ΤΟΤΕ
      ΓΡΑΨΕ ΕΚΑ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ ΑΡΧ[Ι], "*****"
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ " ___________________________"
  ΓΡΑΨΕ " ___________________________"
  ΓΡΑΨΕ "ΑΥΤΟΙ ΠΟΥ ΕΙΝΑΙ ΚΑΙ ΣΤΟΥΣ 2 ΣΥΛΛΟΓΟΥΣ"
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ ΧΑΡ(ΕΚΑ, ΑΡΧ[Ι]) <> 0 ΤΟΤΕ
      ΓΡΑΨΕ ΑΡΧ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



ΣΥΝΑΡΤΗΣΗ ΧΑΡ(ΠΙΝ, ΟΝ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΙΝ[100], ΟΝ
  ΑΚΕΡΑΙΕΣ: Ι, ΘΕΣΗ
ΑΡΧΗ
  ΘΕΣΗ <- 0
  Ι <- 1
  ΟΣΟ Ι <= 100 ΚΑΙ ΘΕΣΗ = 0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΠΙΝ[Ι] = ΟΝ ΤΟΤΕ
      ΘΕΣΗ <- Ι
    ΤΕΛΟΣ_ΑΝ
    Ι <- Ι + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΧΑΡ <- ΘΕΣΗ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

η λύση του 4ου θεματος οπως το εχω κανει εγω

programmer

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Διαγώνισμα 14 - Υποπρογράμματα
« Απάντηση #8 στις: 09 Φεβ 2015, 08:55:58 πμ »
ΠΡΟΓΡΑΜΜΑ ΛΕΙΤΟΥΡΓΙΚΑ_ΣΥΣΤΗΜΑΤΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘΜΟΙ[5]
  ΑΚΕΡΑΙΕΣ: Ι, ΣΥΕΣ, ΣΝΟ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝ
ΑΡΧΗ
  ΣΝΟ <- 0
  ΣΥΕΣ <- ΣΝΟ
  ΓΡΑΨΕ "ΔΩΣΕ ΟΝΟΜΑ ΚΑΙ ΒΑΘΜΟΥΣ ΜΕ ΣΕΙΡΑ:ΟΝ,Α1,Α2,Α3,Π"
  ΔΙΑΒΑΣΕ ΟΝ
  ΟΣΟ ΟΝ <> " " ΕΠΑΝΑΛΑΒΕ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 4
      ΚΑΛΕΣΕ ΒΑΘΜΟΣΥΠΟΧΡ(ΒΑΘΜΟΙ[Ι])
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ (ΒΑΘΜΟΙ[1] + ΒΑΘΜΟΙ[2] + ΒΑΘΜΟΙ[3] + ΒΑΘΜΟΙ[4])/4 >= 5 ΤΟΤΕ
      ΓΡΑΨΕ "ΔΩΣΕ ΒΑΘΜΟ ΤΕΛΙΚΗΣ ΕΞΕΤΑΣΗΣ"
      ΚΑΛΕΣΕ ΒΑΘΜΟΣΥΠΟΧΡ(ΒΑΘΜΟΙ[5])
      ΓΡΑΨΕ ΥΠΟΛΟΓΙΣΜΟΣ_ΣΥΝΟΛΙΚΟΥ(ΒΑΘΜΟΙ[1], ΒΑΘΜΟΙ[2], ΒΑΘΜΟΙ[3], ΒΑΘΜΟΙ[4], ΒΑΘΜΟΙ[5])
      ΣΥΕΣ <- ΣΥΕΣ + 1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ "Ο/Η ", ΟΝ, " ΔΕΝ ΔΙΚΑΙΟΥΤΑΙ ΝΑ ΣΥΜΜΕΤΑΣΧΕΙ ΣΤΗΝ ΤΕΛΙΚΗ ΕΞΕΤΑΣΗ "
      ΣΝΟ <- ΣΝΟ + 1
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ "ΔΩΣΕ ΟΝΟΜΑ ΚΑΙ ΒΑΘΜΟ"
    ΔΙΑΒΑΣΕ ΟΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ "ΟΙ ΜΗ ΔΙΚΑΙΟΥΧΟΙ ΣΤΗΝ ΤΕΛΙΚΟΙ ΕΞΕΤΑΣΗ ΑΠΟΤΕΛΟΥΝ ΤΟ ", 100*ΣΝΟ/(ΣΥΕΣ + ΣΝΟ), " % ΤΟΥ ΣΥΝΟΛΟΥ"
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ







ΔΙΑΔΙΚΑΣΙΑ ΒΑΘΜΟΣΥΠΟΧΡ(Β)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Β
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Β
  ΟΣΟ Β < 0 Η Β > 10 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ "ΠΡΕΠΕΙ 0<=Β<=10"
    ΔΙΑΒΑΣΕ Β
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ ΥΠΟΛΟΓΙΣΜΟΣ_ΣΥΝΟΛΙΚΟΥ(Α1, Α2, Α3, Π, ΤΕ): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α1, Α2, Α3, Π, ΤΕ
ΑΡΧΗ
  ΑΝ ΤΕ < 5 ΤΟΤΕ
    ΥΠΟΛΟΓΙΣΜΟΣ_ΣΥΝΟΛΙΚΟΥ <- 0.1*(Α1 + Α2 + Α3) + 0.15*Π + 0.55*ΤΕ
  ΑΛΛΙΩΣ
    ΥΠΟΛΟΓΙΣΜΟΣ_ΣΥΝΟΛΙΚΟΥ <- 0.06*(Α1 + Α2 + Α3) + 0.12*Π + 0.7*ΤΕ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

η λυση του τρίτου 8εματος. εμένα μου τρεχει σωστα παντως στην ΓΛΩΣΣΑ οπως και το 4 θέμα .