Αποστολέας Θέμα: Η αρχικοποίηση του ΠΛ_ΜΑΧ αρχικοποιείται στο 0 ή στο 1  (Αναγνώστηκε 433 φορές)

ΣΧΟΙΝΑΣ ΚΩΣΤΑΣ

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 143
   ΠΡΟΓΡΑΜΜΑ  ΕΥΡΕΣΗ_ΣΥΧΝΟΤΗΤΑΣ_ΜΕΓΙΣΤΟΥ

Να γράψετε πρόγραμμα το οποίο χωρίς χρήση πίνακα θα διαβάζει 5 θετικούς ακέραιους  αριθμούς και θα υπολογίζει  τη συχνότητα  του max



ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:I ,X,ΜΑΧ ,ΠΛ_ΜΑΧ
ΑΡΧΗ                               

  ΜΑΧ ← -1
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ   5
    ΔΙΑΒΑΣΕ   X
    ΑΝ X>   ΜΑΧ  ΤΟΤΕ
      ΜΑΧ  ←  X           
      ΠΛ_ΜΑΧ  ←1   
    ΑΛΛΙΩΣ
      ΑΝ ΜΑΧ=X  ΤΟΤΕ
        ΠΛ_ΜΑΧ ←ΠΛ_ΜΑΧ +1
      ΤΕΛΟΣ_ΑΝ       
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ   ΜΑΧ , ' ΜΕ ΣΥΧΝΟΤΗΤΑ',   ΠΛ_ΜΑΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ   

ΔΥΟ     ΕΡΩΤΗΜΑΤΑ
                   
Η παραπάνω λύση είναι σωστή; Επίσης σε ποιες εκφωνήσεις ασκήσεων το πλήθος  εμφάνισης της μέγιστης τιμής max αρχικοποιείται στο 0 και όχι στο 1
Καθηγητής πληροφορικής ΠΕ20

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 673
Απ: Η αρχικοποίηση του ΠΛ_ΜΑΧ αρχικοποιείται στο 0 ή στο 1
« Απάντηση #1 στις: 03 Σεπ 2019, 08:48:25 πμ »
Καλημερα..

1) αν δεν μου ξεφεύγει κάτι, σωστή είναι η λύση
2) δεν ξέρω αν κατάλαβα σωστά το ερωτημα με την αρχικοποίηση, αλλά στην συγκεκριμένη άσκηση δεν χρειαζεται καν αρχικοποίηση έξω από την επανάληψη... Από Ν αριθμούς θα έχουμε σίγουρα ενα αριθμό που είναι μεγαλύτερος... Κάθε φορά που βρίσκουμε νέο μέγιστο αρχικοποιουμε στο 1, αν ειναι ίσος με το μέγιστο αυξάνουμε 1...μια χαρά μου φαινεται..

bugman

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 382
  • The Bug Eater
    • Πληροφορική Προγραμματισμός
Απ: Η αρχικοποίηση του ΠΛ_ΜΑΧ αρχικοποιείται στο 0 ή στο 1
« Απάντηση #2 στις: 03 Σεπ 2019, 09:59:40 πμ »
Επειδή η άσκηση λέει για θετικούς αριθμούς, χωρίς έλεγχο, με αρχικοποίηση με αρνητικό για ΜΑΧ, είναι εντάξει.
Αν θέλαμε 20 οποιουσδήποτε αριθμούς, θα ξεχωρίσαμε την εικοσάδα σε 1 και 19. Το πρώτο θα το διαβάζαμε στο ΜΑΧ και θα βάζαμε ΠΛ_ΜΑΧ το 1. Μετά θα κάναμε την επανάληψη για τα υπόλοιπα εισαγόμενα στοιχεία.

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1094
Απ: Η αρχικοποίηση του ΠΛ_ΜΑΧ αρχικοποιείται στο 0 ή στο 1
« Απάντηση #3 στις: 05 Σεπ 2019, 12:09:43 πμ »
Ο κώδικας εύρεσης του πλήθους του μεγαλύτερου δουλεύει σωστά, δεν έχει πρόβλημα