Αποστολέας Θέμα: Θέμα 3  (Αναγνώστηκε 990 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Θέμα 3
« στις: 12 Ιούν 2019, 09:35:18 πμ »
Εδώ σχολιάζουμε το θέμα 3
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

progmat

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Θέμα 3
« Απάντηση #1 στις: 12 Ιούν 2019, 11:07:51 πμ »
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΓ_2019
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΡ_ΕΠ, ΜΑΧ, ΜΜΑΧ, ΠΛ1, ΠΛ2, ΠΛ3
  ΧΑΡΑΚΤΗΡΕΣ: ΤΙΤΛΟΣ, ΤΜΑΧ, ΚΑΤΜΑΧ

ΑΡΧΗ
  ΜΑΧ <- 0
  ΠΛ1 <- 0
  ΠΛ2 <- 0
  ΠΛ3 <- 0
  ΔΙΑΒΑΣΕ ΤΙΤΛΟΣ
  ΟΣΟ ΤΙΤΛΟΣ <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ ΑΡ_ΕΠ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΑΡ_ΕΠ > 0
    ΑΝ ΑΡ_ΕΠ > ΜΑΧ ΤΟΤΕ
      ΜΑΧ <- ΑΡ_ΕΠ
      ΤΜΑΧ <- ΤΙΤΛΟΣ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΑΡ_ΕΠ <= 100 ΤΟΤΕ
      ΠΛ1 <- ΠΛ1 + 1
    ΑΛΛΙΩΣ_ΑΝ ΑΡ_ΕΠ <= 1000 ΤΟΤΕ
      ΠΛ2 <- ΠΛ2 + 1
    ΑΛΛΙΩΣ
      ΠΛ3 <- ΠΛ3 + 1
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ ΤΙΤΛΟΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΤΟ ΒΙΝΤΕΟ ΜΕ ΤΟΝ ΜΕΓΑΛΥΤΕΡΟ ΑΡ_ΕΠ ΕΙΝΑΙ ', ΤΜΑΧ
  ΓΡΑΨΕ 'ΧΑΜΗΛΗ ΚΑΤΗΓΟΡΙΑ', ΠΛ1
  ΓΡΑΨΕ 'ΜΕΣΑΙΑ ΚΑΤΗΓΟΡΙΑ', ΠΛ2
  ΓΡΑΨΕ 'ΥΨΗΛΗ ΚΑΤΗΓΟΡΙΑ', ΠΛ3
  ΜΜΑΧ <- ΠΛ1
  ΚΑΤΜΑΧ <- 'ΧΑΜΗΛΗ'
  ΑΝ ΠΛ2 > ΜΜΑΧ ΤΟΤΕ
    ΜΑΧ <- ΠΛ2
    ΚΑΤΜΑΧ <- 'ΜΕΣΑΙΑ'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΠΛ3 > ΜΜΑΧ ΤΟΤΕ
    ΜΑΧ <- ΠΛ3
    ΚΑΤΜΑΧ <- 'ΥΨΗΛΗ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ΚΑΤΜΑΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: Θέμα 3
« Απάντηση #2 στις: 12 Ιούν 2019, 11:12:42 πμ »
Στον ελεγχο εγκυροτητας η συνθηκη ειναι >=0 .... λεει να μην ειναι αρνητικος

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα 3
« Απάντηση #3 στις: 12 Ιούν 2019, 11:13:20 πμ »
μηδενικές επισκέψεις δεν καταμετρώνται

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2212
Απ: Θέμα 3
« Απάντηση #4 στις: 12 Ιούν 2019, 11:35:28 πμ »
Το πινακάκι έχει παγίδα, προσοχή
Τα αν πρέπει να έχουν διπλές συνθήκες και όχι Αλλιώς
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα 3
« Απάντηση #5 στις: 12 Ιούν 2019, 11:43:16 πμ »
Καλή παρατήρηση!
Εκτός αν βάλεις το πρώτο Αν..τότε να διαχειριστεί τα μηδενικά βίντεο
Το πινακάκι έχει παγίδα, προσοχή
Τα αν πρέπει να έχουν διπλές συνθήκες και όχι Αλλιώς
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: Θέμα 3
« Απάντηση #6 στις: 12 Ιούν 2019, 11:57:19 πμ »
Ή πιο απλά ξεκινάς με έλεγχο αυτών που είναι >1000 και βάζεις τετελευταίο  το Αλλιως_αν επισκ>0, χωρίς να βάλεις Αλλιώς.
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

akouts

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Θέμα 3
« Απάντηση #7 στις: 12 Ιούν 2019, 04:48:30 μμ »
Δεν καταμετρώνται μεν, θα πρέπει να γίνονται δεκτές δε. Δεν θα πρέπει όποιος δώσει 0 να εξαναγκασθεί να ξαναδώσει τιμή.
μηδενικές επισκέψεις δεν καταμετρώνται

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα 3
« Απάντηση #8 στις: 12 Ιούν 2019, 09:36:16 μμ »
Καλή παρατήρηση!
Εκτός αν βάλεις το πρώτο Αν..τότε να διαχειριστεί τα μηδενικά βίντεο
δλδ?
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα 3
« Απάντηση #9 στις: 12 Ιούν 2019, 10:19:10 μμ »
δλδ?
Όταν κατέβεις Αθήνα για καμιά μπύρα θα σου εξηγήσω :D
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

giannakos

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα 3
« Απάντηση #10 στις: 12 Ιούν 2019, 10:20:10 μμ »
Καλησπέρα και από εμένα.
Θα ήθελα να ρωτήσω το εξής:
Στο πρόγραμμα που δίνετε ως λύση, αν δοθεί την πρώτη φορά η λέξη 'ΤΕΛΟΣ' στην μεταβλητή ΤΙΤΛΟΣ, τότε δεν θα κάνει καμμία επανάληψη και η μεταβλητή ΤΜΑΧ δεν θα έχει αρχική τιμή.

Οπότε στην εντολή
ΓΡΑΨΕ 'ΤΟ ΒΙΝΤΕΟ ΜΕ ΤΟΝ ΜΕΓΑΛΥΤΕΡΟ ΑΡ_ΕΠ ΕΙΝΑΙ ', ΤΜΑΧ
υπάρχει λάθος.

Δεν θα έπρεπε μετά το διάβασε ΤΙΤΛΟΣ να υπάρχει ΤΜΑΧ <-- τίτλος ?

Ευχαριστώ

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 116
Απ: Θέμα 3
« Απάντηση #11 στις: 12 Ιούν 2019, 10:25:58 μμ »
Καλησπέρα και από εμένα.
Θα ήθελα να ρωτήσω το εξής:
Στο πρόγραμμα που δίνετε ως λύση, αν δοθεί την πρώτη φορά η λέξη 'ΤΕΛΟΣ' στην μεταβλητή ΤΙΤΛΟΣ, τότε δεν θα κάνει καμμία επανάληψη και η μεταβλητή ΤΜΑΧ δεν θα έχει αρχική τιμή.

Οπότε στην εντολή
ΓΡΑΨΕ 'ΤΟ ΒΙΝΤΕΟ ΜΕ ΤΟΝ ΜΕΓΑΛΥΤΕΡΟ ΑΡ_ΕΠ ΕΙΝΑΙ ', ΤΜΑΧ
υπάρχει λάθος.

Δεν θα έπρεπε μετά το διάβασε ΤΙΤΛΟΣ να υπάρχει ΤΜΑΧ <-- τίτλος ?

Ευχαριστώ
Κατά τη γνώμη μου από τη στιγμή που στο ερώτημα με την εύρεση μεγίστου αναφέρει ότι θεωρείστε ότι υπάρχει μόνο ένα αυτό σημαίνει ότι θα δοθεί τουλάχιστον μία σωστή εισαγωγή

sakisnemkav

  • Βετεράνος
  • ****
  • Μηνύματα: 66
Απ: Θέμα 3
« Απάντηση #12 στις: 15 Ιούν 2019, 12:05:34 πμ »

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 116
Απ: Θέμα 3
« Απάντηση #13 στις: 16 Ιούν 2019, 10:19:12 πμ »
Γ4. Να υπολογίζει για καθεμία από τις τρεις κατηγορίες επισκεψιμότητας το πλήθος των βίντεο που καταχωρίστηκαν σε αυτή.
Να εμφανίζει για κάθε κατηγορία: το όνομά της και το πλήθος των βίντεο που περιλαμβάνει. Μονάδες6

Σε ότι αφορά το ερώτημα Γ4 μαθητής μου έδωσε την παρακάτω απάντηση, δεν πήρε δηλαδή τον τελευταίο έλεγχο και έβαλε σκέτο αλλιώς με αποτέλεσμα όταν οι επισκέψεις είναι 0 να προστίθενται στη υψηλή.  Από τις 6 μονάδες θα πάρει μόνο τις 3 για την εμφάνιση των ονομάτων των κατηγορίων ή θα "τσιμπήσει" και από τον κώδικα της πολλαπλής. Πάντως αρκετοί μαθητές όπως έχω καταλάβει σε αυτό το ερώτημα έχουν φτιάξει την πολλαπλή μόνο με το δεξί όριο ΑΝ ΕΠ<=100 ΤΟΤΕ....

ΑΝ ΕΠΙΣΚΕΨΕΙΣ >= 1 ΚΑΙ ΕΠΙΣΚΕΨΕΙΣ <= 100 ΤΟΤΕ
      ΠΛ1 <- ΠΛ1 + 1
    ΑΛΛΙΩΣ_ΑΝ ΕΠΙΣΚΕΨΕΙΣ >= 101 ΚΑΙ ΕΠΙΣΚΕΨΕΙΣ <= 1000 ΤΟΤΕ
      ΠΛ2 <- ΠΛ2 + 1
    ΑΛΛΙΩΣ
      ΠΛ3 <- ΠΛ3 + 1
ΤΕΛΟΣ_ΑΝ

έξω από την επανάληψη έγραψε
ΓΡΑΨΕ 'ΧΑΜΗΛΗ', ΠΛ1
ΓΡΑΨΕ 'ΜΕΣΑΙΑ', ΠΛ2
ΓΡΑΨΕ 'ΥΨΗΛΗ', ΠΛ3

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2212
Απ: Θέμα 3
« Απάντηση #14 στις: 16 Ιούν 2019, 10:39:07 πμ »
Εγώ θα έκοβα το πολύ  μια μονάδα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής