Αποστολέας Θέμα: Θέμα 1  (Αναγνώστηκε 2067 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Θέμα 1
« στις: 12 Ιούν 2019, 09:34:42 πμ »
Εδώ σχολιάζουμε το θέμα 1
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

progmat

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Θέμα 1
« Απάντηση #1 στις: 12 Ιούν 2019, 11:05:59 πμ »
Α1. 1.Σ  2.Λ  3.Λ  4.Σ   5.Λ

Α3. α) 6 8 10     β) 7   γ) 1  3

Α5.
Κώδικας: [Επιλογή]
     Ρ<- 0
               ΟΣΟ Μ2 > 0 ΕΠΑΝΑΛΑΒΕ
                 ΑΝ Μ2mod2 = 1 ΤΟΤΕ
                    Ρ <- Ρ + Μ1
                    Μ1 <- Μ1 * 2
                    Μ2 <- Α_Μ(Μ2/2)
                 ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                 ΓΡΑΨΕ Ρ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Απ: Θέμα 1
« Απάντηση #2 στις: 12 Ιούν 2019, 11:08:53 πμ »
Μέσα στην επανάληψη μόνο η πρώτη εντολή  ;)

               Ρ<- 0
               ΟΣΟ Μ2 > 0 ΕΠΑΝΑΛΑΒΕ
                 ΑΝ Μ2mod2 = 1 ΤΟΤΕ
                    Ρ <- Ρ + Μ1
                    Μ1 <- Μ1 * 2
                    Μ2 <- Α_Μ(Μ2/2)

                 ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                 ΓΡΑΨΕ Ρ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 655
Απ: Θέμα 1
« Απάντηση #3 στις: 12 Ιούν 2019, 11:09:42 πμ »
Μέσα στην επιλογή ;)

marvic

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 46
Απ: Θέμα 1
« Απάντηση #4 στις: 12 Ιούν 2019, 11:11:13 πμ »
Στο θέμα Α5 το ΤΕΛΟΣ_ΑΝ είναι πριν την εντολή Μ1<--Μ1 *2

marvic

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 46
Απ: Θέμα 1
« Απάντηση #5 στις: 12 Ιούν 2019, 11:12:42 πμ »
ΧΧμμμμ.. Δεν το πετάει σε μεθεπόμενο βήμα.. Αλλά σε αυτήν την περίπτωση δεν είναι ο πολλαπλασιασμόσ αλά ρωσικά. και δεύτερον εννοείτε πως τελειώνει εκεί η ΑΝ(καθώς γράφεται στην ίδια γραμμή), οπότε δεν χρειάζεται να το στείλει αλλού..

Konstantina Petropoulou

  • Μηχανικών Η/Υ
  • Οπαδός
  • **
  • Μηνύματα: 16
    • Φαρρών 2
Απ: Θέμα 1
« Απάντηση #6 στις: 12 Ιούν 2019, 11:15:37 πμ »
Ρ<- 0
 ΟΣΟ Μ2 > 0 ΕΠΑΝΑΛΑΒΕ
      ΑΝ Μ2mod2 = 1 ΤΟΤΕ
            Ρ <- Ρ + Μ1
      ΤΕΛΟΣ_ΑΝ
        Μ1 <- Μ1 * 2
         Μ2 <- Α_Μ(Μ2/2)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ Ρ

Το σωστό είναι αυτο?

progmat

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Θέμα 1
« Απάντηση #7 στις: 12 Ιούν 2019, 11:17:48 πμ »

progmat

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Θέμα 1
« Απάντηση #8 στις: 12 Ιούν 2019, 11:20:47 πμ »
Κώδικας: [Επιλογή]
Ρ<- 0
 ΟΣΟ Μ2 > 0 ΕΠΑΝΑΛΑΒΕ
      ΑΝ Μ2mod2 = 1 ΤΟΤΕ
            Ρ <- Ρ + Μ1
      ΤΕΛΟΣ_ΑΝ
        Μ1 <- Μ1 * 2
         Μ2 <- Α_Μ(Μ2/2)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ Ρ

Ναι

Konstantina Petropoulou

  • Μηχανικών Η/Υ
  • Οπαδός
  • **
  • Μηνύματα: 16
    • Φαρρών 2
Απ: Θέμα 1
« Απάντηση #9 στις: 12 Ιούν 2019, 11:21:26 πμ »
μπορεί κάποιος να μου πει η θεωρία που είναι μεσα απο το βιβλίο;

dg69

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 71
  • Όλα καλά, όλα ανθηρά
Απ: Θέμα 1
« Απάντηση #10 στις: 12 Ιούν 2019, 11:21:31 πμ »
Προφανώς οι δύο εντολές είναι έξω από την Αν. Στο βιβλίο από κάτω από την έκφραση σε φυσική γλώσσα, υπάρχει η αντίστοιχη κωδικοποίηση. Είναι σε μορφή ψευδογλώσσας όπου η σύνταξη μιας απλής ΑΝ, με μία εντολή, μπορεί να γραφεί σε μια γραμμή και να μην μπει ΤΕΛΟΣ_ΑΝ.
Αν μπουν μέσα στην ΑΝ, δεν είναι ο πολλαπλασιασμός ΑΛΑ ΡΩΣΙΚΑ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Απ: Θέμα 1
« Απάντηση #11 στις: 12 Ιούν 2019, 11:29:20 πμ »
Η συγχώνευση και ο διαχωρισμός είναι πράξεις που μπορούν να γίνουν σε πίνακες?

Προσοχή!! Η έννοια της συγχώνευσης όπως περιγράφεται στις δομές δεδομένων είναι διαφορετική από αυτή στις τυπικές επεξεργασίες πινάκων.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 116
Απ: Θέμα 1
« Απάντηση #12 στις: 12 Ιούν 2019, 11:31:05 πμ »
Στα διαγράμματα της οσο και της μέχρις_ότου αν βάλουμε ναι όχι αντί για αληθής ψευδής λογικά δεν υπάρχει πρόβλημα, σωστά;

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3190
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα 1
« Απάντηση #13 στις: 12 Ιούν 2019, 11:35:02 πμ »
Η συγχώνευση και ο διαχωρισμός είναι πράξεις που μπορούν να γίνουν σε πίνακες?
το τετράδιο οδηγιών μαθητή ενώνει 2 πίνακες σε νέο ενιαίο πίνακα στη σελίδα 61. Ο διαχωρισμός είναι το αντίθετο της συγχώνευσης (σελίδα 61).

Konstantina Petropoulou

  • Μηχανικών Η/Υ
  • Οπαδός
  • **
  • Μηνύματα: 16
    • Φαρρών 2
Απ: Θέμα 1
« Απάντηση #14 στις: 12 Ιούν 2019, 11:36:19 πμ »
η απάντηση μέσα στο  βιβλίο είναι;