Αποστολέας Θέμα: Δυο ασκήσεις με MOD  (Αναγνώστηκε 457 φορές)

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Δυο ασκήσεις με MOD
« στις: 10 Ιούν 2019, 07:38:33 μμ »
Τις έβαλα φέτος στην τάξη σε διαγώνισμα α τετραμήνου.


Άσκηση 1:
Να  συμπληρώσετε τα κενά στα τμήματα προγράμματος των  Στηλών ΙΙ και ΙΙΙ ώστε τα τμήματα προγράμματος των τριών στηλών να εκτελούν την ίδια λειτουργία. (Να θεωρήσετε ότι η μεταβλητή Χ περιέχει μία ακέραια θετική τιμή.)

Στήλη Ι                                       Στήλη ΙΙ                                        Στήλη ΙΙΙ

Αν  Χ mod 2 = 0 τότε                    Χ<- Χ+1                                       Χ<- .....................
   Χ<- Χ+2                                   Αν  (Χ+1) mod 2 = 0 τότε                     Γράψε Χ
Αλλιώς                                               Χ<- .....................
   Χ<- Χ+1                                   Τέλος_αν
Τέλος_αν                                      Γράψε Χ
Γράψε Χ


Άσκηση 2:
α. Τι θα εμφανιστεί κατά την εκτέλεση του παρακάτω τμήματος προγράμματος;
            
         Σ<- 0
         Για Α από 1 μέχρι 5
            Χ<- A mod 3 + (A+1) mod 3 + (A+2) mod 3
            Γράψε Χ
            Αν Α mod 3 = 0 τότε
               Σ<- Σ+Α^2
            Τέλος_αν
         Τέλος_επανάληψης 
      Γράψε Σ                            

β. Να επιλέξετε τη/τις σωστή/σωστές απάντηση/απαντήσεις.
    Αν η τιμή της μεταβλητής Α είναι ακέραια και θετική, η τιμή της έκφρασης  A mod 3 + (A+1) mod 3 + (A+2) mod 3  μπορεί
    να είναι:   
    α) 0      β) 1      γ) 2      δ) 3       ε) 4        στ) 5        ζ) 6       η) 7        θ) 8        ι) 9         ια) καμιά από τις  προηγούμενες     
    ιβ) οποιαδήποτε ακέραια θετική τιμή
« Τελευταία τροποποίηση: 11 Ιούν 2019, 09:25:04 πμ από ολγα »

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 115
Απ: Δυο ασκήσεις με MOD
« Απάντηση #1 στις: 10 Ιούν 2019, 11:04:32 μμ »
για τη στήλη ΙΙΙ έχω πολλές ιδέες, όπως
χ <-- χ + 2 - χ mod 2
χ <-- χ + 1 + (χ+1) mod 2
χ <-- χ + 2 div (2 -  x mod 2)
και διάφορα ατελείωτα...

για τη στήλη ΙΙ όμως, περιμένω να δω την πρότασή σου γιατί εμένα μού φαίνεται λάθος

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Δυο ασκήσεις με MOD
« Απάντηση #2 στις: 11 Ιούν 2019, 08:12:51 πμ »


χ <-- χ + 2 div (2 -  x mod 2)
   
Αυτό δεν είναι σωστό. Νομίζω το σωστό είναι:  χ <-- χ + 2 div (2 -  (χ+1) mod 2)

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Δυο ασκήσεις με MOD
« Απάντηση #3 στις: 11 Ιούν 2019, 08:35:03 πμ »
για τη στήλη ΙΙ όμως, περιμένω να δω την πρότασή σου γιατί εμένα μού φαίνεται λάθος
Έχεις δίκιο. Το διορθώνω και πάνω.
Το σωστό είναι:    Αν  (Χ+1) mod 2 = 0      και όχι:       Αν  Χ mod 2 = 0
 Στήλη ΙΙ                                   
 Χ<- Χ+1                                     
 Αν  (Χ+1) mod 2 = 0 τότε
          Χ<- .....................
 Τέλος_αν
 Γράψε Χ
« Τελευταία τροποποίηση: 11 Ιούν 2019, 08:48:15 πμ από ολγα »