Αποστολέας Θέμα: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ  (Αναγνώστηκε 1838 φορές)

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 633
Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
« Απάντηση #15 στις: 11 Ιούν 2019, 11:55:38 μμ »
Καλησπέρα

αν δεν κάνω λάθος κάπου το είχα διαβάσει στο βιβλίο πως ονομάζεται "έξυπνη" συγχώνευση, δεν το ανέφερα αυστηρά ως "ορισμό" .. όπως και να έχει είναι ωραία σαν άσκηση ..  :laugh: >:D

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 114
Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
« Απάντηση #16 στις: 12 Ιούν 2019, 03:57:23 μμ »
! έστω πίνακας Α μεγέθους Μ ταξινομημένος σε αύξουσα σειρά
! έστω πίνακας Β μεγέθους Ν ταξινομημένος σε αύξουσα σειρά
! ζητούμενο να δημιουργηθεί ταξινομημένος σε αύξουσα σειρά πίνακας Γ, με όλα τα στοιχεία των Α, Β
! από άποψη λογικής, το ζητούμενο επιτυγχάνεται με μια κατά τη γνώμη μου πολύ πιο απλή διαδικασία από αυτή που παρουσιάζεται στο βιβλίο:


Κώδικας: Bash
  1. χ <-- 1
  2. ψ <-- 1
  3. για θ από 1 μέχρι Μ+Ν
  4.   αν ψ > Ν ή Α[χ] < Β[ψ] τότε
  5.     Γ[θ] <-- Α[χ]
  6.     χ <-- χ + 1
  7.   αλλιώς
  8.     Γ[θ] <-- Β[ψ]
  9.     ψ <-- ψ + 1
  10.   τέλος_αν
  11. τέλος_επανάληψης
  12.  

τώρα, αν θέλουμε να σκεφτούμε την πιθανότητα για index out of size error, που κατ' εμέ είναι θέμα διαχείρισης της διάζευξης από τον compiler, και δε θα έπρεπε να μας απασχολεί, μπορούμε να το σπάσουμε σε 3 περιπτώσεις

Κώδικας: Bash
  1. χ <-- 1
  2. ψ <-- 1
  3. για θ από 1 μέχρι Μ+Ν
  4.   αν ψ > Ν
  5.     Γ[θ] <-- Α[χ]
  6.     χ <-- χ + 1
  7.   αλλιώς_αν Α[χ] < Β[ψ] τότε
  8.     Γ[θ] <-- Α[χ]
  9.     χ <-- χ + 1
  10.   αλλιώς
  11.     Γ[θ] <-- Β[ψ]
  12.     ψ <-- ψ + 1
  13.   τέλος_αν
  14. τέλος_επανάληψης
  15.  

ssimaiof

  • Πληροφορικοί Δυτικής Μακεδονίας
  • *
  • Μηνύματα: 23
Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
« Απάντηση #17 στις: 12 Ιούν 2019, 07:11:14 μμ »
Για τη 2η περίπτωση πρέπει να ξέχασες μία ΑΝ.
Προφανώς μετά το ΑΝ ψ>Ν χρειάζεται και η ΑΛΛΙΩΣ_ΑΝ χ>Μ.
Ολοκληρωμένο :
Κώδικας: Bash
  1.   χ <- 1
  2.   ψ <- 1
  3.   ΓΙΑ θ ΑΠΟ 1 ΜΕΧΡΙ Μ + Ν
  4.     ΑΝ ψ > Ν ΤΟΤΕ
  5.       Γ[θ] <- Α[χ]
  6.       χ <- χ + 1
  7.     ΑΛΛΙΩΣ_ΑΝ χ > Μ ΤΟΤΕ
  8.       Γ[θ] <- Β[ψ]
  9.       ψ <- ψ + 1
  10.     ΑΛΛΙΩΣ_ΑΝ Α[χ] < Β[ψ] ΤΟΤΕ
  11.       Γ[θ] <- Α[χ]
  12.       χ <- χ + 1
  13.     ΑΛΛΙΩΣ
  14.       Γ[θ] <- Β[ψ]
  15.       ψ <- ψ + 1
  16.     ΤΕΛΟΣ_ΑΝ
  17.   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 114
Απ: Προτάσεις και ιδέες για τα θέματα 2019 στην ΑΕΠΠ
« Απάντηση #18 στις: 13 Ιούν 2019, 01:15:01 πμ »
βεβαίως
μα ούτε και η πρώτη είναι σωστή  :D

μάλλον θα κρατήσω αυτό που λες εσύ