Αποστολέας Θέμα: ΘΕΜΑ Α5 - ΕΙΜΑΣΤΕ ΜΕΣΑ 2019  (Αναγνώστηκε 1439 φορές)

xkon2007

  • Νέος
  • *
  • Μηνύματα: 2
ΘΕΜΑ Α5 - ΕΙΜΑΣΤΕ ΜΕΣΑ 2019
« στις: 11 Ιαν 2019, 10:44:44 πμ »
Είναι μια μετατροπή από ''όσο'' σε ''για'' αλλά η λύση που προτείνουν δεν νομίζω να είναι σωστή. Για παράδειγμα ως είσοδο στο x το 0,1.

ozorgnax

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: ΘΕΜΑ Α5 - ΕΙΜΑΣΤΕ ΜΕΣΑ 2019
« Απάντηση #1 στις: 13 Ιαν 2019, 11:09:03 πμ »
Ναι, κανονικά θα έπρεπε να διευκρινίζεται ότι το X μπορεί να πάρει μόνο ακέραιες τιμές. Αν μπορεί να πάρει και πραγματικές, υπάρχει πρόβλημα, δεν ξέρω αν μπορεί να μετατραπεί 100% σωστά

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1002
Απ: ΘΕΜΑ Α5 - ΕΙΜΑΣΤΕ ΜΕΣΑ 2019
« Απάντηση #2 στις: 13 Ιαν 2019, 02:57:03 μμ »
...
ΌΣΟ  Ι <= Χ-1  ΕΠΑΝΑΛΆΒΕ
   ΑΘΡ <- ΑΘΡ + (I+3)
   ΓΡΑΨΕ  Ι+3
   I <-  Ι+3
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
...

Α

ozorgnax

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: ΘΕΜΑ Α5 - ΕΙΜΑΣΤΕ ΜΕΣΑ 2019
« Απάντηση #3 στις: 13 Ιαν 2019, 04:13:45 μμ »
...
ΌΣΟ  Ι <= Χ-1  ΕΠΑΝΑΛΆΒΕ
   ΑΘΡ <- ΑΘΡ + (I+3)
   ΓΡΑΨΕ  Ι+3
   I <-  Ι+3
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
...

Α

Αν κατάλαβα καλά ζητείται η αντίστροφη μετατροπή, δηλ. από Όσο σε Για.

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 106
Απ: ΘΕΜΑ Α5 - ΕΙΜΑΣΤΕ ΜΕΣΑ 2019
« Απάντηση #4 στις: 14 Ιαν 2019, 11:40:51 μμ »
Δίνεται η ΟΣΟ και ζητείται μετατροπή σε ΜΕΧΡΙΣ_ΟΤΟΥ και σε ΓΙΑ. Κλασική άσκηση - μετατροπή που έχει την παγίδα στον μετρητή

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 182
Απ: ΘΕΜΑ Α5 - ΕΙΜΑΣΤΕ ΜΕΣΑ 2019
« Απάντηση #5 στις: 16 Ιαν 2019, 05:44:36 πμ »
Ναι, κανονικά θα έπρεπε να διευκρινίζεται ότι το X μπορεί να πάρει μόνο ακέραιες τιμές. Αν μπορεί να πάρει και πραγματικές, υπάρχει πρόβλημα, δεν ξέρω αν μπορεί να μετατραπεί 100% σωστά
για ι απο 0 μεχρι Α_Μ(Χ-1) με_βημα 3
ΚΤΛ ΚΤΛ
τελος_επαναληψης

Λάμπρος Παπαδόπουλος

  • Βετεράνος
  • ****
  • Μηνύματα: 59
Απ: ΘΕΜΑ Α5 - ΕΙΜΑΣΤΕ ΜΕΣΑ 2019
« Απάντηση #6 στις: 16 Ιαν 2019, 11:28:12 πμ »

Διάβασε x
Αθρ <- 0
Για i από 0 μέχρι x με_βήμα 3
  Aν i < x τοτε
   Αθρ <- Αθρ + i +3
   Γραψε i+3
  τελος_αν
Τέλος_επανάληψης
Γράψε Αθρ

Για να παίρνουμε τα ίδια αποτελέσματα...
« Τελευταία τροποποίηση: 16 Ιαν 2019, 11:39:25 πμ από Λάμπρος Παπαδόπουλος »