Αποστολέας Θέμα: ΘΕΜΑΤΑ ΟΕΦΕ 2011  (Αναγνώστηκε 21644 φορές)

spantoulis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 109
Απ: ΘΕΜΑΤΑ ΟΕΦΕ 2011
« Απάντηση #90 στις: 18 Μάι 2011, 08:15:54 μμ »
Παραμονές εξέτασης της ΑΕΠΠ προτείνω να χαλαρώσουμε. Πολύ στα σοβαρά δεν έχουμε πάρει τα θέματα ΟΕΦΕ?
Θέματα φροντιστών είναι ρε παιδιά. Δεν είναι θέματα ΚΕΕ. Γιατί τέτοια βαβούρα λοιπον?
Η χρήση υπολογιστών ΔΕΝ είναι πληροφορική

loutos

  • Νέος
  • *
  • Μηνύματα: 1
Απ: ΘΕΜΑΤΑ ΟΕΦΕ 2011
« Απάντηση #91 στις: 18 Μάι 2011, 08:27:35 μμ »
Στη δεύτερη περίπτωση, η συνθήκη είναι >= ΜΟΝΟ αν το βήμα είναι αρνητικό
το μηδέν ΔΕΝ είναι αρνητικός άρα η συνθήκη είναι <= και δεν εκτελείται ούτε μια φορά

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3178
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΘΕΜΑΤΑ ΟΕΦΕ 2011
« Απάντηση #92 στις: 18 Μάι 2011, 09:32:20 μμ »
το μηδέν δεν είναι αρνητικός (σύμφωνοι)

το μηδέν είναι θετικός;

kyriakos208

  • Θαμώνας
  • ***
  • Μηνύματα: 22
Απ: ΘΕΜΑΤΑ ΟΕΦΕ 2011
« Απάντηση #93 στις: 24 Οκτ 2018, 02:15:03 μμ »
Μια διαφορετική λύση(ΧΩΡΙΣ ΤΑΞΙΝΟΜΗΣΗ ΔΙΣΔΙΑΣΤΑΤΟΥ ΠΙΝΑΚΑ) για το Θέμα Δ-(γ ) ΑΝ ΕΧΩ ΚΑΠΟΙΟ ΛΑΘΟΣ ΠΕΙΤΕ ΜΟΥ 

ΜΑΧ<--ΒΚ[1]
Θ_1<--1
ΜΙΝ<--ΒΚ[1]
Θ<--1
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 14
  ΑΝ ΒΚ[Ι]>ΜΑΧ ΤΟΤΕ
     ΜΑΧ<--ΒΚ[Ι]
     Θ_1<--Ι
  ΑΛΛΙΩΣ
             ΑΝ ΒΚ[Ι]<ΜΙΝ ΤΌΤΕ
                   ΜΙΝ<--ΒΚ[Ι]
                   Θ<--Ι
            ΤΈΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΑΝ
ΒΚ[Θ_1]<--42
ΒΚ[Θ]<--3
Z<--39
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
   ΔΙΑΦ<--ΜΑΧ-ΜΙΝ
   ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 14
         ΑΝ ΔΙΑΦ>ΜΑΧ-ΒΚ[Ι] ΚΑΙ ΒΚ[Ι]<>ΜΑΧ ΚΑΙ ΜΑΧ-ΒΚ[Ι]>0 ΤΌΤΕ
               ΔΙΑΦ<--ΜΑΧ-ΔΙΑΦ
         ΤΈΛΟΣ_ΑΝ
  ΤΈΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΑΧ<--ΜΑΧ-ΔΙΑΦ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 14
   ΑΝ ΒΚ[Ι]=ΜΑΧ ΤΟΤΕ
         Σ[Ι]<--Ζ
          Ζ<--Ζ-3
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ