Αποστολέας Θέμα: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη  (Αναγνώστηκε 5080 φορές)

ggkioule

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #15 στις: 24 Αύγ 2018, 01:07:41 μμ »
Ο Firefox δεν ανοίγει .swf αρχεία, πχ. Μαθηματικά Α'-Β' Δημοτικού

ggkioule

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #16 στις: 26 Αύγ 2018, 09:12:40 μμ »
Δεν ανοίγει ο Επόπτης από τον Server και το LibreOffice από τους clients (πριν 5 μέρες δεν είχα τέτοιο πρόβλημα).

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4629
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #17 στις: 26 Αύγ 2018, 09:19:46 μμ »
1) Νέα sch-scripts => έτοιμα,
2) Νέος Επόπτης => έτοιμος,
3) .swf => λόγω αλλαγών στον firefox, θέλει νέα έκδοση στα Μαθηματικά Α΄-Β΄ ώστε να περιτυλίγουν το .swf σε μια απλή .html σελίδα. Θα την ανεβάσω μέσα στο Σεπτέμβριο που θα έχω πρόσβαση.
4) LibreOffice => το έχω διορθώσει στο LTSP, θα ανεβάσω αύριο νέα έκδοση,
5) Δεν ανοίγει ο Επόπτης => τρέξε "epoptes" από τερματικό και ανέβασε τυχόν μηνύματα που εμφανίζει.

ggkioule

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #18 στις: 28 Αύγ 2018, 02:23:42 μμ »
administrator@server:~$ epoptes
[Errno 2] No such file or directory: '/home/administrator/.config/epoptes/history'
Traceback (most recent call last):
  File "/usr/bin/epoptes", line 99, in <module>
    main()
  File "/usr/bin/epoptes", line 89, in main
    egui = gui.EpoptesGui()
  File "/usr/lib/python3/dist-packages/epoptes/ui/gui.py", line 117, in __init__
    config.expand_filename('groups.json'))
  File "/usr/lib/python3/dist-packages/epoptes/common/config.py", line 106, in read_groups
    data = json.loads(file.read())
  File "/usr/lib/python3.6/json/__init__.py", line 354, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.6/json/decoder.py", line 339, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.6/json/decoder.py", line 357, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

ggkioule

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #19 στις: 28 Αύγ 2018, 02:46:46 μμ »
Δεν μπουτάρουν οι clients (κολλάει η οθόνη)

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4629
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #20 στις: 28 Αύγ 2018, 05:10:46 μμ »
administrator@server:~$ epoptes
  File "/usr/lib/python3/dist-packages/epoptes/ui/gui.py", line 117, in __init__
    config.expand_filename('groups.json'))
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

Φαίνεται σαν να έχεις χαλασμένο αρχείο ομάδων του Επόπτη. Μπορείς να τρέξεις "xdg-open ~/.config/epoptes/" για να ανοίξεις τον σχετικό φάκελο, και μετά να επισυνάψεις εδώ το αρχείο groups.json από εκεί;
Στη συνέχεια, μετονόμασέ το σε groups-bak.json ώστε να δημιουργηθεί καινούργιο, και ξαναδοκίμασε να ανοίξεις τον Επόπτη.


Δεν μπουτάρουν οι clients (κολλάει η οθόνη)

Πάλι χρειάζεται να αναφέρεις το συγκεκριμένο μήνυμα σφάλματος, είτε με πληκτρολόγηση είτε με φωτογραφία από το κινητό.

gouvasg

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 67
    • Ο ιστότοπός μου
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #21 στις: 03 Σεπ 2018, 09:04:20 πμ »

Όσοι έχουν μόνο 64bit clients να προτιμήσουν το amd64 iso. Όσοι έχουν έστω και έναν 32bit, το i386 iso.



το link για το 64 bit ubuntu mate είναι http://cdimage.ubuntu.com/ubuntu-mate/releases/18.04/release/ubuntu-mate-18.04.1-desktop-amd64.iso
Γεώργιος Γκούβας
Μηχ. Η/Υ-Σ
www.gouvas.eu


demetriox

  • Βετεράνος
  • ****
  • Μηνύματα: 92
  • Πως μιλάς σε φασίστα? Ρίξτου ένα τούβλο στο κεφάλι
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #23 στις: 03 Σεπ 2018, 12:30:48 μμ »
Καλημέρα και καλή χρονιά... Ευχαριστούμε για όλα... Ξεκινώ την εγκατάστηση της νέας έκδοσης... ελπίζω να πάνε όλα καλά...

gidarakos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 322
    • http://www.gidarakos.com/
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #24 στις: 05 Σεπ 2018, 02:13:34 μμ »
Άλκη σε καινούργιες εγκαταστάσεις 18.04 ισχύουν οι οδηγίες Προτεινόμενοι browsers, flash και java;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4629
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #25 στις: 05 Σεπ 2018, 05:21:26 μμ »
Άλκη σε καινούργιες εγκαταστάσεις 18.04 ισχύουν οι οδηγίες Προτεινόμενοι browsers, flash και java;

Το adobe-flashplugin το βάζουν τα sch-scripts, η java δεν υποστηρίζεται πια από κανέναν browser, οπότε ουσιαστικά εκείνο το topic συνοψίζεται στο "όποιος θέλει μπορεί προαιρετικά να εγκαταστήσει chromium-browser".

vovos

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #26 στις: 05 Σεπ 2018, 10:06:03 μμ »
Ξεκίνησα εγκατάσταση του 18 και ακολούθησα τα βήματα του Wiki. Ήθελα όμως να εγκαταστήσω λογισμικό από το boutique γιατί εκεί έχει πολλά λογισμικά από όσα χρειάζομαι τα οποία δεν θυμάμαι απ' έξω. Είχα ήδη βάλει τα sch-scripts. Είδα λοιπόν ότι το boutique καθώς και τα ubuntu-mate-welcome και snap έλειπαν. Καταλαβαίνω για την απεγκατάσταση των boutique και ubuntu-mate-welcome (μάλλον για να μην εμφανίζεται το ενοχλητικό welcome στο login των μαθητών) αλλά το snap γιατί απουσιάζει (το πακέτο είναι το snapd); Υπάρχει πρόβλημα με το snap και τους εικονικούς δίσκους;
For the record και επειδή με έτρωγε να πειραματιστώ αφού ήταν νέα εγκατάσταση και δεν είχα τίποτα να χάσω (το πολύ πολύ να την ξανάκανα από την αρχή) εγκατέστησα ubuntu-mate-welcome, boutique και snap και όλα τα προγράμματα που ήθελα από εκεί. Μετά έκανα απεγκατάσταση ubuntu-mate-welcome και boutique αλλά κράτησα το snap. Τα προγράμματα που εγκατέστησα όσα από αυτά δοκίμασα δούλευαν κανονικά και στους clients. Δεν διαπίστωσα κανένα πρόβλημα πέρα από ένα μικρό: στις ρυθμίσεις ήχου όταν πατάς δοκιμή ήχου και δεξί ή αριστερό ηχείο δεν ακούγεται τίποτα (αντί για την γνώριμη γυναικεία φωνή που λέει "front left" και "front right"). Στην αρχή τρόμαξα ότι δεν δουλεύει ο ήχος... Ίσως λείπουν για κάποιο λόγο τα αντίστοιχα αρχεία ήχου.
Μπράβο Άλκη και μπράβο σε όλους όσους συνεισέφεραν σε νια τόσο καταπληκτική διανομή! :)

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4629
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #27 στις: 05 Σεπ 2018, 11:31:06 μμ »
Εντελώς προσωπική άποψη... η Canonical για διάφορους λόγους ξεκίνησε κάποια projects που μετά τα εγκατέλειψε (upstart, bazaar, unity, mir, ubuntu phone κλπ), και πιστεύω ότι και το snap θα είναι ένα από αυτά. Παλιότερα αποφύγαμε όλη τη φούσκα του unity παραμένοντας στο gnome-flashback, έχω την εντύπωση ότι και τώρα θα ταλαιπωρηθούμε λιγότερο αν το αποφύγουμε.

Επί του πρακτέου, στην αρχή τα snaps κόλλαγαν τους LTSP clients αλλά το διόρθωσα το καλοκαίρι και δεν ξέρω να έχει μείνει κάποιο πρόβλημα. Όμως τρώνε μνήμη και στον server και στους clients, είναι μόνιμα προσαρτημένα (τρέξε mount και δες όλα τα snap mountpoints), και δεν δένουν σωστά με το υπόλοιπο deb-based σύστημα (ρυθμίσεις χρήστη/administrator κλπ).

Εν τέλει αφού κατέθεσα την προσωπική μου γνώμη, εννοείται ότι όποιος θέλει το ξαναεγκαθιστά μαζί με όσα και όποια snaps θέλει, τα sch-scripts το αφαιρούν μόνο κατά την αρχική εγκατάσταση εμφανίζοντας και το σχετικό μήνυμα.

vovos

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #28 στις: 06 Σεπ 2018, 08:37:01 πμ »
Παράθεση
Όμως τρώνε μνήμη και στον server και στους clients, είναι μόνιμα προσαρτημένα...
Με τα μηχανήματα που έχουμε δεν υπάρχουν περιθώρια για σπατάλη μνήμης. Τα απεγκατέστησα όλα και θα τα βάλω πάλι με apt ή synaptic (έφτιαξα λίστα πλέον και ξέρω τα προγράμματα που θέλω). Και πάλι ευχαριστώ Άλκη για όλα!

gidarakos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 322
    • http://www.gidarakos.com/
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #29 στις: 06 Σεπ 2018, 11:53:44 πμ »
Άλκη για το Slow disk writes after some uptime, only on 32bit/16+RAM/4+ kernels έχουμε κάτι νεώτερο ή για συστήματα >8G RAM εφαρμόζουμε workaround όπως το How To Boot with “mem=1024m” Argument using GRUB βάζοντας mem=8g;