Ψηφοφορία

Σας ενδιαφέρει να συνεχίσουν να εκτελούνται τα flash/java λογισμικά του Π.Ι. μετά το 2019;

Ναι (αν θέλετε γράψτε και ποια)
Όχι

Αποστολέας Θέμα: Μέλλον εκπαιδευτικών λογισμικών ΠΙ (flash/java)  (Αναγνώστηκε 1597 φορές)

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5106
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Το Παιδαγωγικό Ινστιτούτο είχε κάποια λογισμικά, τα οποία πακετάραμε ώστε να τρέχουν σε Ubuntu και κάποια από αυτά τα έχουμε και online στη σελίδα http://ts.sch.gr/software.

Κυρίως χωρίζονται σε τρεις κατηγορίες, τα .swf που βασίζονται σε flash, τα .jar που βασίζονται σε java, και τα εκτελέσιμα .exe που τρέχουν με το wine.
Το flash και η java έχουν διάφορα προβλήματα ασφαλείας και καταργούνται από το Internet. Έτσι από το 2019/2020 οι browsers θα σταματήσουν εντελώς να υποστηρίζουν flash, και τα λογισμικά αυτών των δύο κατηγοριών θα πάψουν να δουλεύουν (ενώ για παράδειγμα ο Διερμηνευτής της ΓΛΩΣΣΑΣ και το microworlds που είναι .exe θα συνεχίσουν να δουλεύουν).

Μια σκέψη είναι "ε εντάξει παλιά λογισμικά είναι τα έφαγαν τα ψωμιά τους δεν αξίζει να ασχολούμαστε άλλο με αυτά".
Ένα επιπλέον επιχείρημα είναι "έτσι κι αλλιώς στο φωτόδεντρο γράφονται ένα σωρό νέα λογισμικά σε HTML5 που θα παίζουν παντού, μέχρι και σε tablets, ας εγκαταλείψουμε τα παλιά".

Από την άλλη μεριά όμως υπάρχει η δυνατότητα να ξαναπακετάρουμε αυτά τα λογισμικά ώστε να μπορούν να τρέχουν τοπικά, χρησιμοποιώντας π.χ. παλιές εκδόσεις του standalone adobe flash player ή κάποια δική μας minimal έκδοση browser (ένα απλό webkit/gecko component) κλπ.

Η πρώτη ερώτηση είναι, υπάρχει ενδιαφέρον να συνεχίσουν να εκτελούνται αυτά τα λογισμικά; Γι' αυτήν την ερώτηση έβαλα και ψηφοφορία, να δούμε τι ζήτηση υπάρχει.
Και η δεύτερη ερώτηση είναι, επειδή η ομάδα της Τεχνικής Στήριξης είναι πλέον υποστελεχωμένη, υπάρχει κάποιος που να θέλει να το αναλάβει, πιθανώς με κάποια καθοδήγηση;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5106
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μέλλον εκπαιδευτικών λογισμικών ΠΙ (flash/java)
« Απάντηση #1 στις: 09 Οκτ 2018, 10:01:09 πμ »
Αν κάποιος έχει εγκατεστημένα τα πακέτα chromium-browser και flashplugin-nonfree, τότε ο chromium browser αναφέρει ότι "η λειτουργία (flash player) δεν υποστηρίζεται" και δεν εκτελεί τα λογισμικά.

Η λύση είναι να ενεργοποιηθεί το αποθετήριο "partner" της Canonical και να εγκατασταθεί το πακέτο adobe-flashplugin αντί του flashplugin-nonfree, γιατί εκείνο επιτρέπει και στον chromium-browser να παίζει flash (και όχι μόνο στον firefox).

Αυτό το κάνουν αυτόματα τα sch-scripts, οπότε υπό φυσιολογικές συνθήκες δεν χρειάζεται να κάνετε κάτι.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5106
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μέλλον εκπαιδευτικών λογισμικών ΠΙ (flash/java)
« Απάντηση #2 στις: 09 Οκτ 2018, 11:36:49 πμ »
Ανέβηκαν νέες εκδόσεις σε κάποια λογισμικά που δεν παίζανε σε 18.04.
Αν, αφού κάνετε ενημέρωση λογισμικού και δημοσίευση εικονικού δίσκου, δείτε να υπάρχει ακόμα κάποιο πρόβλημα, φωνάξτε.

happiness

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 231
Απ: Μέλλον εκπαιδευτικών λογισμικών ΠΙ (flash/java)
« Απάντηση #3 στις: 09 Οκτ 2018, 11:15:04 μμ »
Εγώ θα ήθελα να υπάρχει πρόσβαση και στα παλιά λογισμικά. Αφενώς γιατί υπήρχαν ανάμεσά τους κάποια απλά και καλά εκπαιδευτικά προγράμματα (ενδεικτικά θυμάμαι απλό flashάκι αντιστοίχισης περιφερειακών συσκευών ή τοποθέτησης καρτών στην μητρική ή απλός μετατροπέας δυαδικού συστήματος). Βέβαια είναι πλέον ξεπερασμένα σε αυτά που δείχνουν ,αλλά εάν δεν έχουν αντικατασταθεί από κάτι αντίστοιχο στο photodentro τότε είναι ακόμα χρήσιμα. Επίσης, μην ξεχνάμε και το all time classic πρόβλημα των σχολείων ... το "δεν έχουμε internet σήμερα". Ωραίο το να τα έχουμε όλα στο internet, αλλά πρέπει να έχουμε και μερικές offline εναλλακτικές γιατί το πέφτει το δίκτυο για τον Α ή τον Β λόγο στο σχολείο, είναι ακόμα πολύ συχνό φαινόμενο.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5106
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Μέλλον εκπαιδευτικών λογισμικών ΠΙ (flash/java)
« Απάντηση #4 στις: 11 Νοέ 2019, 08:16:35 πμ »
Το flash συνεχίζει ακόμα να παίζει μέχρι το τέλος του 2020.
Η java έχει κοπεί από τον firefox 52 και μετά.
Όμως έχει βγει ένας νέος browser ονόματι pale moon που βασίζεται στον firefox και συνεχίζει να υποστηρίζει τα plugins τεχνολογίας NPAPI, δηλαδή και το flash και την java.

Και πάλι όμως η ρύθμιση της java ώστε να παίζει στον pale moon είναι λίγο δύσκολη, οπότε την αναφέρω παρακάτω. Δοκιμασμένο σε Ubuntu 18.04:

Λήψη του pale moon από https://software.opensuse.org/download.html?project=home:stevenpusser&package=palemoon
Μιας και το θέλουμε μόνο για τα εκπαιδευτικά λογισμικά και όχι για browsing, μπορούμε να επιλέξουμε το .deb και όχι το αποθετήριο.
Εγκατάσταση με: sudo apt install ./palemoon_28.7.2+repack-1_amd64.deb
Μετά μενού Σύστημα → Προτιμήσεις → Άλλα → Oracle Java 8 Plugin Control Panel
Security → Edit site list
Προσθέτουμε http://ts.sch.gr
Κλείνουμε, τρέχουμε τον pale moon, πάμε στο http://ts.sch.gr/software → Μαθηματικά Γ΄-Δ΄ → Χελωνοσελίδα.
Βγαίνει security prompt, επιλέγουμε [x] I accept the risk and want to run this application, και πατάμε [Run].
Block potentially unsafe components from being run? [Don't Block]
Do you want to run this application? [Run]

...και επιτέλους βλέπουμε java εν έτει 2019. :)