Αποστολέας Θέμα: Δομες Δεδομενων  (Αναγνώστηκε 615 φορές)

Δημήτρης Μαχαίρας

  • Οπαδός
  • **
  • Μηνύματα: 14
Δομες Δεδομενων
« στις: 21 Μάι 2018, 04:16:02 μμ »
Μπορεί κάποιος να με βοηθήσει στην Άσκηση 45 ?

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Δομες Δεδομενων
« Απάντηση #1 στις: 21 Μάι 2018, 08:43:45 μμ »
έβαλα κατά λάθος εδώ απάντηση για το μαγικό τετράγωνο, και την μετάφερα εκεί που έπρεπε

Δημήτρης Μαχαίρας

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Δομες Δεδομενων
« Απάντηση #2 στις: 21 Μάι 2018, 08:55:14 μμ »
Ευχαριστώ!

tasospap

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Δομες Δεδομενων
« Απάντηση #3 στις: 21 Μάι 2018, 09:55:48 μμ »
ΠΡΟΓΡΑΜΜΑ ΔΟΜΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Π[30], Κ,Λ,Σ,Σ_ΜΑΧ,ΠΛ,ΠΛ_ΜΑΧ
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
    ΔΙΑΒΑΣΕ Π[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Σ_ΜΑΧ <-- 0
  ΠΛ_ΜΑΧ <-- 0   
  ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 30
    Κ <-- 30
    ΑΝ Κ>Λ ΤΟΤΕ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        Σ <-- 0
        ΠΛ <-- 0
        ΓΙΑ Ι ΑΠΟ Λ ΜΕΧΡΙ Κ
          Σ <-- Σ+Π[Ι]
          ΠΛ <-- ΠΛ+1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΝ Σ>Σ_ΜΑΧ ΤΟΤΕ
          Σ_ΜΑΧ <-- Σ
          ΠΛ_ΜΑΧ <-- ΠΛ
        ΤΕΛΟΣ_ΑΝ
        Κ <-- Κ-1
      ΜΕΧΡΙΣ_ΟΤΟΥ Κ=Λ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
  ΓΡΑΨΕ Σ_ΜΑΧ, ΠΛ_ΜΑΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Η λογική είναι η εξής:
Βρίσκω όλους τους πιθανούς συνδυασμούς αθροισμάτων που ξεκινούν με το Π[1].
π.χ. Π[1]+Π[2].....+Π[30]
       Π[1]+Π[2].....+Π[29]
       Π[1]+Π[2].....+Π[28]
......................................
       Π[1]+Π[2]+Π[3]
       Π[1]+Π[2]

στη συνέχεια κάνω το ίδιο για το Π[2] και κτλ.

       Π[2]+Π[3].....+Π[30]
       Π[2]+Π[3].....+Π[29]
       Π[2]+Π[3].....+Π[28]
......................................
       Π[2]+Π[3]+Π[4]
       Π[2]+Π[3]


Κάθε άθροισμα που βρίσκω το συγκρίνω με το Σ_ΜΑΧ και μετράω το πλήθος των όρων από το οποίο αποτελείται.




« Τελευταία τροποποίηση: 25 Μάι 2018, 01:39:37 μμ από tasospap »

Δημήτρης Μαχαίρας

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Δομες Δεδομενων
« Απάντηση #4 στις: 22 Μάι 2018, 08:25:49 πμ »
Ευχαριστώ!

Δημήτρης Μαχαίρας

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Δομες Δεδομενων
« Απάντηση #5 στις: 25 Μάι 2018, 12:13:32 μμ »
Γιατί ξεκινάς το Κ με 5 ?

Δημήτρης Μαχαίρας

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Δομες Δεδομενων
« Απάντηση #6 στις: 25 Μάι 2018, 12:17:47 μμ »
Άκυρη ερώτηση δεν είχα διαβάσει καλά την εκφώνηση!

tasospap

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Δομες Δεδομενων
« Απάντηση #7 στις: 25 Μάι 2018, 01:40:20 μμ »

Το Κ πρέπει να ξεκινάει από 30.   Έκανα δοκιμές με 5 τιμές στον πίνακα και ξέχασα να το αλλάξω.  8)

Δημήτρης Μαχαίρας

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Δομες Δεδομενων
« Απάντηση #8 στις: 25 Μάι 2018, 01:58:32 μμ »
Γιαυτο κάτι δεν μου πηγενε καλα ....      οκ!