Αποστολέας Θέμα: Επαναληπτικό διαγώνισμα  (Αναγνώστηκε 1554 φορές)

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 646
Επαναληπτικό διαγώνισμα
« στις: 28 Μάι 2018, 11:35:29 πμ »
καλημέρα σε όλους

ανεβάζω και εγώ ένα επαναληπτικό διαγώνισμα για να υπάρχει ποικιλία  :angel: >:D :police:  προσπάθησα να είναι στο πνεύμα των εξετάσεων, το Γ και το Β2 είναι τα πιο δύσκολα νομίζω

αν έχετε κάποιες παρατηρήσεις ή μου έχει ξεφύγει κάτι παρακαλώ ενημερώστε με

Μανώλης

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 184
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #1 στις: 28 Μάι 2018, 12:30:24 μμ »
καλημέρα σε όλους

ανεβάζω και εγώ ένα επαναληπτικό διαγώνισμα για να υπάρχει ποικιλία  :angel: >:D :police:  προσπάθησα να είναι στο πνεύμα των εξετάσεων, το Γ και το Β2 είναι τα πιο δύσκολα νομίζω

αν έχετε κάποιες παρατηρήσεις ή μου έχει ξεφύγει κάτι παρακαλώ ενημερώστε με

Μανώλης

ωραιο το θεμα γ

τροποποιηση:στο θεμα γ στη λυση υπαρχει ενα μικρο λαθακι που δεν επηρρεαζει τα αποτελεσματα αλλα παραμενει λαθος.δεν το διορθωνω επιτηδες οποιος το βρει να το πει
« Τελευταία τροποποίηση: 31 Μάι 2018, 10:36:38 μμ από Κωστας τζιαννης »

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 54
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #2 στις: 04 Ιούν 2018, 01:29:14 μμ »
Στο Α3 η λυση ειναι με χρηση νεων μεταβλητων ή πρεπει να χρησιμοποιηθουν μονο τα κ, λ , μ ?

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 646
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #3 στις: 04 Ιούν 2018, 03:19:24 μμ »
Στέλλα καλησπέρα

Δεν ξέρω αν λύνεται δίχως νέα μεταβλητή, εγώ αυτό που έχω στο μυαλό μου απαιτεί νέα μεταβλητή

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 184
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #4 στις: 04 Ιούν 2018, 04:28:29 μμ »
Στέλλα καλησπέρα

Δεν ξέρω αν λύνεται δίχως νέα μεταβλητή, εγώ αυτό που έχω στο μυαλό μου απαιτεί νέα μεταβλητή


  ΔΙΑΒΑΣΕ κ, λ, μ
  ΑΝ κ > 0 ΤΟΤΕ
    λ <- -1 !το κανω αρνητικο=-1
    μ <- -1
    ΓΡΑΨΕ "Α"
  ΤΕΛΟΣ_ΑΝ
  ΑΝ λ > 0 ΤΟΤΕ
    κ <- -1
    μ <- -1
    ΓΡΑΨΕ "Α"
  ΤΕΛΟΣ_ΑΝ
  ΑΝ μ > 0 ΤΟΤΕ
    κ <- -1
    λ <- -1
    ΓΡΑΨΕ "Α"
  ΤΕΛΟΣ_ΑΝ

ΕΤΣΙ λοιπον αν ενα τουλαχιστον απο τα κ,λ,μ>0 τοτε θα γραψει το Α μονο μια φορα.πχ αν το κ ειναι θετικο τοτε θα κανει το λ,μ=-1 θα γραψει το Α και δεν θα μπει σε καμια αλλη ΑΝ αφου πια και το λ και το μ ειναι ισα με -1<0.τελος δεν χρειαζονταν και οι 2 εκχωρησεις
κ<--1 και λ<--1 σε ολες τις αν.απλα τις αφησα για να ειναι πιο κατανοητο

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 184
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #5 στις: 04 Ιούν 2018, 04:39:18 μμ »
μια διαφορετικη λυση με την ιδια φιλοσοφια απλα με την αναποδη διαδικασια ειναι αυτη

 ΔΙΑΒΑΣΕ κ, λ, μ
  ΑΝ κ > 0 ΤΟΤΕ
    μ <- 1 !το κανω 1

     
  ΤΕΛΟΣ_ΑΝ
  ΑΝ λ > 0 ΤΟΤΕ
    μ <-1

   
  ΤΕΛΟΣ_ΑΝ
  ΑΝ μ > 0 ΤΟΤΕ

    ΓΡΑΨΕ "Α"
  ΤΕΛΟΣ_ΑΝ

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 646
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #6 στις: 04 Ιούν 2018, 05:53:10 μμ »
Το μόνο μειοεκτημα είναι πως αλλάζεις τιμή στις μεταβλητές...στο συγκεκριμένο δεν ζητάει κάτι άλλο,αν όμως ήθελε πχ και τις αρχικές τιμές των μεταβλητών ίσως υπάρχει θέμα...εγώ έχου στο νου μου το ακόλουθο

Έλεγχος<-- αληθής
Αν κ>0 τότε
  Γράψε 'α'
  Έλεγχος<--ψευδής
Τέλος_αν
Αν λ>0 και έλεγχος=αληθής τότε
   Γράψε 'α'
   Έλεγχος<--ψευδής
Τέλος_αν
Αν μ>0 και έλεγχος=αληθής τότε
  Γράψε 'α'
Τέλος_αν

Η λογική μεταβλητή ελέγχει αν έχει γίνει έίσοδος σε κάποιο αν.... ξαναλέω η δική μου εκδοχή δίχως να αλλάξουν τιμές τα κ,μ,λ

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 184
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #7 στις: 04 Ιούν 2018, 06:04:30 μμ »
Το μόνο μειοεκτημα είναι πως αλλάζεις τιμή στις μεταβλητές...στο συγκεκριμένο δεν ζητάει κάτι άλλο,αν όμως ήθελε πχ και τις αρχικές τιμές των μεταβλητών ίσως υπάρχει θέμα...εγώ έχου στο νου μου το ακόλουθο

Έλεγχος<-- αληθής
Αν κ>0 τότε
  Γράψε 'α'
  Έλεγχος<--ψευδής
Τέλος_αν
Αν λ>0 και έλεγχος=αληθής τότε
   Γράψε 'α'
   Έλεγχος<--ψευδής
Τέλος_αν
Αν μ>0 και έλεγχος=αληθής τότε
  Γράψε 'α'
Τέλος_αν

Η λογική μεταβλητή ελέγχει αν έχει γίνει έίσοδος σε κάποιο αν.... ξαναλέω η δική μου εκδοχή δίχως να αλλάξουν τιμές τα κ,μ,λ

ναι το καταλαβα οταν ειπες οτι εχεις στο μυαλο σου λυση με εξτρα μεταβλητη.απλα το εκανα ετσι για να μην βαλω στην αν συνθηκη με και ή η παρα μονο τις αρχικες συνθηκες της αρχικης εκδοσης που πρεπει να σπασουν σε 3 αν.γενικα μπραβο για το διαγωνισμα απο τα καλυτερα που εχω δει εδω μεσα

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 646
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #8 στις: 04 Ιούν 2018, 09:35:38 μμ »
Σε ευχαριστώ πολύ ... βέβαια όλα τα διαγωισμςτα των συναδέλφων είναι εξαιρετικά εδώ μέσα νομίζω

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 646
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #9 στις: 04 Ιούν 2018, 09:36:28 μμ »
Σε ευχαριστώ πολύ ... βέβαια όλα τα διαγωνίσματα των συναδέλφων είναι εξαιρετικά εδώ μέσα νομίζω

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 115
Απ: Επαναληπτικό διαγώνισμα
« Απάντηση #10 στις: 06 Ιούν 2018, 04:14:11 μμ »
σε τέτοια προβλήματα εγώ τους προτείνω πρώτα να διώξουν τους λογικούς τελεστές:

αν κ>0 τότε
  γράψε 'α'
αλλιώς_αν λ>0 τότε
  γράψε 'α'
αλλιώς_αν μ>0 τότε
  γράψε 'α'
τέλος_αν

και μετά  να μετατρέψουν την πολλαπλή σε απλές, αναγνωρίζοντας ότι κάθε αλλιώς υποδηλώνει την απόρριψη των προηγούμενων συνθηκών:

αν κ>0 τότε
  γράψε 'α'
τέλος_αν
αν όχι κ>0 και λ>0 τότε
  γράψε 'α'
τέλος_αν
αν όχι κ>0 και όχι λ>0 και μ>0 τότε
  γράψε 'α'
τέλος_αν

.
.
.
.
.
.

πάντως μια αποδεκτή λύση θα ήταν και η εξής:
 :D

αν κ>0 ή λ>0 ή μ>0 τότε
  γράψε 'α'
τέλος_αν
αν κ=1 και κ=2 τότε
  γράψε 'δεν παίζει'
τέλος_αν
αν λ=μ και λ<>μ τότε
  γράψε 'στον αιώνα τον άπαντα'
τέλος_αν