Αποστολέας Θέμα: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι  (Αναγνώστηκε 4436 φορές)

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Επαναληπτικό Διαγώνισμα για την Ανάπτυξη Εφαρμογών (2016-2017).

-- από την Ομάδα Διαγωνισμάτων του Στεκιού

Αναρτήθηκε μία εκδοχή λύσεων - Τετάρτη 31-05-2017
« Τελευταία τροποποίηση: 31 Μάι 2017, 05:39:40 μμ από bagelis »

morfeus

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 588
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #1 στις: 25 Μάι 2017, 08:49:09 μμ »
μπράβο στους συγγραφείς που κρατάνε ψηλά την σημαία του μαθήματος σε πείσμα των καιρών και των συνθηκών στη δευτεροβάθμια..
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1459
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #2 στις: 25 Μάι 2017, 09:11:14 μμ »
Συγχαρητήρια στην ομάδα για την προσφορά και τη συνέπεια τόσων χρόνων. Λυπάμαι που δεν είχα καθόλου χρόνο αυτή τη χρονιά να συνεισφέρω.
Ένα μεγάλο μπράβο στους συναδέλφους που αφιέρωσαν εθελοντικά μεγάλο προσωπικό χρόνο και πολύ μεράκι για να φέρουν εις πέρας ένα πραγματικά δύσκολο (ειδικά για φέτος) έργο.  :)
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4289
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #3 στις: 25 Μάι 2017, 10:38:21 μμ »
Συγχαρητήρια στην ομάδα που τα κατάφερε και πάλι παρ' όλες τις δυσκολίες! :)

ΚΑΛΟΓΙΑΝΝΗΣ ΝΕΣΤΟΡΑΣ

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 29
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #4 στις: 26 Μάι 2017, 10:51:52 πμ »
Συγχαρητήρια για ακόμα μια φορά !!!!!
Τις λύσεις πότε θα τις έχουμε????

lxart

  • Βετεράνος
  • ****
  • Μηνύματα: 72
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #5 στις: 26 Μάι 2017, 01:03:08 μμ »
Τα θέματα αυτά αφορούν ίσως μια κλειστή κοινότητα ασχολούμενων με τον προγραμματισμό, ένα φροντιστήριο για πολύ καλούς μαθητές, κάποιους "τρελαμένους" με το μάθημα ΑΕΠΠ, γι' αυτό και τα πολλά συγχαρητήρια.
ΔΕΝ έχουν σχέση όμως με θέματα πανελλαδικών εξετάσεων, ΔΕΝ απευθύνονται σε ΟΛΟΥΣ του μαθητές που διδάσκονται το μάθημα ΑΕΠΠ. ΔΕΝ έχουν σαφήνεια και προσιτότητα από έναν ΜΕΣΟ μαθητή Γ Λυκείου.
Π.Χ. "4.   Εάν έναν αριθμό του δυαδικού συστήματος τον ολισθήσουμε αριστερά και κατόπιν τον ίδιο αρχικό αριθμό τον ολισθήσουμε δεξιά τα δύο αποτελέσματα διαφέρουν κατά τέσσερα."
!!!!!!!!!!!!!!!! Είναι αυτή ερώτηση Σ-Λ για Πανελλήνιες
Λυπάμαι....

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #6 στις: 26 Μάι 2017, 02:21:02 μμ »
@lxart
ξεκαθαρίζοντας ότι η άποψή μου είναι προσωπική, ούτε της κοινότητας, ούτε της ομάδας διαγωνισμάτων:

έχεις απόλυτο δίκιο στο μεγαλύτερο μέρος του μηνύματός σου. τα θέματα αυτά αφορούν 100% τις ομάδες που ανέφερες και από εκεί και πέρα αφορούν, σε διαφορετικό ποσοστό, και όλους τους υπόλοιπους εκπαιδευτικούς και μαθητές.

η διαχρονική πρόθεση στο στέκι είναι να μην φτιάξει ένα ακόμα διαγώνισμα πανελληνίων, όπως κυκλοφορούν χιλιάδες άλλα στο διαδίκτυο τώρα πια. αλλά είναι να αναδείξει την αλγοριθμική σκέψη, την φιλοσοφία της επιστήμης μας, και να δείξει την αληθινή κατεύθυνση που πιστεύει η εδώ κοινότητα ότι θα έπρεπε να πάρει το μάθημα. Όλα αυτά βέβαια με προϋποθέσεις που αυτή τη στιγμή δεν υπάρχουν στην δευτεροβάθμια εκπαίδευση αλλά δεν σημαίνει ότι δεν μπορούμε να τις επιζητούμε.

τέλος το διαγώνισμα διατίθεται ανοιχτό, ακριβώς για να μπορεί ο κάθε ενδιαφερόμενος να πάρει μόνο όσα κομμάτια κρίνει χρήσιμα και να τα χρησιμοποιήσει έτσι όπως είναι ή αλλαγμένα.

« Τελευταία τροποποίηση: 26 Μάι 2017, 03:03:22 μμ από bagelis »

morfeus

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 588
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #7 στις: 26 Μάι 2017, 04:01:27 μμ »
Τα θέματα αυτά αφορούν ίσως μια κλειστή κοινότητα ασχολούμενων με τον προγραμματισμό, ένα φροντιστήριο για πολύ καλούς μαθητές, κάποιους "τρελαμένους" με το μάθημα ΑΕΠΠ, γι' αυτό και τα πολλά συγχαρητήρια.
ΔΕΝ έχουν σχέση όμως με θέματα πανελλαδικών εξετάσεων, ΔΕΝ απευθύνονται σε ΟΛΟΥΣ του μαθητές που διδάσκονται το μάθημα ΑΕΠΠ. ΔΕΝ έχουν σαφήνεια και προσιτότητα από έναν ΜΕΣΟ μαθητή Γ Λυκείου.
Π.Χ. "4.   Εάν έναν αριθμό του δυαδικού συστήματος τον ολισθήσουμε αριστερά και κατόπιν τον ίδιο αρχικό αριθμό τον ολισθήσουμε δεξιά τα δύο αποτελέσματα διαφέρουν κατά τέσσερα."
!!!!!!!!!!!!!!!! Είναι αυτή ερώτηση Σ-Λ για Πανελλήνιες
Λυπάμαι....

αν κάποιοι δεν διατηρούσαν το υψηλό επίπεδο του μαθήματος εδώ και χρόνια, το μάθημα, ίσως, να μην υπήρχε τώρα. Δεν φταίνε πάντα οι εξωτερικοί (αόρατοι και ορατοί) εχθροί..
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

jtsi3

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #8 στις: 26 Μάι 2017, 06:38:45 μμ »
Για τα μαθήματα του ΕΠΑΛ θα βγάλετε διαγωνίσματα;

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #9 στις: 26 Μάι 2017, 09:16:50 μμ »
Δεχόμαστε σαν σωστή λύση στο Β2 την επισυναπτόμενη ενός μαθητή μου;
Βρίσκει την απάντηση αλλά μόνο για αυτή τη συνάρτηση και για εκείνες τις συναρτήσεις στις οποίες στο δοθέν διάστημα το δεξι άκρο έχει θετική τιμή και το αριστερό αρνητική;
( Το γράφω όπως μου το υπαγορεύει ο ίδιος. Ρωτάει αν θα έπαιρνε όλες τις μονάδες του ερωτήματος )
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #10 στις: 26 Μάι 2017, 09:21:56 μμ »
νομίζω ότι στο εμφωλευμένο ΑΝ θα έπρεπε να τα έχει αντίθετα..... είναι πολύ κοντά πάντως....

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2910
  • to Iterate is human to Recurse divine
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #11 στις: 26 Μάι 2017, 09:43:35 μμ »
Μια λύση για το Α3 για πίνακα ΝxN σε ψευδογλώσσα
Κώδικας: Pascal
  1. start <-- 1
  2. end <-- Ν
  3. step <-- 1
  4. κ <-- 1
  5. Για i από 1 μέχρι Ν
  6.     Για j από start μέχρι end με_βήμα step
  7.           Α[i,j] <-- κ
  8.           κ <- κ + 1
  9.     Τέλος_Επανάληψης
  10.     Αντιμετάθεσε start, end
  11.     step <-- step *(-1)
  12. Τέλος_Επανάληψης
  13.  
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

sstauross

  • Θαμώνας
  • ***
  • Μηνύματα: 22
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #12 στις: 26 Μάι 2017, 09:51:20 μμ »
Επαναληπτικό Διαγώνισμα για την Ανάπτυξη Εφαρμογών (2016-2017).

-- από την Ομάδα Διαγωνισμάτων του Στεκιού

Υπάρχουν κάπου οι λύσεις του διαγωνίσματος;

pfan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 101
  • ...
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #13 στις: 26 Μάι 2017, 09:56:31 μμ »
Ευχαριστούμε την ομάδα!!!!!!

Ξέρουμε εδώ και χρόνια ότι δεν είναι θέματα πανελλαδικών τα διαγωνίσματα από το Στέκι... ίσως για αυτό να χρειάζεται να πούμε ακόμη ένα ευχαριστώ....

Καλή συνέχεια. ;)
 
Πύρζα Φανή
Μηχανικός Η/Υ Συστημάτων
Καθηγήτρια Πληροφορικής

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #14 στις: 26 Μάι 2017, 10:10:13 μμ »
Υπάρχουν κάπου οι λύσεις του διαγωνίσματος;
οι λύσεις θα αναρτηθούν κάποια στιγμή από Δευτέρα μέχρι Τετάρτη....

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 36
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #15 στις: 26 Μάι 2017, 10:20:33 μμ »
Μία λύση για το Α3 μετά από κάμποση σκέψη:

Για i από 1 μέχρι 6
  Για j από 1 μέχρι 8
    A[i, j] <- (i - i mod 2)*8 + 1 - i mod 2 - (-1)^i * j
  Τέλος_επαναληψης
Τέλος_επαναληψης

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2074
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #16 στις: 26 Μάι 2017, 11:32:22 μμ »
Παραπλήσια με του Ευρυπίδη

x <-- 0
step <-- 1
Για i από 1 μέχρι 6
     Αν i mod 2 = 0 τότε
          begin <-- 1
           end <-- 8
     Αλλιώς
          begin <-- 8
          end <-- 1
     Τέλος_Αν
     Για j από begin μέχρι end με βήμα step
          x <-- x + 1
          A[i,j] <-- x
     Τέλος_Επανάληψης
     step <-- step * (-1)
Τέλος_Επανάληψης   
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

http://petrosp13.blogspot.com/

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #17 στις: 26 Μάι 2017, 11:41:02 μμ »
νομίζω ότι στο εμφωλευμένο ΑΝ θα έπρεπε να τα έχει αντίθετα..... είναι πολύ κοντά πάντως....
Ναι έχετε δίκαιο.
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

DmitrijPyc

  • Νέος
  • *
  • Μηνύματα: 8
    • Barracuda
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #18 στις: 27 Μάι 2017, 08:13:31 μμ »
Το β2)
ΠΡΟΓΡΑΜΜΑ  Α3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΙΔ,ΡΙΖΑ,Α,Β
  ΛΟΓΙΚΕΣ: ΦΛΑΓ
ΑΡΧΗ
  Ι <-- 0
  ΦΛΑΓ <-- ΨΕΥΔΗΣ
  ΔΙΑΒΑΣΕ Α,Β
  ΜΙΔ <-- (Α+Β)/2
  ΟΣΟ Ι<=100 ΚΑΙ ΦΛΑΓ=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ   
    Ι <-- Ι+1
    ΑΝ 3*ΜΙΔ^2+2*ΜΙΔ-3=0 ΤΟΤΕ
      ΦΛΑΓ <-- ΑΛΗΘΗΣ
      ΡΙΖΑ <-- ΜΙΔ
    ΑΛΛΙΩΣ_ΑΝ (3*ΜΙΔ^2+2*ΜΙΔ-3)*(3*Α^2+2*Α-3)<0 ΤΟΤΕ
      Β <-- ΜΙΔ
    ΑΛΛΙΩΣ
      Α <-- ΜΙΔ
    ΤΕΛΟΣ_ΑΝ
    ΜΙΔ <-- (Α+Β)/2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΦΛΑΓ=ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'ΒΡΕΘΗΚΕ Η ΡΙΖΑ.Η ΡΙΖΑ ΕΙΝΑ=',ΡΙΖΑ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


                                 

epsilonXi

  • Βετεράνος
  • ****
  • Μηνύματα: 75
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #19 στις: 27 Μάι 2017, 08:22:45 μμ »
ας πω κι εγώ την εξυπνάδα μου:

νούμερο1:
για χ από 1 μέχρι 5 με βήμα 2
  μ <-- (χ-1)*8
  χχ <-- χ+1
  ζ <-- χχ*8+1
  για ψ από 1 μέχρι 8
    Α[χ,ψ] <-- μ + ψ
    Α[χχ,ψ] <-- ζ - ψ
  τέλος_επανάληψης
τέλος_επανάληψης


νούμερο2:
τ <-- 0
εδώ <-- 1
εκεί <-- 8
β <-- 1
για χ από 1 μέχρι 6
  για ψ από εδώ μέχρι εκεί με βήμα β
    τ <-- τ + 1
    Α[χ,ψ] <-- τ
  τέλος_επανάληψης
  αντιμετάθεσε εδώ, εκεί
  β <-- -β
τέλος_επανάληψης

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #20 στις: 27 Μάι 2017, 11:55:15 μμ »
Ζητώ συγγνώμη που αναρτω το παρακάτω σε αυτό το θέμα αλλά... για τον παρακάτω πίνακα πως θα ήταν ένας όμορφος κωδικας;

1   2   3   4   5   6   7   8
17   18   19   20   21   22   23   24
33   34   35   36   37   38   39   40
48   47   46   45   44   43   42   41
32   31   30   29   28   27   26   25
16   15   14   13   12   11   10   9
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

epsilonXi

  • Βετεράνος
  • ****
  • Μηνύματα: 75
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #21 στις: 28 Μάι 2017, 12:25:57 πμ »
για κομψότητα δεν ξέρω, αλλά η πρώτη μου σκέψη βασίζεται στην προηγούμενη, οπότε τι λες για τούτο δω:

γ <-- 435261
τ <-- 0
εδώ <-- 1
εκεί <-- 8
β <-- 1
για χ από 1 μέχρι 6
  δ <-- γ mod 10
  για ψ από εδώ μέχρι εκεί με βήμα β
    τ <-- τ + 1
    Α[δ,ψ] <-- τ
  τέλος_επανάληψης
  αντιμετάθεσε εδώ, εκεί
  β <-- -β
  γ <-- γ div 10
τέλος_επανάληψης

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #22 στις: 28 Μάι 2017, 12:32:32 πμ »
για κομψότητα δεν ξέρω, αλλά η πρώτη μου σκέψη βασίζεται στην προηγούμενη, οπότε τι λες για τούτο δω:

γ <-- 435261
τ <-- 0
εδώ <-- 1
εκεί <-- 8
β <-- 1
για χ από 1 μέχρι 6
  δ <-- γ mod 10
  για ψ από εδώ μέχρι εκεί με βήμα β
    τ <-- τ + 1
    Α[δ,ψ] <-- τ
  τέλος_επανάληψης
  αντιμετάθεσε εδώ, εκεί
  β <-- -β
  γ <-- γ div 10
τέλος_επανάληψης
Σ'αγαπώ epsilonXi.....
 Τι λες τώρα;
δ<--γ mod 10
Και πιο πάνω αυτό το υπέροχο γ<--435261
Με αυτό το κόλπο το κάνεις ότι θες!!
Respect

Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

ether

  • Επισκέπτης
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #23 στις: 28 Μάι 2017, 09:25:14 πμ »
Ζητώ συγγνώμη που αναρτω το παρακάτω σε αυτό το θέμα αλλά... για τον παρακάτω πίνακα πως θα ήταν ένας όμορφος κωδικας;

1   2   3   4   5   6   7   8
17   18   19   20   21   22   23   24
33   34   35   36   37   38   39   40
48   47   46   45   44   43   42   41
32   31   30   29   28   27   26   25
16   15   14   13   12   11   10   9
Κώδικας: [Επιλογή]
  τιμη <- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 8
      τιμη <- τιμη + 1
      Α[i, j] <- τιμη
      Α[6 + 1 - i, 8 + 1 - j] <- τιμη + 8
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    τιμη <- τιμη + 8
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ether

  • Επισκέπτης
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #24 στις: 28 Μάι 2017, 10:40:14 πμ »
Μια λύση για το Α3
Κώδικας: [Επιλογή]
  τιμη <- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΜΕ_ΒΗΜΑ 2
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 8
      τιμη <- τιμη + 1
      Α[i, j] <- τιμη
      Α[i + 1, 8 + 1 - j] <- τιμη + 8
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    τιμη <- τιμη + 8
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Και γενικά για πίνακα με ΓΡΑΜΜΕΣ γραμμές και ΣΤΗΛΕΣ στήλες
Κώδικας: [Επιλογή]
  τιμη <- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ (ΓΡΑΜΜΕΣ - 1) + (ΓΡΑΜΜΕΣ mod 2) ΜΕ_ΒΗΜΑ 2
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ ΣΤΗΛΕΣ
      τιμη <- τιμη + 1
      Α[i, j] <- τιμη
      ΑΝ i < ΓΡΑΜΜΕΣ ΤΟΤΕ
        Α[i + 1, ΣΤΗΛΕΣ + 1 - j] <- τιμη + ΣΤΗΛΕΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    τιμη <- τιμη + ΣΤΗΛΕΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

mana

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #25 στις: 28 Μάι 2017, 06:12:13 μμ »
Και του χρόνου με υγεία.
A3
 ΓΙΑ ΓΡ ΑΠΟ 1 ΜΕΧΡΙ 5 ΜΕ_ΒΗΜΑ 2
    ΓΙΑ ΣΤ ΑΠΟ 1 ΜΕΧΡΙ 8
      Π[ΓΡ, ΣΤ] <- (ΓΡ - 1)*8 + ΣΤ
      Π[ΓΡ + 1, ΣΤ] <- (ΓΡ + 1)*8 + 1 - ΣΤ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

mana

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #26 στις: 29 Μάι 2017, 08:45:31 πμ »
για κομψότητα δεν ξέρω, αλλά η πρώτη μου σκέψη βασίζεται στην προηγούμενη, οπότε τι λες για τούτο δω:
ο τρόπος με το γ είναι πολύ όμορφος, γενικός, με μεγάλο εύρος εφαρμογών και εξαιρετικής εκπαιδευτικής αξίας. Συγχαρητήρια.
Παραθέτω μια τροποποίηση που βασίζεται στον δικό σου τρόπο.
! ΠΑΡΑΛΛΑΓΗ
γ ← 435261
τ ← 0
εδώ ← 1
εκεί ← 8
β ← 1
Για χ από 1 μέχρι 6
  δ ← (γ div 10^(χ - 1)) mod 10
  Για ψ από εδώ μέχρι εκεί με βήμα β
    τ ← τ + 1
    α[δ, ψ] ← τ
  Τέλος_επανάληψης
  β ← -β
  εδώ ← εδώ - β*7
  εκεί ← εκεί + β*7
Τέλος_επανάληψης

Και ένα άλλο άσχετο με την προηγούμενη λύση:
 ! Β ΤΡΟΠΟΣ
ΤΙΜΗ ← -16
Για ΓΡ από 1 μέχρι 3
  ΤΙΜΗ ← ΤΙΜΗ + 16
  Για ΣΤ από 1 μέχρι 8
    Π[ΓΡ, ΣΤ] ← ΤΙΜΗ + ΣΤ
    Π[ΓΡ + 3, ΣΤ] ← 49 - Π[ΓΡ, ΣΤ]
  Τέλος_επανάληψης
Τέλος_επανάληψης


nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #27 στις: 29 Μάι 2017, 01:01:19 μμ »
Στο Δ θέμα και στο ερώτημα Δ1.3 όσον αφορά τους 10 καλύτερους, στην τελική κατάταξη μπορεί το ίδιο όνομα να εμφανίζεται και περισσότερες από μία φορές ή θα χρειαστεί να βρούμε μοναδικα ονόματα με τη χρήση συχνοτήτων εμφάνισης;
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

Λάμπρος Παπαδόπουλος

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #28 στις: 29 Μάι 2017, 02:13:57 μμ »
Όπως το διαβάζω είναι μοναδικά ονόματα. Αλλά πίνακες συχνοτήτων γιατί; Σαν insertion sort μου φαίνεται. Αν μεταφράζω καλά το απευθείας...
« Τελευταία τροποποίηση: 30 Μάι 2017, 12:30:15 πμ από Λάμπρος Παπαδόπουλος »

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #29 στις: 29 Μάι 2017, 04:52:49 μμ »
Στο Δ θέμα και στο ερώτημα Δ1.3 όσον αφορά τους 10 καλύτερους, στην τελική κατάταξη μπορεί το ίδιο όνομα να εμφανίζεται και περισσότερες από μία φορές ή θα χρειαστεί να βρούμε μοναδικα ονόματα με τη χρήση συχνοτήτων εμφάνισης;
Στους δέκα καλύτερους παίκτες στη διάρκεια του έτους επιτρέπεται ο ίδιος παίκτης να υπάρχει πολλές φορές εφόσον έχει κάνει σκορ τέτοια που να μπαίνουν στο ετήσιο top ten.

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #30 στις: 29 Μάι 2017, 05:11:17 μμ »
Στους δέκα καλύτερους παίκτες στη διάρκεια του έτους επιτρέπεται ο ίδιος παίκτης να υπάρχει πολλές φορές εφόσον έχει κάνει σκορ τέτοια που να μπαίνουν στο ετήσιο top ten.
Ωραία!!
Σαν τα παιχνίδια που παίζαμε μικροί (ή μεγαλοι ) στα φλιπερακια (ή στο mame32) που μπορείς να εμφανίζεσαι στο τοπ 10 πολλές φορές  ;D

Πάντως το μοιρασα σήμερα φωτοτυπία .
Όσοι θέλουν έδωσα link να αναρτήσουν απαντησεις εδώ μέχρι να βγουν οι επισημες . Αγχωμενα τα βλέπω τα παιδιά. Θα δούμε τώρα...
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

BOUKITSA

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #31 στις: 29 Μάι 2017, 07:49:28 μμ »
pedia perimenoume tis lisis enagonios!!

Λάμπρος Παπαδόπουλος

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #32 στις: 30 Μάι 2017, 12:28:47 πμ »
Στους δέκα καλύτερους παίκτες στη διάρκεια του έτους επιτρέπεται ο ίδιος παίκτης να υπάρχει πολλές φορές εφόσον έχει κάνει σκορ τέτοια που να μπαίνουν στο ετήσιο top ten.

Αφού είναι έτσι δεν θα έπρεπε να γράφει "...δέκα παίκτες.." αλλά

"3.   Επαναλαμβάνει τα παραπάνω ερωτήματα 1 και 2, για μία περίοδο 52 εβδομάδων και στο τέλος εμφανίζει το όνομα και το σκορ για τους δέκα παίκτες που κατέχουν τις δέκα καλύτερες επιδόσεις στη διάρκεια όλου του έτους. "

ή ακόμα καλύτερα

"3.   Επαναλαμβάνει τα παραπάνω ερωτήματα 1 και 2, για μία περίοδο 52 εβδομάδων και στο τέλος εμφανίζει τα δέκα καλύτερα σκορ, στη διάρκεια όλου του έτους, και τα ονόματα των παικτών που τα πέτυχαν."   

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #33 στις: 30 Μάι 2017, 09:18:58 μμ »
Η εκφώνηση αναφέρει:
"εμφανίζει το όνομα και το σκορ για τους δέκα παίκτες που κατέχουν τις δέκα καλύτερες επιδόσεις στη διάρκεια όλου του έτους"
οπότε δεν είναι, κατά τη γνώμη μου, ασαφές.

Από εκεί και πέρα εναλλακτικές διατυπώσεις που να προσδιορίζουμε με ακόμα μεγαλύτερη ακρίβεια το νόημα, όπως οι παραπάνω που προτείνονται, είναι ευπρόσδεκτες και θα ληφθούν υπόψη σε πιθανό μελλοντικό update.

Για αυτό το λόγο συνάδελφοι είναι καλό να συμμετέχουν όσο το δυνατόν περισσότεροι στην ομάδα διαγωνισμάτων κάθε χρόνο, γιατί ο συγκερασμός όλων αυτών των απόψεων βγάζει πάντα καλύτερα αποτελέσματα.

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 476
  • There can be only one...may it be AEPP.
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #34 στις: 31 Μάι 2017, 01:27:37 μμ »
Το θέμα 3 μπορούμε να το τροποποιήσουμε κατά τέτοιο τρόπο ώστε να μπορεί αν ο πίνακας δεν είναι μαγικό τετράγωνο να αλλάζει τη σειρά των αριθμών μέχρι να ισχύουν οι προϋποθέσεις για να είναι;
Πόσους δυνατούς συνδυασμούς αριθμών μπορούμε να έχουμε;
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #35 στις: 31 Μάι 2017, 05:24:24 μμ »
Το πλήθος των αριθμών είναι Ν Χ Ν.
Έχω την αίσθηση ότι οι συνδυασμοί είναι (Ν Χ Ν) !

πολύ μεγάλος αριθμός....

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #36 στις: 31 Μάι 2017, 05:40:35 μμ »
Αναρτήθηκε μία πρώτη εκδοχή λύσεων στο αρχικό post.

http://alkisg.mysch.gr/steki/index.php?topic=7123.0

novaro

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #37 στις: 08 Ιούν 2017, 09:35:05 μμ »

Δεν συγκρίνουμε πραγματικούς με το 0 γράφοντας ΑΝ Χ =0 αλλά γράφουμε π.χ
ΑΝ Χ<0.00001 τότε βρέθηκε ρίζα.



bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 503
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #38 στις: 08 Ιούν 2017, 09:45:31 μμ »
Δεν συγκρίνουμε πραγματικούς με το 0 γράφοντας ΑΝ Χ =0 αλλά γράφουμε π.χ
ΑΝ Χ<0.00001 τότε βρέθηκε ρίζα.
???
Σε πραγματικές γλώσσες ΝΑΙ, αλλά στη ΓΛΩΣΣΑ δεν νομίζω να υφίσταται κάτι τέτοιο.

Αν εννοείς ότι θα ήταν καλό να το έχει προβλέψει η εκφώνηση του Β2 θέματος για λόγους συνέπειας με ότι δουν στο πανεπιστήμιο, αυτό είναι μια ενδιαφέρουσα άποψη.

COACH

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 120
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #39 στις: 10 Ιούν 2017, 09:01:42 πμ »
Καλημέρα σε όλους και καλή δύναμη...
Συγχαρητήρια παιδιά, πολύ καλό διαγώνισμα, πολύ εύστοχο και όχι μακριά από το πνεύμα των εξετάσεων...
Συγχαρητήρια σε όσους κρατάτε ζωντανό τον θεσμό αυτού του διαγωνίσματος και σε αυτό το επίπεδο
ΔΗΜΗΤΡΗΣ ΘΩΜΟΥ

skarkchr

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #40 στις: 10 Ιούν 2017, 05:18:34 μμ »
Συγχαρητήρια στην ομάδα!!!!

MRX

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #41 στις: 11 Ιούν 2017, 04:11:13 μμ »
ΕΡΩΤΗΣΗ στο θεμα Γ στις λυσεις λεει "ΑΝ σημαία ΤΟΤΕ", οπου σημαια μια μεταβλητη λογικου τυπου. Δεν θα επρεπε να λεει Αν "σημαία =ΑΛΗΘΗΣ τοτε" ή είναι το ιδιο πράγμα? Το κάνει και παραπάνω που λεει " ΑΝ ΟΧΙ υπάρχει(Α, αρ) ΤΟΤΕ " και με μπερδεψε λίγο.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2074
Απ: Τελικό επαναληπτικό Διαγώνισμα 2016 - 2017 από το Στέκι
« Απάντηση #42 στις: 11 Ιούν 2017, 04:22:46 μμ »
Δεν είναι απαραίτητο
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

http://petrosp13.blogspot.com/