Αποστολέας Θέμα: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων  (Αναγνώστηκε 8595 φορές)

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 185
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #60 στις: 02 Ιούν 2018, 01:27:12 μμ »
:-[Συγνώμη, όταν λέτε "ΑΣΚΗΣΗ ΚΑΛΗ!!", εννοείτε για κάποιο περιοδικό (ΣΤΑΥΡΟΛΕΞΟ, ΤΕΣΤ κλπ.), με το οποίο περνάμε την ώρα μας, η για Πανελλήνιες Εξετάσεις;
Ελπίζω να αναφέρεστε στο πρώτο.

γενικα ανεβαζω ασκησεις που μου φαινονται οτι εχουν καποιο ενδιαφερον.οταν καποια ξεφευγει απο τη λογικη των πανελληνιων το γραφω απο πανω απο την εκφωνηση.οι υπολοιπες δεν ειναι ασκησεις που θα πεσουν στις πανελληνιες ατοφιες σε καμια περιπτωση αλλα αν καποιος τις λυσει πιστευω οτι θα τον βοηθησουν πχ αυτη που λεει για ταξινομηση πινακα συμφωνα με τη συχνοτητα ή οι ακολουθιες των αριθμων που αποτελουνται απο συγκεκριμενα ψηφια (η οποια σε αναγκαζει να
φτιαξεις αλγοριθμο που βρισκει τα ψηφια ενος αριθμου) κτλ.η τελευταια ασκηση επισης που λεω "ασκηση καλη",για να τη λυσει καποιος χρειαζεται να χρησιμοποιησει πραγματα που εμαθε και τη θεωρω μετριας δυσκολιας.τις ασκησεις αυτες δεν τις ανεβαζω μονο για αυτους που δινουν πανελληνιες .δεν ειναι επαναληπτικα διαγωνισματα.ειναι ομως και για τους μαθητες της νεας σχολικης χρονιας που θα ξεκινησει κτλ.πιστευω τελικα,οτι αν τις κανει καποιος μαθητης δεν θα του ειναι αχρηστες.

Πέτρος Κ.

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 108
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #61 στις: 02 Ιούν 2018, 02:39:24 μμ »
ΑΣΚΗΣΗ ΜΕΓΙΣΤΟ ΓΙΝΟΜΕΝΟ
Δινεται πινακας ακεραιων 20 θεσεων Α[20].να φτιαξετε προγραμμα σε γλωσσα που θα εμφανιζει το μεγιστο γινομενο που μπορουμε να παρουμε αν πολλαπλασιασουμε μεταξυ τους 5 στοιχεια του πινακα.(θελω πολυ να δω καποιον να τη λυνει αυτη την ασκηση με τιμιο τροπο)

Κώδικας: [Επιλογή]
Αλγόριθμος ΓΙΝ5ΜΑΧ

!ΕΙΣΑΓΩΓΗ ΑΡΙΘΜΩΝ
ΓΡΑΨΕ "ΑΡΧΙΚΟΣ ΠΙΝΑΚΑΣ:"
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
Π[Ι] ← ΤΥΧΑΙΟΣ_ΑΚΕΡΑΙΟΣ(-20,-1)
ΓΡΑΨΕ Π[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!ΤΑΞΙΝΟΜΗΣΗ ΦΘΙΝΟΥΣΑ
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 20
ΓΙΑ Ξ ΑΠΟ 20 ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ -1
ΑΝ Π[Ξ-1] < Π[Ξ] ΤΟΤΕ
Τ ← Π[Ξ-1]
Π[Ξ-1] ← Π[Ξ]
Π[Ξ] ← Τ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ""
ΓΡΑΨΕ "ΤΑΞΙΝΟΜΗΜΕΝΟΣ ΠΙΝΑΚΑΣ:"
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
ΓΡΑΨΕ Π[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ""
ΓΡΑΨΕ "ΜΕΓΙΣΤΟ ΓΙΝΟΜΕΝΟ: "
Γ1 ← Π[1] * Π[2] * Π[3] * Π[4] * Π[5]
Γ2 ← Π[1] * Π[2] * Π[3] * Π[20] * Π[19]
Γ3 ← Π[1] * Π[20] * Π[19] * Π[18] * Π[17]

ΑΝ Γ1 > Γ2 ΚΑΙ Γ1 > Γ3 ΤΟΤΕ
ΓΡΑΨΕ Γ1
ΑΛΛΙΩΣ_ΑΝ Γ2 > Γ3 ΤΟΤΕ
ΓΡΑΨΕ Γ2
ΑΛΛΙΩΣ
ΓΡΑΨΕ Γ3
ΤΕΛΟΣ_ΑΝ

Τέλος ΓΙΝ5ΜΑΧ

Να την δυσκολέψουμε λίγο;

Παράθεση
ΑΣΚΗΣΗ ΜΕΓΙΣΤΟ ΓΙΝΟΜΕΝΟ 2
Να φτιαξετε αλγόριθμο που διαβάσει άγνωστο πλήθος πραγματικών αριθμών (η εισαγωγή θα σταματάει όταν διαβαστεί το μηδέν) και θα εμφανιζει το μεγιστο γινομενο που μπορουμε να παρουμε αν πολλαπλασιασουμε μεταξυ τους 5 αριθμούς από αυτούς που διαβάστηκαν.

taxata

  • Βετεράνος
  • ****
  • Μηνύματα: 95
  • Live long and prosper \\//
    • Πληροφορική στο ΕΠΑΛ
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #62 στις: 02 Ιούν 2018, 09:04:12 μμ »
@ Πέτρος Κ.
Δεν νομίζω ότι δουλεύει ο αλγόριθμος.
Τάσος_Χατζηπαπαδόπουλος
http://users.sch.gr/chatzipap/

bugman

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 380
  • The Bug Eater
    • Πληροφορική Προγραμματισμός
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #63 στις: 03 Ιούν 2018, 08:03:33 πμ »
θα πρέπει να εξαιρεθεί η μηδενική τιμή. (στην άσκηση να λέει για είκοσι μη μηδενικούς ακέραιους). Αλλιώς αν στους 20 αριθμούς έχουμε 16 μηδέν τότε δεν έχει λύση η άσκηση, οποιοιδήποτε 5 δίνουν γινόμενο μηδέν.

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 185
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #64 στις: 03 Ιούν 2018, 01:23:53 μμ »

ΓΡΑΨΕ ΛΑΘΟΣ
Η λυση του Πετρου ειναι ολοσωστη!!μπορει να υπαρχουν και αρνητικοι αριθμοι στον πινακα.η λυση λοιπον ειναι ολοσωστη απλα δεν ειναι ευελικτη.αν πχ δωσουμε εναν πινακα ακεραιων ενος εκατομμυριου θεσεων Α[1000000] και θελω να βρω το μεγιστο γινομενο που παιρνω αν πολλαπλασιασω μαζι 300001 στοιχεια του πινακα τοτε η λυση αυτη δε δουλευει
« Τελευταία τροποποίηση: 03 Ιούν 2018, 11:16:42 μμ από Κωστας τζιαννης »

taxata

  • Βετεράνος
  • ****
  • Μηνύματα: 95
  • Live long and prosper \\//
    • Πληροφορική στο ΕΠΑΛ
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #65 στις: 03 Ιούν 2018, 01:37:23 μμ »
Στο scrolling δεν είδα το μέρος της "φθίνουσας" ταξινόμησης θα επαναελέγξω
« Τελευταία τροποποίηση: 04 Ιούν 2018, 09:16:27 πμ από taxata »
Τάσος_Χατζηπαπαδόπουλος
http://users.sch.gr/chatzipap/

Πέτρος Κ.

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 108
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #66 στις: 03 Ιούν 2018, 06:51:40 μμ »
Η λυση του Πετρου ειναι ολοσωστη!!μπορει να υπαρχουν και αρνητικοι αριθμοι στον πινακα.η λυση λοιπον ειναι ολοσωστη απλα δεν ειναι ευελικτη.αν πχ δωσουμε εναν πινακα ακεραιων ενος εκατομμυριου θεσεων Α[1000000] και θελω να βρω το μεγιστο γινομενο που παιρνω αν πολλαπλασιασω μαζι 300001 στοιχεια του πινακα τοτε η λυση αυτη δε δουλευει

Δεν χρειαζόταν να είναι ευέλικτη. Δεν το έλεγε η άσκηση!    ???
Ο παρακάτω αλγόριθμος είναι παντως γενικότερος....  ::)

Κώδικας: [Επιλογή]
Αλγόριθμος ΓΙΝ5ΜΑΧ
ΠΠ ← 6 ! ΠΛΗΘΟΣ ΣΤΟΙΧΕΙΩΝ ΠΙΝΑΚΑ
ΠΓ ← 3 ! ΠΛΗΘΟΣ ΠΑΡΑΓΟΝΤΩΝ

!ΕΙΣΑΓΩΓΗ ΑΡΙΘΜΩΝ
ΓΡΑΨΕ "ΑΡΧΙΚΟΣ ΠΙΝΑΚΑΣ:"
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΠΠ
Π[Ι] ← ΤΥΧΑΙΟΣ_ΑΚΕΡΑΙΟΣ(-10,10)
ΓΡΑΨΕ Π[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!ΤΑΞΙΝΟΜΗΣΗ ΦΘΙΝΟΥΣΑ
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ ΠΠ
ΓΙΑ Ξ ΑΠΟ ΠΠ ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ -1
ΑΝ Π[Ξ-1] < Π[Ξ] ΤΟΤΕ
Τ ← Π[Ξ-1]
Π[Ξ-1] ← Π[Ξ]
Π[Ξ] ← Τ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ""
ΓΡΑΨΕ "ΤΑΞΙΝΟΜΗΜΕΝΟΣ ΠΙΝΑΚΑΣ:"
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΠΠ
ΓΡΑΨΕ Π[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ""
ΓΡΑΨΕ "ΜΕΓΙΣΤΟ ΓΙΝΟΜΕΝΟ: "

ΑΝ ΠΓ MOD 2 = 0 ΤΟΤΕ
Γ ← 1
Κ ← 1
ΑΛΛΙΩΣ
Γ ← Π[1]
Κ ← 2
ΤΕΛΟΣ_ΑΝ

Λ ← ΠΠ
ΓΙΑ Ι ΑΠΟ Κ ΜΕΧΡΙ ΠΓ ΜΕ_ΒΗΜΑ 2
ΑΝ Π[Κ]*Π[Κ+1] > Π[Λ]*Π[Λ-1] ΤΟΤΕ
Γ ← Γ * Π[Κ]*Π[Κ+1]
Κ ← Κ + 2
ΑΛΛΙΩΣ
Γ ← Γ * Π[Λ]*Π[Λ-1]
Λ ← Λ - 2
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ Γ

Τέλος ΓΙΝ5ΜΑΧ

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 185
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #67 στις: 03 Ιούν 2018, 11:09:59 μμ »
Δεν χρειαζόταν να είναι ευέλικτη. Δεν το έλεγε η άσκηση!    ???
Ο παρακάτω αλγόριθμος είναι παντως γενικότερος....  ::)

Κώδικας: [Επιλογή]
Αλγόριθμος ΓΙΝ5ΜΑΧ
ΠΠ ← 6 ! ΠΛΗΘΟΣ ΣΤΟΙΧΕΙΩΝ ΠΙΝΑΚΑ
ΠΓ ← 3 ! ΠΛΗΘΟΣ ΠΑΡΑΓΟΝΤΩΝ

!ΕΙΣΑΓΩΓΗ ΑΡΙΘΜΩΝ
ΓΡΑΨΕ "ΑΡΧΙΚΟΣ ΠΙΝΑΚΑΣ:"
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΠΠ
Π[Ι] ← ΤΥΧΑΙΟΣ_ΑΚΕΡΑΙΟΣ(-10,10)
ΓΡΑΨΕ Π[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!ΤΑΞΙΝΟΜΗΣΗ ΦΘΙΝΟΥΣΑ
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ ΠΠ
ΓΙΑ Ξ ΑΠΟ ΠΠ ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ -1
ΑΝ Π[Ξ-1] < Π[Ξ] ΤΟΤΕ
Τ ← Π[Ξ-1]
Π[Ξ-1] ← Π[Ξ]
Π[Ξ] ← Τ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ""
ΓΡΑΨΕ "ΤΑΞΙΝΟΜΗΜΕΝΟΣ ΠΙΝΑΚΑΣ:"
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΠΠ
ΓΡΑΨΕ Π[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ""
ΓΡΑΨΕ "ΜΕΓΙΣΤΟ ΓΙΝΟΜΕΝΟ: "

ΑΝ ΠΓ MOD 2 = 0 ΤΟΤΕ
Γ ← 1
Κ ← 1
ΑΛΛΙΩΣ
Γ ← Π[1]
Κ ← 2
ΤΕΛΟΣ_ΑΝ

Λ ← ΠΠ
ΓΙΑ Ι ΑΠΟ Κ ΜΕΧΡΙ ΠΓ ΜΕ_ΒΗΜΑ 2
ΑΝ Π[Κ]*Π[Κ+1] > Π[Λ]*Π[Λ-1] ΤΟΤΕ
Γ ← Γ * Π[Κ]*Π[Κ+1]
Κ ← Κ + 2
ΑΛΛΙΩΣ
Γ ← Γ * Π[Λ]*Π[Λ-1]
Λ ← Λ - 2
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ Γ

Τέλος ΓΙΝ5ΜΑΧ

για δοκιμασε να βαλεις σαν μεγεθος πινακα 5 και βρες το μεγιστο γινομενο 3 στοιχειων.δωσε σαν στοιχεια του πινακα τους εξης αριθμους
-10, -3, -5, -6, -20 .ησουν κοντα παντως η ασκηση αυτη δεν ειναι τοσο ευκολη οσο φαινεται αλλα εισαι πολυ κοντα.ακομα ο taxata ειχε δικιο και γω αδικο.ουτε ο πρωτος αλγοριθμος δουλευει σωστα απλα ειναι δυσκολο να το δεις.το προβλημα ειναι οταν εχεις μονο αρνητικους αριθμους

bugman

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 380
  • The Bug Eater
    • Πληροφορική Προγραμματισμός
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #68 στις: 04 Ιούν 2018, 09:06:31 πμ »
1. Αρχικά θα πρέπει να εξαιρεθούν οι μηδενικές τιμές
2. Μετά μπορεί κανείς να αλλάζει τους ακέραιους σε θετικούς, αφαιρώντας τον μικρότερο αρνητικό συν ένα στο καθένα. Έτσι έχει να κάνει με γινόμενα θετικών.
πχ τα α,β γ θα γίνουν α-δ+1, β-δ+1, γ-δ+1, όπου το δ είναι ο μικρότερος αρνητικός (αν δεν υπάρχει αρνητικός τότε είναι 0)
αν το γινόμενο (α-δ+1)*(β-δ+1) είναι μεγαλύτερο από το (α-δ+1)*(γ-δ+1) τότε θα πρέπει τα
(β-δ+1)>(γ-δ+1) ή β>γ. Άρα πρακτικά και χωρίς την αλλαγή σε θετικούς, θα έχουμε την ανισότητα β>γ ή α*β>α*γ να ισχύει.

στο παράδειγμα με τους -10, -3, -5, -6, -20
έχουμε τα -10--20+1=11, -3--20+1=18, -5--20+1=16, -6--20+1=15, -20--20+1=1
ταξινομούμε και παίρνουμε τα μέγιστα τρία: 18, 16, 15 από τα -3, -5 και -6, και έτσι καταλήγουμε σε αυτά τα νούμερα. που δίνουν το -90 ως μέγιστο γινόμενο.
Όπως το βλέπω και χωρίς την αφαίρεση του μικρότερου αρνητικού συν ένα, πάλι με απλή ταξινόμηση παίρνουμε τους τρεις μέγιστους και έχουμε το μεγαλύτερο γινόμενο.

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 185
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #69 στις: 04 Ιούν 2018, 10:54:48 πμ »
1. Αρχικά θα πρέπει να εξαιρεθούν οι μηδενικές τιμές
2. Μετά μπορεί κανείς να αλλάζει τους ακέραιους σε θετικούς, αφαιρώντας τον μικρότερο αρνητικό συν ένα στο καθένα. Έτσι έχει να κάνει με γινόμενα θετικών.
πχ τα α,β γ θα γίνουν α-δ+1, β-δ+1, γ-δ+1, όπου το δ είναι ο μικρότερος αρνητικός (αν δεν υπάρχει αρνητικός τότε είναι 0)
αν το γινόμενο (α-δ+1)*(β-δ+1) είναι μεγαλύτερο από το (α-δ+1)*(γ-δ+1) τότε θα πρέπει τα
(β-δ+1)>(γ-δ+1) ή β>γ. Άρα πρακτικά και χωρίς την αλλαγή σε θετικούς, θα έχουμε την ανισότητα β>γ ή α*β>α*γ να ισχύει.

στο παράδειγμα με τους -10, -3, -5, -6, -20
έχουμε τα -10--20+1=11, -3--20+1=18, -5--20+1=16, -6--20+1=15, -20--20+1=1
ταξινομούμε και παίρνουμε τα μέγιστα τρία: 18, 16, 15 από τα -3, -5 και -6, και έτσι καταλήγουμε σε αυτά τα νούμερα. που δίνουν το -90 ως μέγιστο γινόμενο.
Όπως το βλέπω και χωρίς την αφαίρεση του μικρότερου αρνητικού συν ένα, πάλι με απλή ταξινόμηση παίρνουμε τους τρεις μέγιστους και έχουμε το μεγαλύτερο γινόμενο.

οι μηδενικες τιμες δεν χρειαζεται να εξαιρεθουν.αν πχ εχω εναν πινακα 6 θεσεων με στοιχεια -1,-2,-3,-4,-5,0 και θελω το μεγιστο γινομενο 5 στοιχειων τοτε αυτο ειναι 0.αν αφησω το 0 εξω και δεν το παρω σαν εναν απο τους 5 αριθμους τοτε το γινομενο ειναι αρνητικο=-120 στην προκειμενη περιπτωση<0. το 0 μπορει να ειναι το μεγιστο γινομενο δλδ

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #70 στις: 06 Ιούν 2018, 02:12:42 μμ »
ΤΡΟΜΕΡΗ ΑΣΚΗΣΗ(καταλληλη και για μαθητες)
https://practice.geeksforgeeks.org/problems/sorting-elements-of-an-array-by-frequency/0

Δινεται ενας πινακας ακεραιων 100 θεσεων.ταξινομηστε τον ως προς την συχνοτητα των στοιχειων του ως εξης:
1)το στοιχειο που υπαρχει περισσοτερες φορες στον πινακα μπαινει πρωτο και αυτο που υπαρχει τις λιγοτερες τελευταιο.
2)αν 2 η περισσοτεροι αριθμοι εχουν την ιδια συχνοτητα ταξινομουνται κατα αυξουσα σειρα δλδ πρωτος μπαινει ο μικροτερος
Ωραίες ασκήσεις, πράγματι Κώστα, για σπαζοκεφαλιές και όχι για πανελλήνιες
(το διευκρινίζω κι εγώ για να μην πανικοβάλλονται μαθητές που τις βλέπουν)
Θα ήθελα να παραθέσω κι εγώ σ' αυτή την άσκηση, μόνο τον τρόπο με τον οποίο δημιουργώ τον πίνακα με τα διακεκριμένα στοιχεία του Α (αυτόν που στη λύση σου τον λες αρ, κι εγώ στη Διαδικασία τον λέω Α, ενώ F λέω τις αντίστοιχες συχνότητες)
Η διαδικασία αυτή καλείται για κάθε στοιχείο του αρχικού Α, ώστε να παράξει τον αρ και τις αντίστοιχες συχνότητες (αρχικά το Μ είναι 0 προφανώς)
Κώδικας: [Επιλογή]
ΔΙΑΔΙΚΑΣΙΑ add(x, A, F, M)
! x το στοιχείο που θα εισαχθεί στον Α
! F οι αντίστοιχες συχνότητες
! Μ το πλήθος των στοιχείων ως τώρα μέσα στον Α
ΣΤΑΘΕΡΕΣ
 N = 10
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: A[N], x, F[N], M , i
  ΛΟΓΙΚΕΣ: found
ΑΡΧΗ
  ! αναζητώ το x μέσα στον Α
  i <- 1
  found <- ΨΕΥΔΗΣ
  ΟΣΟ i<=M ΚΑΙ ΟΧΙ found ΕΠΑΝΑΛΑΒΕ
    ΑΝ A[i]=x ΤΟΤΕ
      found <- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ
      i <- i+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ found ΤΟΤΕ  !  αν το βρήκε, προσθέτει 1 στη συχνότητά του
    F[i] <- F[i]+1
  ΑΛΛΙΩΣ         ! αλλιώς το εισάγει ως νέο, με μία παρουσία
    M <- M+1
    A[M]<-x
    F[M]<-1
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Φιλικά,
Γιώργος Θαλασσινός

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 185
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #71 στις: 07 Ιούν 2018, 01:38:56 πμ »
ΑΣΚΗΣΗ ΜΕΤΡΙΑΣ ΔΥΣΚΟΛΙΑΣ
να φτιαξετε προγραμμα σε γλωσσα που θα διαβαζει απο το χρηστη εναν πραγματικο αριθμο χ και εναν ακεραιο y και θα εμφανιζει στην οθονη το αποτελεσμα χ^y. Να μην χρησιμοποιηθει πουθενα ο τελεστης υψωσης σε δυναμη  .να γινεται ελεγχος δεδομενων  για τα χ και y και αν δωθουν μη αποδεκτες τιμες να ξαναζηταμε απο το χρηστη να δωσει παλι τα x,y.
« Τελευταία τροποποίηση: 07 Ιούν 2018, 04:56:01 μμ από Κωστας τζιαννης »

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 185
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #72 στις: 08 Ιούν 2018, 06:44:43 μμ »
ΑΣΚΗΣΗ ΜΕΓΙΣΤΟ ΓΙΝΟΜΕΝΟ
Δινεται πινακας ακεραιων 20 θεσεων Α[20].να φτιαξετε προγραμμα σε γλωσσα που θα εμφανιζει το μεγιστο γινομενο που μπορουμε να παρουμε αν πολλαπλασιασουμε μεταξυ τους 5 στοιχεια του πινακα.(θελω πολυ να δω καποιον να τη λυνει αυτη την ασκηση με τιμιο τροπο)

μια λυση με ελαφρως αλλαγμενο τροπο ταξινομησης απο τον κλασσικο της φθινουσας.η ταξινομηση γινεται κατα φθινουσα σειρα απολυτων τιμων.η λυση ειναι για μεταβλητο πληθος μεγεθους πινακα και πληθος στοιχειων που θελω να πολλαπλασιασω τα οποια οριζονται σαν σταθερες.με ταξινομηση με αυτον τον τροπο ειναι πολυ ευκολο να βρω αν θελω και τον υποπινακα του Α με το μεγιστο γινομενο.δηλαδη να μη μου λεει πληθος στοιχειων αλλα να βρω εγω ποσα και ποια στοιχεια πρεπει να πολλαπλασιασω για να εχω το μεγιστο γινομενο.Ανεβαζω και την παραλλαγη που βρισκει για καθε πληθος στοιχειων απο 1 μεχρι το μεγεθος του πινακα ,το μεγιστο γινομενο καθως και το συνολικο μεγιστο γινομενο και απο ποσα στοιχεια αποτελειται.
« Τελευταία τροποποίηση: 08 Ιούν 2018, 10:29:45 μμ από Κωστας τζιαννης »

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 185
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #73 στις: 09 Ιούν 2018, 02:30:12 πμ »
 ΑΣΚΗΣΗ ΜΕΓΙΣΤΟ ΓΙΝΟΜΕΝΟ 2 (την προτεινε ο Πετρος)
Να φτιαξετε αλγόριθμο που διαβάσει άγνωστο πλήθος πραγματικών αριθμών (η εισαγωγή θα σταματάει όταν διαβαστεί το μηδέν) και θα εμφανιζει το μεγιστο γινομενο που μπορουμε να παρουμε αν πολλαπλασιασουμε μεταξυ τους 5 αριθμούς από αυτούς που διαβάστηκαν.

μπορει να μαζευτει αρκετα ο κωδικας,αλλα βαριομουν να το κανω. οποιος εχει ορεξη ας το βελτιωσει η ας στειλει τη δικη του.
ουσιαστικα κραταμε τους 5 μεγαλυτερους θετικους αριθμους σε εναν πινακα.τους 5 μεγαλυτερους αρνητικους αριθμους σε εναν αλλον και τους 5 μικροτερους αρνητικους αριθμους σε εναν αλλον.ο δευτερος πινακας χρησιμευει στην περιπτωση που εχω μονο αρνητικες τιμες
(στην περιπτωση αυτη το μαχ γινομενο ειναι αυτο που παιρνω αν πολλαπλασιασω τα στοιχεια του 2ου πινακα).

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 185
Απ: Απ: Δύσκολες ασκήσεις εκτός λογικής πανελληνίων
« Απάντηση #74 στις: 09 Ιούν 2018, 02:41:51 πμ »
----------------ΑΣΚΗΣΑΡΑ---------(ΕΚΤΟς ΛΟΓΙΚΗΣ ΠΑΝΕΛΛΗΝΙΩΝ ΦΥΣΙΚΑ!!!)

δινεται πινακας ακεραιων 20 θεσεων Α[20].αν ταξινομηθει ο Α κατα αυξουσα η φθινουσα σειρα(δεν εχει διαφορα) να βρειτε τη μεγιστη αποσταση μεταξυ 2 γειτονικων στοιχειων του ταξινομημενου Α.γειτονικα στοιχεια ειναι αυτα που βρισκονται σε διπλανες θεσεις δλδ ττο α[3] με το α[4] ,το α[2] με το α[3] κτλ. Μετα προσπαθειστε να κανετε το ιδιο ΧΩΡΙΣ ΝΑ ΧΡΗΣΙΜΟΠΟΙΗΘΕΙ ΤΑΞΙΝΟΜΗΣΗ!!!
ΠΑΡΑΔΕΙΓΜΑ
Α=3,2,1,49
αν τον ταξινομησω θα εχω 1,2,3,49  η μεγιστη διαφορα γειτονικων στοιχειων ειναι 49-3=46.πως θα βρω το ιδιο χωρις ταξινομηση????
« Τελευταία τροποποίηση: 09 Ιούν 2018, 06:34:49 πμ από Κωστας τζιαννης »