Αποστολέας Θέμα: Το ΘΕΜΑ Β2 του 2016 με υλοποίηση δομής επανάληψης  (Αναγνώστηκε 473 φορές)

ΣΧΟΙΝΑΣ ΚΩΣΤΑΣ

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 125
Καλησπέρα θα ήθελα τα σχόλια σας σχετικά με την παρακάτω λύση στο θέμα Β2 δεν ξέρω αν δουλεύει απόλυτα σωστά
Η λογική μου είναι οι αρχικοποίηση εκτός της επανάληψης  πριν την έναρξη του βρόχου για από μέχρι και εφόσον ο χρόνος  (ΧΡΟΝΟΣ_ΕΞΥΠΕΡ) γίνει ίσος με το 3 τότε ο μετρητής ξανά αρχικοποιείται. Επίσης  κάθε 2 λεπτά σταθερά προσέρχεται νέος πελάτης


Αλγόριθμος ουρα_τραπεζας
αριθ_προτεραιοτητας← 1

ΧΡΟΝΟΣ_ΕΞΥΠΕΡ←0

για   λεπτό απο 1 μέχρι 6
   ΧΡΟΝΟΣ_ΕΞΥΠΕΡ ← ΧΡΟΝΟΣ_ΕΞΥΠΕΡ +1
   Εμφάνισε ""
   Εμφάνισε " Η ουρά πελατών του ταμείου  για το",λεπτό, "λεπτό"
   
Αν ΧΡΟΝΟΣ_ΕΞΥΠΕΡ < 3 ΤΟΤΕ   
    Εμφάνισε " στην ουρα αναμένει ο πελάτης με αριθμό ",αριθ_προτεραιοτητας
   
αλλιώς_αν  ΧΡΟΝΟΣ_ΕΞΥΠΕΡ=3 ΤΟΤΕ
     Εμφάνισε " Ο ΠΕΛΑΤΗΣ",αριθ_προτεραιοτητας -1 ," εξυπηρετήθηκε"
     Εμφάνισε " Ο ΠΕΛΑΤΗΣ",αριθ_προτεραιοτητας ," είναι σε αναμονή"
     ΧΡΟΝΟΣ_ΕΞΥΠΕΡ←0
Τέλος_αν    
αν λεπτό mod 2=0 και λεπτό  >0  τότε
   
   αριθ_προτεραιοτητας← αριθ_προτεραιοτητας+1
    Εμφάνισε " ΝΕΟΣ ΠΕΛΑΤΗΣ ΣΤΗΝ ΟΥΡΑ"," με αριθμό προτεραιότητας" ,αριθ_προτεραιοτητας
Τέλος_αν    
Τέλος_επανάληψης   
Τέλος ουρα_τραπεζας
« Τελευταία τροποποίηση: 21 Ιούλ 2016, 10:26:39 μμ από ΣΧΟΙΝΑΣ ΚΩΣΤΑΣ »
Καθηγητής πληροφορικής ΠΕ20