Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 6146 φορές)

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 537
Απ: Θέμα Δ
« Απάντηση #45 στις: 05 Ιούν 2015, 10:01:16 πμ »
Καλημέρα

ήθελα να ρωτήσω το εξής: ένας μαθητής μου στο Δ4 κατάλαβε ότι η έκφραση "το μεγαλύτερο βαθμό σε ένα τραγούδι" αντιστοιχεί σε αναζήτηση...δηλαδή έκανε αναζήτηση, βρήκε σε ποια γραμμή βρίσκεται στο τραγούδι, βρήκε το μέγιστο κάθε κριτή και έλεγξε αν είναι πόσα μέγιστα έχουμε (έτσι μου το περιέγραψε) ... θα πάρει κάποια μόρια θεωρείτε ?? πολύ κρίμα για τον συγκεκριμένο, πολύ καλό παιδί και άριστος μαθητής, όλα τα άλλα μάλλον τα έχει σωστά ..

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 128
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: Θέμα Δ
« Απάντηση #46 στις: 05 Ιούν 2015, 02:04:06 μμ »
Καλημέρα

ήθελα να ρωτήσω το εξής: ένας μαθητής μου στο Δ4 κατάλαβε ότι η έκφραση "το μεγαλύτερο βαθμό σε ένα τραγούδι" αντιστοιχεί σε αναζήτηση...δηλαδή έκανε αναζήτηση, βρήκε σε ποια γραμμή βρίσκεται στο τραγούδι, βρήκε το μέγιστο κάθε κριτή και έλεγξε αν είναι πόσα μέγιστα έχουμε (έτσι μου το περιέγραψε) ... θα πάρει κάποια μόρια θεωρείτε ?? πολύ κρίμα για τον συγκεκριμένο, πολύ καλό παιδί και άριστος μαθητής, όλα τα άλλα μάλλον τα έχει σωστά ..

Αρκετά από τα 9 μόρια.. τουλάχιστον 3 από το γεγονός ότι βρίσκει το μέγιστο κάθε κριτή... από κει και πέρα πρέπει να ξέρουμε ακριβώς αυτό που έκανε γιατί στην παραπάνω περιγραφή η κατάσταση είναι μπερδεμένη

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 537
Απ: Θέμα Δ
« Απάντηση #47 στις: 05 Ιούν 2015, 02:09:23 μμ »
ευχαριστώ για την απάντηση συνάδελφε....ναι όντως μπέρδεψε την αναζήτηση και δεν ξέρουμε πως ακριβώς θα βαθμολογηθεί ... και εγώ τώρα περιγράδω στο περίπου αυτα που μου είπε .... ωραία τουλάχιστον να πάρει κάποια γιατι είναι κρίμα

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 128
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: Θέμα Δ
« Απάντηση #48 στις: 12 Ιούν 2015, 07:04:12 μμ »
Συνάδελφοι, κατά την  βαθμολόγηση  μου έκανε φοβερή εντύπωση μια «λανθασμένη» λύση που συνάντησα και αφορά το ερώτημα Δ4. Την παραθέτω και ζητάω την γνώμη σας για το πόσο πρέπει να βαθμολογηθεί με άριστα το 9.

!
Για j από 1 μέχρι 7
   MaxB[j] <-- B[1, j]
   Για i από 2 μέχρι 45
      Αν  B[i, j] >  MaxB[j] τότε
         MaxB[j] <--  B[i, j] 
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
!
Max <--   0
Για i από 1 μέχρι 45
   k <-- 0
   Για j από 1 μέχρι 7
      Αν  B[i, j] =  MaxB[j] τότε
          k <-- k + 1
      Τέλος_αν
   Τέλος_επανάληψης
   Αν  k > Max  τότε
      Max <-- k
   Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε ‘πλήθος κριτών :’ , Max
!

Dimi97

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Θέμα Δ
« Απάντηση #49 στις: 13 Ιούν 2015, 02:26:50 μμ »
Συνάδελφοι, κατά την  βαθμολόγηση  μου έκανε φοβερή εντύπωση μια «λανθασμένη» λύση που συνάντησα και αφορά το ερώτημα Δ4. Την παραθέτω και ζητάω την γνώμη σας για το πόσο πρέπει να βαθμολογηθεί με άριστα το 9.

!
Για j από 1 μέχρι 7
   MaxB[j] <-- B[1, j]
   Για i από 2 μέχρι 45
      Αν  B[i, j] >  MaxB[j] τότε
         MaxB[j] <--  B[i, j] 
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
!
Max <--   0
Για i από 1 μέχρι 45
   k <-- 0
   Για j από 1 μέχρι 7
      Αν  B[i, j] =  MaxB[j] τότε
          k <-- k + 1
      Τέλος_αν
   Τέλος_επανάληψης
   Αν  k > Max  τότε
      Max <-- k
   Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε ‘πλήθος κριτών :’ , Max
!

το πρόβλημα ειναι στο τέλος μόνο,που πρέπει να γίνει

ΑΝ κ=1 τότε
Μax<--Max+1

σωστά?

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 128
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: Θέμα Δ
« Απάντηση #50 στις: 16 Ιούν 2015, 06:33:02 μμ »
το πρόβλημα ειναι στο τέλος μόνο,που πρέπει να γίνει

ΑΝ κ=1 τότε
Μax<--Max+1

σωστά?

Όχι..Τότε θα έβρισκε το πλήθος των τραγουδιών στα οποία ένας μόνο κριτής έδωσε τον μέγιστο βαθμό του.
Η λύση που παρέθεσα απαντά στην εξής εκφώνηση :
Να βρίσκει και να εμφανίζει το μεγαλύτερο  πλήθος κριτών που σε ένα τραγούδι έδωσαν τον μέγιστο βαθμό τους.
Ενώ η εκφώνηση του Δ4 ήταν :
Να βρίσκει και να εμφανίζει το πλήθος των κριτών που έδωσαν τον μέγιστο βαθμό τους σε ένα μόνο τραγούδι.

Dimi97

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Θέμα Δ
« Απάντηση #51 στις: 16 Ιούν 2015, 09:14:58 μμ »
Όχι..Τότε θα έβρισκε το πλήθος των τραγουδιών στα οποία ένας μόνο κριτής έδωσε τον μέγιστο βαθμό του.
Η λύση που παρέθεσα απαντά στην εξής εκφώνηση :
Να βρίσκει και να εμφανίζει το μεγαλύτερο  πλήθος κριτών που σε ένα τραγούδι έδωσαν τον μέγιστο βαθμό τους.
Ενώ η εκφώνηση του Δ4 ήταν :
Να βρίσκει και να εμφανίζει το πλήθος των κριτών που έδωσαν τον μέγιστο βαθμό τους σε ένα μόνο τραγούδι.

ααα καταλαβα ευχαριστώ...οπότε στα τελευταια για πρεπει το 45 και το 7 να αντιστραφούνε...