Αποστολέας Θέμα: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι  (Αναγνώστηκε 22975 φορές)

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Επαναληπτικό Διαγώνισμα για την Ανάπτυξη Εφαρμογών (2014-2015).

-- από την Ομάδα Διαγωνισμάτων του Στεκιού

Edit: προστέθηκε το αρχείο των λύσεων  (12-5-2015)
« Τελευταία τροποποίηση: 12 Μάι 2015, 12:41:48 πμ από Νίκος Αδαμόπουλος »

gioufkas

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #1 στις: 28 Απρ 2015, 02:16:24 πμ »
Συγχαρητήρια... με μια γρήγορη ματιά πολύ καλό, περιεκτικό, πρωτότυπο και σύμφωνο με το πνεύμα του σχολικού βιβλίου... ;)

twisted

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #2 στις: 28 Απρ 2015, 03:06:08 πμ »
Καταντάει βαρετό αλλά well done και πάλι!!!!

Θα ήθελα να δω αιτιολόγηση μαθητών για το Α1. 4....  >:D

Θέμα Γ ωραίο

Θέμα Δ πιστεύω οι περισσότεροι μαθητές θα σκαλώσουν στην εκφώνηση...  :-\

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 541
  • There can be only one...may it be AEPP.
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #3 στις: 28 Απρ 2015, 10:01:39 πμ »
Σε ένα άλλο μήνυμα ο Laertis ήταν λιγάκι προφητικός (http://alkisg.mysch.gr/steki/index.php?topic=6198.msg71654#quickreply  ;) 2ο μήνυμα)
Δύσκολο και απαιτητικό διαγώνισμα

Ένα μεγάλο μπράβο και πολλά συγχαρητήρια στην ομάδα και σε όσους κουράστηκαν για να μας προσφέρουν αυτό το αποτέλεσμα.
Το δίνω σήμερα στα παιδιά σαν δώρο. Είναι τέλειο!!! :D
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #4 στις: 28 Απρ 2015, 11:02:08 πμ »
Πολλά μπράβο στην ομάδα για το διαγώνισμα. Άψογο ως συνήθως!

Σχετικά με το Α4 μιλάμε σίγουρα για 2 συντακτικά και 2 λογικά λάθη γιατί εγώ τα βγάζω 3 συντακτικά και 1 λογικό.
« Τελευταία τροποποίηση: 28 Απρ 2015, 11:37:20 πμ από Βασίλης Παπαχρήστος »

odysseas

  • Ομάδα διαγωνισμάτων 2011
  • *
  • Μηνύματα: 842
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #5 στις: 28 Απρ 2015, 11:52:24 πμ »
Παιδιά, να είστε καλά και πολλά συγχαρητήρια. Και του χρόνου...  ;)
« Τελευταία τροποποίηση: 28 Απρ 2015, 03:26:23 μμ από odysseas »

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #6 στις: 28 Απρ 2015, 01:08:28 μμ »
Πολλές ωραίες και φρέσκιες ιδέες!
Πολλά μπράβο για μια ακόμη φορά στην ομάδα!
Φιλικά,
Γιώργος Θαλασσινός

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 652
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #7 στις: 29 Απρ 2015, 08:53:26 πμ »
Συγχαρητήρια... με μια γρήγορη ματιά πολύ καλό, περιεκτικό, πρωτότυπο και σύμφωνο με το πνεύμα του σχολικού βιβλίου... ;)


συγχαρητήρια και από εμένα, πάρα πολύ καλό, τα θέματα Α και Β που ασχολήθηκα περισσότερο (γιατί που χρόνος τώρα που πλησιάζουν οι εξετάσεις).....και θα συμφωνήσω με τον συνάδελφο, τα θέματα είναι μέσα στην λογική του μαθήματος και ωραιότατα για θέματα εξετάσεων (άντε ίσως για κάτι λίγο - λίγο πιο σύνθετο από τα συνηθισμένα  :police: :laugh: >:D)

καλή συνέχεια σε όλους μας

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #8 στις: 29 Απρ 2015, 02:50:59 μμ »
Με τη σειρά μου και εγώ να συμφωνήσω ότι είναι πολύ έξυπνα τα θέματα και απαιτείται για να λυθούν κατανόηση και όχι παπαγαλία. Μπράβο για την ευρηματικότητα.

Έχω όμως κάποιες παρατηρήσεις για το Γ Θέμα το οποίο διαπραγματεύεται ένα πραγματικό σενάριο. Η εκλογή του Πάπα γίνεται με τη διαδικασία που περιγράφεται μέχρι την 30 ψηφοφορία. Μετά ψηφίζουν τους δύο πρώτους σε ψήφους και εκλέγεται Πάπας αυτός με την απόλυτη πλειοψηφία. Νομίζω ότι καλό θα ήταν να αλλάξει το θέμα και να παρατεθεί η διαδικασία εκλογής όπως ακριβώς γίνεται μιας και αγγίζει και το θρησκευτικό συναίσθημα κάποιων. Από την άλλη βέβαια καθίσταται δυνατή η χρήση πίνακα (απλοποιούνται αρκετά τα πράγματα) για το 5 ερώτημα κάτι μάλλον που εκτιμώ ότι δεν το ήθελε η ομάδα των διαγωνισμάτων.
Τέλος στο ερώτημα Γ5 δεν ξεκαθαρίζεται τουλάχιστον κατά την άποψη μου τι μήνυμα θα εμφανιστεί αν ο Πάπας εκλεγεί με την πρώτη φορά. Έτσι όπως δίνεται η εκφώνηση αφού δεν υπάρχει προηγούμενη ψηφοφορία μάλλον "Αουτσάιντερ";     

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #9 στις: 29 Απρ 2015, 07:05:22 μμ »
Εξαιρετικό διαγώνισμα. Συγχαρητήρια στην ομάδα των συναδέλφων που το έφτιαξε. Το έδωσα ήδη σε μαθητές μου και πήγε αρκετά καλά.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #10 στις: 30 Απρ 2015, 10:38:33 μμ »
Συνάδελφοι ευχαριστούμε για τα καλά σας λόγια...  :)

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #11 στις: 30 Απρ 2015, 11:23:28 μμ »
Έχω όμως κάποιες παρατηρήσεις για το Γ Θέμα το οποίο διαπραγματεύεται ένα πραγματικό σενάριο. Η εκλογή του Πάπα γίνεται με τη διαδικασία που περιγράφεται μέχρι την 30 ψηφοφορία. Μετά ψηφίζουν τους δύο πρώτους σε ψήφους και εκλέγεται Πάπας αυτός με την απόλυτη πλειοψηφία. Νομίζω ότι καλό θα ήταν να αλλάξει το θέμα και να παρατεθεί η διαδικασία εκλογής όπως ακριβώς γίνεται μιας και αγγίζει και το θρησκευτικό συναίσθημα κάποιων. Από την άλλη βέβαια καθίσταται δυνατή η χρήση πίνακα (απλοποιούνται αρκετά τα πράγματα) για το 5 ερώτημα κάτι μάλλον που εκτιμώ ότι δεν το ήθελε η ομάδα των διαγωνισμάτων.

Σχετικά με το παραπάνω...

...όπως φαίνεται και στις παραθέσεις που ακολουθούν, το συγκεκριμένο σημείο είχε απασχολήσει αρκετά την ομάδα. Όμως τελικά η ομάδα θεώρησε ότι αποτελεί μια διαδικαστική λεπτομέρεια που έτσι κι αλλιώς δεν ίσχυε πάντα, δεν έχει να κάνει με τις αρχές του δόγματος και επομένως δεν μπορεί να θίξει τις θρησκευτικές ευαισθησίες των πιστών. Μάλλον θα συμβαίνει σπάνια και άρα το βασικό τμήμα της διαδικασίας της εκλογής είναι αυτό που περιγράφει η άσκηση. Μια άσκηση αποτελεί πάντα μια αφαιρετική προσέγγιση της πραγματικότητας, η ομάδα παρόλα αυτά δεν αυθαιρέτησε  προσθέτοντας περίεργα ερωτήματα ή καταστάσεις που δεν ισχύουν στην πραγματικότητα, όπως αρκετά τέτοια είχαν προταθεί αρχικά.

Πάντως για να δείτε ότι η συγκεκριμένη διατύπωση της άσκησης δεν οριστικοποιήθηκε ελαφρά τη καρδία, ακολουθούν μερικά αποσπάσματα από τις σχετικές συζητήσεις της ομάδας...

Παράθεση
Ένα ζήτημα, ειδικά με τη συγκεκριμένη κάπως ευαίσθητη πρόταση, είναι ότι μάλλον δεν μπορούμε να προτείνουμε άλλη διαδικασία εκλογής από αυτήν που πραγματικά ισχύει. Αλλιώς μπορεί να βρεθεί κάποιος και να μας την πει! Ελπίζω βέβαια η αρχική πρόταση να περιγράφει όντως την πραγματική διαδικασία που ακολουθείται. Ο +++++ θα μπορούσε να μας το επιβεβαιώσει...

Παράθεση
++++ η διαδικασία που περιγράφεται στο αρχικό θέμα είναι η πραγματική. Θα συμφωνήσω μαζί σου ότι καλό είναι όταν επιλέγουμε ένα θέμα από τον πραγματικό κόσμο να μην απομακρυνόμαστε πολύ από τη διαδικασία που όντως ισχύει, παρόλο που κάποιες από τις επεκτάσεις που έχουν προταθεί έχουν πολύ ενδιαφέρον.

Παράθεση
Βέβαια δεν είναι ανάγκη να χρησιμοποιηθούν οι λέξεις: πάπας, καρδινάλιος, μαύρος καπνός.
Απλά η εκφώνηση να αναφέρεται γενικά σε ανάδειξη - εκλογή κάποιου από κάποιους.
Αν όμως θέλουμε να μιλήσουμε για πάπα τότε αυτό που λέτε (προσκόλληση στην πραγματικότητα)  είναι μονόδρομος

Παράθεση
Από όσο είδα, αλλού λέει 30 ψηφοφορίες, αλλού 33, αλλού ότι αποφασίζουν τότε τι να κάνουν...

Παράθεση
Η διαδικασία που περιγράφουμε ίσχυε μέχρι και τον Πάπα John Paul II ,ο οποίος πρόσθεσε την παραλλαγή ότι μετά τις 30 ψηφοφορίες οι δύο δημοφιλέστεροι μπαίνουν σε ψηφοφορία μεταξύ τους και εκλέγεται αυτός που πλειοψηφεί.
Προσωπικά, θεωρώ ότι είμαστε απόλυτα καλυμμένοι με την τρέχουσα εκφώνηση.

Παράθεση
Έδωσα σε πολύ καλό μαθητή το θέμα με τον Πάπα (όπως ακριβώς είχε προταθεί αρχικά). Το έλυσε αν και του ξέφυγαν κάποιες ψιλολεπτομέρειες. Το θέμα έχει σημεία που πρέπει να προσέξει κάποιος αν θέλει να το λύσει ολόσωστα. Ειδικά το τελευταίο ερώτημα τον παίδεψε. Έφτιαξε πίνακα όπου έβαζε το όνομα του 1ου σε κάθε ψηφοφορία και μετά έλεγξε αν όλα τα ονόματα είναι ίδια! Βέβαια πίνακα δεν νομιμοποιούταν να χρησιμοποιήσει αφού δεν ξέραμε πόσες ψηφοφορίες θα έχουμε το πολύ. Από την άλλη λυνόταν με λιγότερο κόπο απλά έπρεπε να κάνει τη σωστή σκέψη.

Θεωρώ ότι από άποψη δυσκολίας η αρχική πρόταση έχει το σωστό επίπεδο δυσκολίας και καλή διαβάθμιση μέσα στα ερωτήματα. Το βλέπουμε αν είναι καλό να βάλουμε και τα υποπρογράμματα (το ένα ή και τα δύο), όπως φαίνονται στην προτεινόμενη λύση παραπάνω. Πείτε τη γνώμη σας!

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #12 στις: 30 Απρ 2015, 11:35:11 μμ »
Τέλος στο ερώτημα Γ5 δεν ξεκαθαρίζεται τουλάχιστον κατά την άποψη μου τι μήνυμα θα εμφανιστεί αν ο Πάπας εκλεγεί με την πρώτη φορά. Έτσι όπως δίνεται η εκφώνηση αφού δεν υπάρχει προηγούμενη ψηφοφορία μάλλον "Αουτσάιντερ";     

Η διατύπωση έχει ως εξής:

Παράθεση
Γ5. Θα εμφανίζει το μήνυμα «Ο Πάπας ήταν το φαβορί» σε περίπτωση που ο υποψήφιος που ανακηρύχτηκε Πάπας, είχε πάρει την πρώτη θέση σε όλες τις ψηφοφορίες που προηγήθηκαν μέχρι και την εκλογή του. Διαφορετικά θα εμφανίζει το μήνυμα «Αουτσάιντερ».

Θεωρώ πως αυτό το "μέχρι και την εκλογή του" θέλει να πει πως δεν υπήρχε κανένας άλλος που να είχε βγει πρώτος σε κάποια ψηφοφορία. Περιλαμβάνει φυσικά και την τελευταία ψηφοφορία, δηλαδή αυτήν της εκλογής του. Αν δεν υπάρχουν προηγούμενες ψηφοφορίες τότε αρκεί αυτή η μοναδική της οριστικής εκλογής! Άλλωστε αυτό λέει και η λογική. Αν δηλαδή κάποιος βγει με την πρώτη προσπάθεια τότε δεν θα τον χαρακτηρίζαμε αουτσάιντερ!

ether

  • Επισκέπτης
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #13 στις: 01 Μάι 2015, 12:25:20 πμ »
Η διατύπωση έχει ως εξής:

Θεωρώ πως αυτό το "μέχρι και την εκλογή του" θέλει να πει πως δεν υπήρχε κανένας άλλος που να είχε βγει πρώτος σε κάποια ψηφοφορία. Περιλαμβάνει φυσικά και την τελευταία ψηφοφορία, δηλαδή αυτήν της εκλογής του. Αν δεν υπάρχουν προηγούμενες ψηφοφορίες τότε αρκεί αυτή η μοναδική της οριστικής εκλογής! Άλλωστε αυτό λέει και η λογική. Αν δηλαδή κάποιος βγει με την πρώτη προσπάθεια τότε δεν θα τον χαρακτηρίζαμε αουτσάιντερ!

Αυτό λέει και η μαθηματική λογική αφού η πρόταση "ο υποψήφιος που ανακηρύχτηκε Πάπας έχει πάρει την πρώτη θέση σε όλες τις ψηφοφορίες που προηγήθηκαν μέχρι και την εκλογή του" είναι αληθής εν κενώ (vacuous truth) στην περίπτωση που δεν έχουν προηγηθεί ψηφοφορίες πριν από αυτήν της εκλογής του. Στην περίπτωση που το πεδίο αναφοράς είναι το κενό σύνολο, ο ποσοδείκτης "δια κάθε" αληθεύει

vassilakis

  • Θαμώνας
  • ***
  • Μηνύματα: 40
    • Σύλλογος Εκπαιδευτικών Πληροφορικής Χίου
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #14 στις: 02 Μάι 2015, 07:07:09 πμ »

...όπως φαίνεται και στις παραθέσεις που ακολουθούν, το συγκεκριμένο σημείο είχε απασχολήσει αρκετά την ομάδα. Όμως τελικά η ομάδα θεώρησε ότι αποτελεί μια διαδικαστική λεπτομέρεια που έτσι κι αλλιώς δεν ίσχυε πάντα, δεν έχει να κάνει με τις αρχές του δόγματος και επομένως δεν μπορεί να θίξει τις θρησκευτικές ευαισθησίες των πιστών. Μάλλον θα συμβαίνει σπάνια και άρα το βασικό τμήμα της διαδικασίας της εκλογής είναι αυτό που περιγράφει η άσκηση. Μια άσκηση αποτελεί πάντα μια αφαιρετική προσέγγιση της πραγματικότητας, η ομάδα παρόλα αυτά δεν αυθαιρέτησε  προσθέτοντας περίεργα ερωτήματα ή καταστάσεις που δεν ισχύουν στην πραγματικότητα, όπως αρκετά τέτοια είχαν προταθεί αρχικά.

Θα συμφωνήσω απόλυτα με το Νίκο. Άλλωστε όταν περιγράφουμε ένα θέμα μπορεί να δανειζόμαστε στοιχεία από τον πραγματικό κόσμο, αλλά το στήνουμε με τέτοιο τρόπο ώστε να "καλύπτει" αυτά που θέλουμε να εξετάσουμε. Χωρίς βέβαια οι αλλαγές που κάνουμε να θίγουν τις πεποιθήσεις κανενός, όπως νομίζω ισχύει και στην προκειμένη περίπτωση.
Βασιλάκης Βασίλης

fof

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 291
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #15 στις: 02 Μάι 2015, 09:47:59 πμ »
Συγχαρητήρια! Πολύ καλό!

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #16 στις: 02 Μάι 2015, 10:55:06 πμ »
Σχετικά με το παραπάνω...

...όπως φαίνεται και στις παραθέσεις που ακολουθούν, το συγκεκριμένο σημείο είχε απασχολήσει αρκετά την ομάδα. Όμως τελικά η ομάδα θεώρησε ότι αποτελεί μια διαδικαστική λεπτομέρεια που έτσι κι αλλιώς δεν ίσχυε πάντα, δεν έχει να κάνει με τις αρχές του δόγματος και επομένως δεν μπορεί να θίξει τις θρησκευτικές ευαισθησίες των πιστών. Μάλλον θα συμβαίνει σπάνια και άρα το βασικό τμήμα της διαδικασίας της εκλογής είναι αυτό που περιγράφει η άσκηση. Μια άσκηση αποτελεί πάντα μια αφαιρετική προσέγγιση της πραγματικότητας, η ομάδα παρόλα αυτά δεν αυθαιρέτησε  προσθέτοντας περίεργα ερωτήματα ή καταστάσεις που δεν ισχύουν στην πραγματικότητα, όπως αρκετά τέτοια είχαν προταθεί αρχικά.

Για να εξομολογηθώ την "αμαρτία μου" μιας και πιάσαμε τα θεολογικά δεν ήξερα πως εκλέγεται ο Πάπας. Απλά μαθητής μου (καθολικός) όταν του έδωσα το θέμα (το οποίο θεωρώ ιδανικό) μου είπε: "Τι έγινε ρε παιδιά; Για να βγάλετε άσκηση αλλάξετε και τον τρόπο εκλογής του Πάπα". Πράγματι δεν έχει να κάνει με τις αρχές του δόγματος αλλά με το τυπικό μιας από τις πιο σημαντικές διαδικασίες για τους καθολικούς.

Η δικιά μου αρχή πάντως όπως την έχω εκφράσει και παλιότερα (Θέμα Γ 2011) είναι τα πραγματικά σενάρια να χρησιμοποιούνται όπως είναι και όχι να τροποποιούνται ώστε να μπορούμε να εξετάσουμε συγκεκριμένα πράγματα με τρόπο που να "καλύπτει" εμάς. Αν θέλουμε αφαιρετική προσέγγιση της πραγματικότητας καλό είναι πάντα κατά την προσωπική μου άποψη να αναφερόμαστε στην εκλογή ενός αξιωματούχου και όχι στην εκλογή του Πάπα. Καλό είναι να αναφερόμαστε σε έναν διαγωνισμό για την πρόσληψη προσωπικού και όχι στον διαγωνισμό ΑΣΕΠ όπως στο θέμα Γ του 2011. Στον ΑΣΕΠ για να συμμετάσχει κάποιος το δηλώνει εκ των προτέρων δεν το αποφασίζει την τελευταία στιγμή. Γνωρίζουμε δηλαδή στην πραγματικότητα τον μέγιστο αριθμό αυτών που θα προσέλθουν στις εξετάσεις. Κανένα πρόβλημα να αλλάξουμε τη διαδικασία αλλά όχι αναφορά σε ΑΣΕΠ.

Για το Γ5 μία τροποποίηση της μορφής "θα εμφανίζει φαβορί αν εκλεγεί με την πρώτη φορά ή είναι πρώτος σε όλες τις ψηφοφορίες" νομίζω ότι δεν θα προκαλούσε την συζήτηση.

Και πάλι θέλω να δώσω συγχαρητήρια για την προσπάθεια και να τονίσω ότι τουλάχιστον από την μεριά μου η συζήτηση αποσκοπεί στο να βοηθήσει αυτούς που καλούνται να επιτελέσουν το τόσο δύσκολο έργο της κατάθεσης θεμάτων για τις πανελλαδικές. Είμαι σίγουρος ότι αυτή είναι και η δύναμη και η συνεισφορά του Στεκιού. Προβάλλει διαφορετικούς τρόπους σκέψης και βοηθάει σε μία καλύτερη σύνθεση.

evoy

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #17 στις: 02 Μάι 2015, 04:31:06 μμ »
Πολύ καλό διαγώνισμα. Και ευχαριστούμε για όλη την προσπάθειά σας. 
Μόνο που δυστυχώς "κάψατε" ως πιθανό θέμα πανελλαδικών  τη συγχώνευση ταξινομημένων  σε ταξινομημένο που αρκετοί από εμάς περιμέναμε για φέτος.  Χαλάλι.
Ενδεικτικές απαντήσεις θα ανεβάσετε;
 

nick_papag

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #18 στις: 02 Μάι 2015, 11:02:26 μμ »
Εξαιρετικό και απαιτητικό διαγώνισμα. Μπράβο!
Ενδεικτικές λύσεις θα βοηθούσαν, ώστε να δούμε και διαφορετικές προσεγγίσεις από όλους μας.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #19 στις: 03 Μάι 2015, 12:31:10 μμ »
Σε λίγες μέρες θα ανέβουν και οι ενδεικτικές λύσεις!

dpa2006

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 618
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #20 στις: 04 Μάι 2015, 01:37:46 μμ »
Ευχαριστούμε για τα θέματα και τις αναμενόμενες λύσεις.  :)
Computer science (abbreviated CS or CompSci) is the scientific and practical approach to computation and its applications. It is the systematic study of the feasibility, structure, expression, and mechanization of the methodical processes (or algorithms) that underlie the acquisition, representation, processing, storage, communication of, and access to information, whether such information is encoded in bits and bytes in a computer memory or transcribed engines and protein structures in a human cell.source:http://en.wikipedia.org/wiki/Computer_science

deg

  • Οπαδός
  • **
  • Μηνύματα: 12
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #21 στις: 04 Μάι 2015, 02:32:22 μμ »
Καλό και δυνατό διαγώνισμα (προσωπικά μου πήρε 2 ώρες για να το λύσω). Ευχαριστώ για την προσφορά σας.


Απορίες-επισημάνσεις

Β1/ Συνηθίζεται (σε πίνακα τιμών) ο αριθμός των γραμμών η/και απαντήσεων να είναι πολλαπλάσιος των μονάδων που βαθμολογείται το ερώτημα. Αυτό γίνεται για την διευκόλυνση της βαθμολόγησης. Στο εν λόγω διαγώνισμα αυτό δεν ισχύει, οπότε η βαθμολόγηση του Β1 δεν είναι αναλογικά 0,5 ή 1 μόριο ανά απάντηση.

Δ3α/ Ο υπολογισμός της θερμοκρασίας μπορεί να γίνει με δύο τρόπους
                  1/ σαρώνουμε σειριακά τον πίνακα, ξεκινώντας από την επάνω αριστερά γωνία και  φτάνοντας στην κάτω δεξιά γωνία του.
                  2/ υπολογίζουμε την τιμή σε μια γωνία και αντιγράφοντας (την τιμή αυτή) και στις άλλες 3 γωνίες του πίνακα. Το ίδιο γίνεται για το επόμενο στοιχείο κοκ
Θεωρώ ότι και οι δύο λύσεις είναι σωστές.
Δεν είναι κακό να κάνεις λάθος, κακό είναι να αφήσεις το λάθος αδιόρθωτο.

Αργυροπούλου Βασιλική

  • Οπαδός
  • **
  • Μηνύματα: 12
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #22 στις: 05 Μάι 2015, 12:59:26 πμ »
Συγχαρητήρια για την δουλειά σας και από εμένα! :) :) :)
Αργυροπούλου Βασιλική
Καθηγήτρια Πληροφορικής

manpap

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 122
  • Είμαι χαζομπαμπάς...
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #23 στις: 05 Μάι 2015, 11:18:47 μμ »
Συγχαρητήρια και από μένα. Πολύ καλά θέματα, στο πνεύμα του βιβλιου και του μαθήματος. Να είστε καλά
Συντηρώ το μυαλό μου ακοίμητο, λαγαρό, ανήλεο. Το αμολώ να παλεύει ακατάλυτα. Άλλο αργαστήρι να κάνω το σκοτάδι φως δεν έχω.
Ν. Καζαντζάκης

Domain

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #24 στις: 06 Μάι 2015, 02:19:12 μμ »
Συγχαρητήρια, πολύ καλή δουλειά! Περιμένω τις ενδεικτικές λύσεις :)

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #25 στις: 06 Μάι 2015, 10:19:06 μμ »
Πριν ανέβουν οι ενδεικτικές λύσεις, θα είχε ενδιαφέρον να βλέπαμε προτεινόμενες λύσεις από όποιους έλυσαν τα θέματα.

kwstis

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #26 στις: 07 Μάι 2015, 12:30:55 μμ »
συγχαρητήρια,πολύ καλή δουλεία!!!! ανυπομονώ για τις λύσεις....Α1 ως 4 δυνατό...πιθανό και για τις πανελλήνιες.... :D :D
 

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 116
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #27 στις: 07 Μάι 2015, 12:37:15 μμ »
Για μία ακόμη χρονιά ένα πάρα πολύ καλό διαγώνισμα. Συγχαρητήρια στην ομάδα που το έφτιαξε. Μια ερώτηση για το θέμα Γ σε μία ψηφοφορία μπορεί να υπάρξουν ισοβαθμίες ή θεωρούμε ότι σε κάθε ψηφοφορία ένας κερδίζει ανεξάρτητα με το αν συγκεντρώσει τις απαιτούμενες ψήφους για να εκλεγεί πάπας;

makryd

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #28 στις: 07 Μάι 2015, 02:08:44 μμ »
Ευχαριστώ και την φετινή ομάδα διαγωνισμάτων για την εξαιρετική δουλειά  :).

Παράθεση
Πριν ανέβουν οι ενδεικτικές λύσεις, θα είχε ενδιαφέρον να βλέπαμε προτεινόμενες λύσεις από όποιους έλυσαν τα θέματα.
Μήπως οι προτεινόμενες λύσεις από όποιους έλυσαν τα θέματα δεν πρέπει να ανεβούν ακόμα δημόσια εδώ, αλλά να αποσταλούν μόνο στην ομάδα διαγωνισμάτων? Αν Ναι πείτε μου σε ποιον πρέπει να τις στείλω.

Παράθεση
Μια ερώτηση για το θέμα Γ σε μία ψηφοφορία μπορεί να υπάρξουν ισοβαθμίες ή θεωρούμε ότι σε κάθε ψηφοφορία ένας κερδίζει ανεξάρτητα με το αν συγκεντρώσει τις απαιτούμενες ψήφους για να εκλεγεί πάπας;
Νομίζω οτι εφόσον δεν το διευκρινίζει πρέπει να ληφθει υπόψιν ότι μπορει να υπάρχουν ισοβαθμίες σε ψηφοφορίες που δεν εκλέγουν Πάπα. 
 

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #29 στις: 07 Μάι 2015, 02:58:34 μμ »
Αφού έχουν περάσει αρκετές μέρες από την ανάρτηση του διαγωνίσματος, πλέον δεν θα είναι τόσο μεγάλος ο πειρασμός από μαθητές να δουν τις λύσεις πριν προσπαθήσουν να λύσουν τα θέματα μόνοι τους.

Καλύτερα λοιπόν οι λύσεις να ανεβαίνουν δημόσια σε αυτό το θέμα. Για λόγους επισκόπησης και διευκόλυνσης πιθανών απαντήσεων, καλύτερα να μην ανεβαίνουν ως συνημμένα αρχεία και όχι όλες οι λύσεις μαζί στο ίδιο μήνυμα.

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #30 στις: 07 Μάι 2015, 11:03:33 μμ »
Μιας και ασχοληθήκα με τον Πάπα πρωτύτερα παραθέτω μία ενδεικτική λύση. Απλά για να υπάρχει η δυνατότητα να γίνει παρακολούθηση μεταβλητών θεωρώ τους υποψήφιους 5 και τους καρδινάλιους 10.

Κώδικας: [Επιλογή]
Αλγόριθμος ΘΓ

Για i από 1 μέχρι 5
  Διάβασε ΥΠΟΨ[i]
  ΦΑΒ[i] ← Αληθής
Τέλος_επανάληψης


Αρχή_επανάληψης

  Για i από 1 μέχρι 5
    ΣΨ[i] ← 0
  Τέλος_επανάληψης

  Για i από 1 μέχρι 10
    Διάβασε ον
    j ← 1
    done ← Ψευδής
    Όσο done = Ψευδής και j ≤ 5 επανάλαβε
      Αν ΥΠΟΨ[j] = ον τότε
        ΣΨ[j] ← ΣΨ[j] + 1
        done ← Αληθής
      αλλιώς
        j ← j + 1
      Τέλος_αν
    Τέλος_επανάληψης
  Τέλος_επανάληψης

  μεγ ← ΣΨ[1]
  θμεγ ← 1
  Για j από 2 μέχρι 5
    Αν μεγ < ΣΨ[j] τότε
      μεγ ← ΣΨ[j]
      θμεγ ← j
    Τέλος_αν
  Τέλος_επανάληψης

  Αν μεγ ≥ 2/3* 10 τότε
    Εμφάνισε "Λευκός καπνός"
  αλλιώς
    Εμφάνισε "Μαύρος καπνός"
  Τέλος_αν

  Για j από 1 μέχρι 5
    Αν ΣΨ[j] ≠ μεγ τότε
      ΦΑΒ[j] ← Ψευδής
    Τέλος_αν
  Τέλος_επανάληψης

Μέχρις_ότου μεγ ≥ 2/3* 10

Εμφάνισε ΥΠΟΨ[θμεγ]
Αν ΦΑΒ[θμεγ] = Αληθής τότε
  Εμφάνισε "Φαβορί"
αλλιώς
  Εμφάνισε "Αουτσάιντερ"
Τέλος_αν


Τέλος ΘΓ

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #31 στις: 08 Μάι 2015, 11:46:59 μμ »
Ας γράψω και εγώ με τη σειρά μου μια προτεινόμενη λύση για το Θέμα Γ.

Κώδικας: [Επιλογή]
Αλγόριθμος ΘέμαΓ
Για ι από 1 μέχρι 18
Διάβασε ΥΠΟΨ[ι]
ΠΡΩΤΙΕΣ[ι] <- 0
Τέλος_επανάληψης
ΨΗΦΟΦΟΡΙΕΣ <- 0
Αρχή_επανάληψης
ΨΗΦΟΦΟΡΙΕΣ <- ΨΗΦΟΦΟΡΙΕΣ + 1
Για ι από 1 μέχρι 18
Ψ[ι] <- 0
Τέλος_επανάληψης
Για ι από 1 μέχρι 115
Διάβασε ΟΝ
ξ <- 0
Αρχή_επανάληψης
ξ <- ξ + 1
Μέχρις_ότου ΥΠΟΨ[ξ] = ΟΝ
Ψ[ξ] <- Ψ[ξ] + 1
Τέλος_επανάληψης
θ <- 1
Για ξ από 2 μέχρι 18
Αν Ψ[ξ]>Ψ[θ] τότε θ <- ξ
Τέλος_επανάληψης
ΠΡΩΤΙΕΣ[θ] <- ΠΡΩΤΙΕΣ[θ] + 1
Αν Ψ[θ] < 2/3*115 τότε
Εμφάνισε "Μαύρος καπνός"
Τέλος_αν
Μέχρις_ότου Ψ[θ] >= 2/3*115
Εμφάνισε "Λευκός καπνός"
Εμφάνισε ΥΠΟΨ[θ]
Αν ΨΗΦΟΦΟΡΙΕΣ = ΠΡΩΤΙΕΣ[θ] τότε
Εμφάνισε "Ο Πάπας ήταν φαβορί"
αλλιώς
Εμφάνισε "Αουτσάιντερ"
Τέλος_αν
Τέλος ΘέμαΓ

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #32 στις: 09 Μάι 2015, 12:06:36 πμ »
Να και μια βιαστική λύση για το θέμα Δ.

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:Ι, Κ, Μ
ΠΡΑΓΜΑΤΙΚΕΣ:Τ, ΘΤ, Σ, ΜΟ, Θ[1000,1000], Π[1000,1000]
ΛΟΓΙΚΕΣ: ΙΣΧΥΕΙ
ΑΡΧΗ
ΔΙΑΒΑΣΕ Τ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 1000
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 1000
Θ[Ι,Κ] <- Τ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ ΘΤ
ΜΕΧΡΙΣ_ΟΤΟΥ ΘΤ >= Τ+50
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 1000
Θ[Ι,1] <- ΘΤ
Θ[Ι,1000] <- ΘΤ
Θ[1,Ι] <- ΘΤ
Θ[1000,Ι] <- ΘΤ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μ <- 0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 999
ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 999
Π[Ι,Κ] <- Φ(Θ, Ι, Κ)
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Σ <- 0
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 999
ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 999
Θ[Ι,Κ] <- Π[Ι,Κ]
Σ <- Σ + Θ[Ι,Κ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ <- Σ/998^2
Μ <- Μ + 1
ΜΕΧΡΙΣ_ΟΤΟΥ ΘΤ-ΜΟ<0.5
ΓΡΑΨΕ Μ
ΙΣΧΥΕΙ <- ΑΛΗΘΗΣ
Ι <- 2
ΟΣΟ Ι <= 500 ΚΑΙ ΙΣΧΥΕΙ ΕΠΑΝΑΛΑΒΕ
ΑΝ Θ[Ι,Ι]>Θ[Ι-1,Ι-1] Ή Θ[500+Ι,500+Ι]<Θ[500+Ι-1,500+Ι-1] ΤΟΤΕ
ΙΣΧΥΕΙ <- ΨΕΥΔΗΣ
ΑΛΛΙΩΣ
Ι <- Ι + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΙΣΧΥΕΙ ΤΟΤΕ
ΓΡΑΨΕ 'ΙΣΧΥΕΙ'
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΔΕΝ ΙΣΧΥΕΙ'
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ Φ(Θ, Ι, Κ):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:Ι, Κ, Μ, Ν
ΠΡΑΓΜΑΤΙΚΕΣ:Σ, Θ[1000,1000]
ΑΡΧΗ
Σ <- 0
ΓΙΑ Μ ΑΠΟ Ι-1 ΜΕΧΡΙ Ι+1
ΓΙΑ Ν ΑΠΟ Κ-1 ΜΕΧΡΙ Κ+1
Σ <- Σ + Θ[Μ,Ν]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Σ <- Σ + Θ[Ι,Κ]
Φ <- Σ/10
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #33 στις: 09 Μάι 2015, 10:38:49 πμ »
Ας γράψω και εγώ με τη σειρά μου μια προτεινόμενη λύση για το Θέμα Γ.

Κώδικας: [Επιλογή]
Αλγόριθμος ΘέμαΓ
Για ι από 1 μέχρι 18
Διάβασε ΥΠΟΨ[ι]
ΠΡΩΤΙΕΣ[ι] <- 0
Τέλος_επανάληψης
ΨΗΦΟΦΟΡΙΕΣ <- 0
Αρχή_επανάληψης
ΨΗΦΟΦΟΡΙΕΣ <- ΨΗΦΟΦΟΡΙΕΣ + 1
Για ι από 1 μέχρι 18
Ψ[ι] <- 0
Τέλος_επανάληψης
Για ι από 1 μέχρι 115
Διάβασε ΟΝ
ξ <- 0
Αρχή_επανάληψης
ξ <- ξ + 1
Μέχρις_ότου ΥΠΟΨ[ξ] = ΟΝ
Ψ[ξ] <- Ψ[ξ] + 1
Τέλος_επανάληψης
θ <- 1
Για ξ από 2 μέχρι 18
Αν Ψ[ξ]>Ψ[θ] τότε θ <- ξ
Τέλος_επανάληψης
ΠΡΩΤΙΕΣ[θ] <- ΠΡΩΤΙΕΣ[θ] + 1
Αν Ψ[θ] < 2/3*115 τότε
Εμφάνισε "Μαύρος καπνός"
Τέλος_αν
Μέχρις_ότου Ψ[θ] >= 2/3*115
Εμφάνισε "Λευκός καπνός"
Εμφάνισε ΥΠΟΨ[θ]
Αν ΨΗΦΟΦΟΡΙΕΣ = ΠΡΩΤΙΕΣ[θ] τότε
Εμφάνισε "Ο Πάπας ήταν φαβορί"
αλλιώς
Εμφάνισε "Αουτσάιντερ"
Τέλος_αν
Τέλος ΘέμαΓ

Αν υπάρχει ισοβαθμία πριν από την εκλογή αυξάνεται μόνο ο αριθμός των πρωτιών του πρώτου υποψηφίου που έχει τις περισσότερες ψήφους. Μία τροποποίηση εύρεσης μεγίστου πολλές φορές, λύνει το πρόβλημα
« Τελευταία τροποποίηση: 10 Μάι 2015, 10:39:26 μμ από aperdos »

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 652
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #34 στις: 11 Μάι 2015, 12:27:27 μμ »
Καλησπέρα

ήθελα την γμώμη σας για δύο θέματα ... επιτρέψτε μου και μία ανάλυση ώστε 1) να εξηγήσω εγώ στους μαθητές και 2) εσείς σε εμένα αν έχω λάθος   :laugh: >:D :angel:

Α.3
Για i από N-1 μέχρι  1 με_βήμα -1   
     Για j από 1 μέχρι i με_βήμα +1 
         Αν A[ j ] > A[j + 1] τότε
             Αντιμετάθεσε A[ j ], A[ j+1 ]
       Τέλος_αν
    Τέλος_επανάληψης
Τέλος_επανάληψης

Α.5

α) --> Εμφανίζοναται 4 χαρακτήρες * (υποθέτω η εύκολη μονάδα, βρίσκεται μόνο στην επανάληψη Για i από 1 μέχρι 4)
β) --> Η εντολή Για j από 1 μέχρι i έχει μεταβλητή τιμή "μέχρι" οπότε θα εκτελέσει τις εξής επαναλήψεις

Για j από 1 μέχρι 1  --> 1 εμφάνισε
Για j από 1 μέχρι 2  --> 2 εμφάνισε
Για j από 1 μέχρι 3  --> 3 εμφάνισε
Για j από 1 μέχρι 4  --> 4 εμφάνισε

σύνολο το άθροισμά τους, δηλαδή 10 χαρακτήρες "+"

γ) η εντολή εμφάνισε "#" θα εκτελεστεί

--> 4 φορές στον βρόγχο του i
--> 10 φορές στον βρόγχο του j (η παραπάνω ανάλυση)
--> ο τριτος εμφωλευμένος βρόγχος του κ θα εκτελεστεί 101 φορές (από 101 μέχρο 200 θα ήταν 100) επί 10 φορές οι δύο προγούμενες που είναι εμφωλευμένος

άρα σύνολο 101*10  +  4 + 10  επαναλήψεις  (ελπίζω να μην χάθηκα στην μετάφραση...   :police: >:D ;D

περιμένω τα σχόλιά σας

ευχαριστώ

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #35 στις: 11 Μάι 2015, 12:51:31 μμ »
Καλησπέρα

ήθελα την γμώμη σας για δύο θέματα ... επιτρέψτε μου και μία ανάλυση ώστε 1) να εξηγήσω εγώ στους μαθητές και 2) εσείς σε εμένα αν έχω λάθος   :laugh: >:D :angel:

Ok και τα δύο!

Όσο για το:
101*10  +  4 + 10 = 1024 ...  Τυχαίο;   

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 652
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #36 στις: 11 Μάι 2015, 12:57:53 μμ »
οκ ευχαριστώ ...

1024  ε ?? όντως δεν έκανα την πράξη .... 2^10 ??? έχουν και κρυφά μηνύματα τα θέματα ??? λίγο εδώ, λίγο το θέμα με τον πάπα,βατικανό,  πολύ μυστήριο φέτος ....  >:D :laugh: :police:

tdiam

  • Οπαδός
  • **
  • Μηνύματα: 16
  • Why's the rum gone?
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #37 στις: 11 Μάι 2015, 11:33:05 μμ »
Εξαιρετικά θέματα, μπράβο στην ομάδα για τη φαντασία και το χρόνο που αφιέρωσε!


EDIT: Όπως επισημάνθηκε ήδη, σε μία ψηφοφορία μπορεί να υπάρχουν περισσότεροι από ένας νικητές, λόγω ισοβαθμίας.
Άρα η παρακάτω λογική είναι λανθασμένη, αφού απαιτεί ο εκλεχθείς Πάπας να ήταν ο (μοναδικός) νικητής σε κάθε ψηφοφορία.


Μία εναλλακτική ματιά στο Γ' Θέμα, χωρίς αποθήκευση των νικών κάθε υποψηφίου:
Αν ο εκλεχθείς Πάπας ήταν φαβορί, τότε όλες οι ψηφοφορίες θα είχαν αυτόν νικητή.
Άρα, αν σε οποιαδήποτε ψηφοφορία βρούμε νικητή διαφορετικό από τον νικητή της 1ης ψηφοφορίας, δεν υπάρχει φαβορί.

Κώδικας: [Επιλογή]
Αλγόριθμος Θέμα_Γ

      ! εισαγωγή υποψηφίων
      Για i από 1 μέχρι 18
            Διάβασε ΥΠΟΨ[i]
      Τέλος_επανάληψης

      φαβορί <-- Αληθής    ! κρατάει αν στο τέλος της ψηφοφορίας ο εκλεχθείς πάπας ήταν φαβορί
      λευκός_καπνός <-- Ψευδής
      ψηφοφορία <-- 0
      Αρχή_επανάληψης
            ψηφοφορία <-- ψηφοφορία + 1
            max <-- 0     ! για την εύρεση του νικητή *αυτής* της ψηφοφορίας

            ! μηδενισμός ψήφων κάθε υποψηφίου
            Για i από 1 μέχρι 18   
                  ΨΗΦ[i] <-- 0
            Τέλος_επανάληψης

            ! διεξαγωγή ψηφοφορίας
            Για κ από 1 μέχρι 115
                  Διάβασε όνομα
                  ! σειριακή αναζήτηση στον πίνακα ΥΠΟΨ
                  i <-- 1
                  θέση <-- 0
                  Όσο i <= 18 και θέση = 0 επανάλαβε
                        Αν ΥΠΟΨ[i] = όνομα τότε
                              θέση <-- i
                        Αλλιώς
                              i <-- i + 1
                        Τέλος_αν
                  Τέλος_επανάληψης
                  ΨΗΦ[θέση] <-- ΨΗΦ[θέση] + 1    ! προσθήκη ψήφου στον αντίστοιχο υποψήφιο
            Τέλος_επανάληψης

            Για i από 1 μέχρι 18
                  Αν ΨΗΦ[i] > max τότε
                        max <-- ΨΗΦ[i]
                        max_i <-- i
                  Τέλος_αν
                  Αν ΨΗΦ[i] >= (2/3) * 115 τότε
                        λευκός_καπνός <-- Αληθής    ! εκλέχθηκε πάπας
                        πάπας <-- i                 ! θέση του εκλεχθέντα πάπα στον πίνακα ΥΠΟΨ
                  Τέλος_αν
            Τέλος_επανάληψης

            Αν ψηφοφορία = 1 τότε
                  πρώτος_νικητής <-- max_i              ! κρατάει τη θέση του υποψήφιου που κέρδισε την πρώτη ψηφοφορία
            Αλλιώς_αν max_i <> πρώτος_νικητής τότε      ! o τρέχων νικητής είναι διαφορετικός από τον νικητή της πρώτης ψηφοφορίας
                  φαβορί <-- Ψευδής                     ! άρα δεν υπάρχει φαβορί
            Τέλος_αν

            Αν λευκός_καπνός = Αληθής τότε
                  Γράψε "Λευκός καπνός"
            Αλλιώς
                  Γράψε "Μαύρος καπνός"
            Τέλος_αν
      Μέχρις_ότου λευκός_καπνός = Αληθής

      Γράψε "Ο νέος Πάπας είναι ο", ΥΠΟΨ[πάπας]
      Αν φαβορί = Αληθής τότε
            Γράψε "Ο Πάπας ήταν το φαβορί"
      Αλλιώς
            Γράψε "Αουτσάιντερ"
      Τέλος_αν

Τέλος Θέμα_Γ
« Τελευταία τροποποίηση: 12 Μάι 2015, 12:29:44 μμ από tdiam »

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #38 στις: 12 Μάι 2015, 12:45:09 πμ »
Προστέθηκε το αρχείο λύσεων στο αρχικό μήνυμα.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #39 στις: 12 Μάι 2015, 12:52:25 πμ »
Μία εναλλακτική ματιά στο Γ' Θέμα, χωρίς αποθήκευση των νικών κάθε υποψηφίου:
Αν ο εκλεχθείς Πάπας ήταν φαβορί, τότε όλες οι ψηφοφορίες θα είχαν αυτόν νικητή.
Άρα, αν σε οποιαδήποτε ψηφοφορία βρούμε νικητή διαφορετικό από τον νικητή της 1ης ψηφοφορίας, δεν υπάρχει φαβορί.

Όπως προαναφέρθηκε από άλλους συναδέλφους, το πρόβλημα δημιουργείται από το γεγονός ότι μπορεί σε κάποιες ψηφοφορίες (εκτός φυσικά από την τελευταία) να έχουμε ισοψηφίες στην 1η θέση...

tdiam

  • Οπαδός
  • **
  • Μηνύματα: 16
  • Why's the rum gone?
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #40 στις: 12 Μάι 2015, 12:25:55 μμ »
Ναι, έχεις δίκιο! Άρα φάουλ η απάντηση.

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #41 στις: 12 Μάι 2015, 01:49:04 μμ »
για το Α3 μπορούσε να είναι :
1)1
2)N-1
3)1
4)N-1
5)1
6)j
7)j
8)j+1

σελίδα 49 τετράδιο μαθητή
βέβαια κάνει πολλές περιττές συγκρίσεις. Για μένα σωστή είναι η λύση που δώσατε αλλά... τι θα γινόταν εάν ένας μαθητής έδινε την παραπάνω λύση;




VR in Computing

it0466

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #42 στις: 12 Μάι 2015, 07:29:12 μμ »
Θα ήθελα την γνώμη σας για μια λύση για το θέμα Α3. Πιστεύω ότι δουλεύει, τι λέτε;

Κώδικας: Pascal
  1. Για i από Ν μέχρι 2 με_βήμα -1
  2.      Για j από 1 μέχρι i-1 με_βήμα 1
  3.              Αν Α(j) > A(j+1) τότε
  4.                     Αντιμετάθεσε A(j), A(j+1)
  5.              Τέλος_αν
  6.      Τέλος_επανάληψης
  7. Τέλος_επανάληψης

Συγχαρητήρια για τα θέματα, είναι πάρα πολύ ωραία.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #43 στις: 12 Μάι 2015, 07:57:29 μμ »
και μένα μου φαίνεται ότι δουλεύει, με μια πρώτη ματιά
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

mdelhmh

  • Νέος
  • *
  • Μηνύματα: 7
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #44 στις: 13 Μάι 2015, 07:33:11 μμ »
Τα θέματα ειναι ΕΞΑΙΡΕΤΙΚΑ !!!! Μολις κατεβασα και το αρχειο των λύσεων και ειναι ενδιαφέρουσες και ιδιαίτερα κομψές!!! Ενα τεραστιο ΜΠΡΑΒΟ στην ομάδα !!!!

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #45 στις: 14 Μάι 2015, 12:45:21 πμ »
Η ομάδα ευχαριστεί όλους τους συναδέλφους για τα καλά τους λόγια...

Καλή επιτυχία στους μαθητές που σε λίγες μέρες ξεκινούν τις εξετάσεις τους!

Diotima

  • Επισκέπτης
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2014-2015 από το Στέκι
« Απάντηση #46 στις: 23 Μάι 2015, 11:23:40 μμ »
Αν και καθυστερημένα κάπως θέλω να σας πω Χίλια Συγχαρητήρια!!! για το εξαιρετικό επαναληπτικό σας διαγώνισμα. Είναι από τα πιο ωραία διαγωνίσματα που έχω δει ποτέ.
Δύσκολο όσο πρέπει, χωρίς να είναι τραβηγμένο από τα μαλλιά, έξυπνο, πρωτότυπο, τα έχει όλα!!!
Μπράβο σας!!!

Προσωπικά χάρηκα γιατί τη λειτουργία του undo και redo την έχω στις σημειώσεις μου που δίνω στους μαθητές μου ως παράδειγμα εφαρμογής της στοίβας οπότε στο Α1.α.4 πιστεύω ότι θα απαντήσουν σωστά. (Διότι απαξιώ να τους λέω μόνο παραδείγματα από την καθημερινή ζωή της νοικοκυράς, στοίβα από πιάτα κ.τ.λ.)
Δυστυχώς είχα μεγάλο φόρτο εργασίας πριν τις Πανελλαδικές και είχα αναλάβει να βοηθήσω και την ανιψιά μου στα μαθηματικά που έδινε στο ΕΠΑΛ και χτύπησα 12ωρα δουλειάς. Οπότε κάθισα και το έλυσα εχθές και είδα και τις λύσεις σας.
Επειδή εργάζομαι σε φροντιστήριο με 8 τμήματα στο ΑΕΠΠ φέτος, θα κάνω μια επανάληψη με το διαγώνισμα σας τις παραμονές της εξέτασης.
Σας ευχαριστώ από καρδιάς!