Αποστολέας Θέμα: Εύρεση min max  (Αναγνώστηκε 3697 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3164
  • to Iterate is human to Recurse divine
Απ: Εύρεση min max
« Απάντηση #15 στις: 07 Ιαν 2015, 06:01:33 μμ »
ο κατάλληλος είναι αυτός τον οποίο θα εφάρμοζες στο χαρτί, δηλαδή ο αλγόριθμος που θα σχεδίαζες στο φυσικό μοντέλο του πραγματικού κόσμου και όχι στο μοντέλο της νοητής μηχανής για την οποία προγραμματίζουμε. Τι θέλω να πω τώρα.
Αν σου έλεγα το εξής σενάριο
Σου δίνω αριθμούς (έναν-έναν) και βρες μου ποιος είναι ο μεγαλύτερος.
Μετά τον πρώτο αριθμό θα με ρώταγες συνέχεια ποιος είναι ο πρώτος;

Ποιος είναι ο κατάλληλος τρόπος εύρεσης μεγίστου με γνωστό αριθμό επαναλήψεων;
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Εύρεση min max
« Απάντηση #16 στις: 07 Ιαν 2015, 06:37:56 μμ »
αυτό που παρέθεσα για ι=1 είναι το ίδιο με αυτό που δόθηκε αρχικά. Έχει την ίδια λογική απλά δείχνει λίγο ακραία ότι κάτι δεν πάει καλά με αυτό το σκεπτικό.
όπως είπα και πριν δεν είναι θέμα πολυπλοκότητας αλλά φιλοσοφίας και τρόπου σκέψης

δεν είναι η ίδια, προφανώς εννοείς τάξη πολυπλοκότητας και όχι πολυπλοκότητα που είναι η συνάρτηση T(N)

Ναι οκ, τάξη πολυπλοκότητας, όριο, όπως βολεύεται ο καθένας. Ποια ειναι λοιπόν η φιλοσοφία που θα μεταφέρουμε σε ποιον;  Στον άνθρωπο που θα δει για ένα χρόνο από τη ζωή του ΑΕΠΠ και δεν θα ασχοληθεί ξανα ποτέ, ή στον άνθρωπο που θα ασχοληθεί και θα μάθει ότι δεν έχει καμια σημασία το συγκεκριμένο θέμα; Νόμιζα ότι πιάσαμε κάτι πολύ απλό και το τραβάμε από τα μαλλιά.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Εύρεση min max
« Απάντηση #17 στις: 07 Ιαν 2015, 07:27:12 μμ »
ο κατάλληλος είναι αυτός τον οποίο θα εφάρμοζες στο χαρτί, δηλαδή ο αλγόριθμος που θα σχεδίαζες στο φυσικό μοντέλο του πραγματικού κόσμου και όχι στο μοντέλο της νοητής μηχανής για την οποία προγραμματίζουμε. Τι θέλω να πω τώρα.
Αν σου έλεγα το εξής σενάριο
Σου δίνω αριθμούς (έναν-έναν) και βρες μου ποιος είναι ο μεγαλύτερος.
Μετά τον πρώτο αριθμό θα με ρώταγες συνέχεια ποιος είναι ο πρώτος;


Αυτούς τους αριθμούς, τους δέχομαι εντός επανάληψης και σε άσκηση που ζητάει άλλα 4-5 πράγματα
Δεν είναι απλά αριθμοί που ζητάμε το μέγιστο, όπου είναι αυτονόητο το τι κάνουμε (αυτό δηλαδή που κάνουμε στους πίνακες)
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 63
Απ: Εύρεση min max
« Απάντηση #18 στις: 08 Ιαν 2015, 04:34:06 μμ »
Για μένα ο καλύτερος τρόπος είναι ο παρακάτω:

 Διάβασε χ
min ←  χ
max← χ
Για i από 2 μέχρι Κ
    Διάβασε χ
    Αν (χ < min) τότε
      min ← χ
    Τέλος_αν
    Αν (χ>max) τότε
      max ← χ
    Τέλος_αν
  Τέλος_επανάληψης
  Εκτύπωσε min, max

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 63
Απ: Εύρεση min max
« Απάντηση #19 στις: 08 Ιαν 2015, 09:02:25 μμ »
Για μενα ο καλυτερος τροπος ειναι ο παρακατω:

Διάβασε χ
min ←  χ
max← χ
Για i από 2 μέχρι Κ
    Διάβασε χ
    Αν (χ < min) τότε
      min ← χ
    Τέλος_αν
    Αν (χ > max) τότε
      max ← χ
  Τέλος_επανάληψης
  Εκτύπωσε min, max


petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Εύρεση min max
« Απάντηση #20 στις: 08 Ιαν 2015, 10:24:48 μμ »
Και αν η άσκηση ζητά να βρεθεί ο μέσος όρος των βαθμών πάνω από 18, κάτω από 10 και ο μεγαλύτερος βαθμός κάτω του 15;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

anestis85

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Εύρεση min max
« Απάντηση #21 στις: 24 Αύγ 2018, 06:42:00 μμ »
Καλησπέρα συνάδελφοι. Σε συνέχεια της συζήτησης θα ήθελα να θέσω το εξής ερώτημα. Κατά πόσο είναι έγκυρη η παρακάτω λογική αρχικοποίησης max και min? Στην Γλώσσα ορίζεται επίσημα το εύρος των τιμών;

 min ←  10^9
 max←  - 10^9
 Για i από 1 μέχρι 200
    Διάβασε χ
    Aν χ < min τότε  min ← χ
    Aν χ>max τότε   max ← χ
 Τέλος_επανάληψης
  Εκτύπωσε min, max

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Εύρεση min max
« Απάντηση #22 στις: 25 Αύγ 2018, 10:33:07 πμ »
Η συγκεκριμένη μεθοδολογία είναι καλό να χρησιμοποιείται όταν υπάρχουν κάποια συγκεκριμένα ή λογικά όρια τιμών μιας μεταβλητής (πχ μόνο θετικά, 1-100, θερμοκρασίες στην Ελλάδα κτλ.)
Θα πρέπει να αποφεύγεται σε περιπτώσεις που δεν υπάρχουν όρια και να επιλέγεται κάποιος άλλος αλγόριθμος
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

anestis85

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Εύρεση min max
« Απάντηση #23 στις: 25 Αύγ 2018, 01:47:03 μμ »
Άρα θεωρείται εσφαλμένη η συγκεκριμένη διατύπωση; Την έχω εντοπίσει σε αρκετές λύσεις και σε βοηθήματα. Και αν θυμάμαι καλά είχε προταθεί αυτός ο αλγόριθμος ως λύση λόγω των ορίων που θέτει ο ίδιος ο μεταγλωττιστής της ΓΛΩΣΣΑΣ.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5093
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Εύρεση min max
« Απάντηση #24 στις: 25 Αύγ 2018, 04:26:38 μμ »
είχε προταθεί αυτός ο αλγόριθμος ως λύση λόγω των ορίων που θέτει ο ίδιος ο μεταγλωττιστής της ΓΛΩΣΣΑΣ.

Η ΓΛΩΣΣΑ δεν έχει μεταγλωττιστή.
Η ΓΛΩΣΣΑ δεν ορίζει όρια.
Ο Διερμηνευτής της ΓΛΩΣΣΑΣ ορίζει όρια, αλλά δεν έχουν καμία απολύτως σχέση με αυτά που προαναφέρθηκαν:
http://alkisg.mysch.gr/ΓΛΩΣΣΑ/Τύποι_δεδομένων/

Το να χρησιμοποιηθούν αβάσιμα όρια όταν δεν υπάρχει όριο στην άσκηση, είναι λάθος.
Όπως όμως είπε ο Πέτρος, αυτή η μέθοδος μπορεί να χρησιμοποιηθεί εάν στα δεδομένα εισόδου υπάρχουν όρια, π.χ. βαθμοί.