Αποστολέας Θέμα: Άσκηση σε πολλαπλή δομή επιλογής  (Αναγνώστηκε 621 φορές)

thCnd

  • Οπαδός
  • **
  • Μηνύματα: 14
Άσκηση σε πολλαπλή δομή επιλογής
« στις: 16 Σεπ 2014, 07:07:42 πμ »
Καλημέρα,
θα ήθελα να ρωτήσω πώς λύνεται μία άσκηση με κλαδική συνάρτηση όπου το x ανήκει στα διαστήματα (-5,0],     (0,5]     και για κάθε άλλο x.

Εγώ σκέφτηκα τη λύση
Αν x > -5 και x <=o τότε
    Εντολές
Αλλιώς_αν x > 0 και x <=5 τότε
    Εντολές
Αλλιώς
    Εντολές
Τέλος_αν

Ευχαριστώ εκ των προτέρων  :)

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 39
Απ: Άσκηση σε πολλαπλή δομή επιλογής
« Απάντηση #1 στις: 16 Σεπ 2014, 10:53:02 πμ »
Μια χαρά λύση!
Κουβέντα να γίνεται, μια άλλη προσέγγιση θα ήταν η ακόλουθη:

Αν x <= -5 τότε
  Εντολές 1
Αλλιώς_αν x <= 0 τότε
  Εντολές 2
Αλλιώς_αν x <= 5 τότε
  Εντολές 3
Αλλιώς
  Εντολές 1
Τέλος_αν