Αποστολέας Θέμα: Επαναληπτικές Εξετάσεις 2014  (Αναγνώστηκε 11262 φορές)

stark

  • Νέος
  • *
  • Μηνύματα: 6
Επαναληπτικές Εξετάσεις 2014
« στις: 24 Ιούν 2014, 06:45:50 μμ »
Τα θέματα:http://www.minedu.gov.gr/publications/docs2014/them_plir_kat_c_hmer_epan_140624.pdf

Με μια πρώτη ανάγνωση,ως μαθητής,τα κρίνω εμφανώς πιο απαιτητικά από αυτά των κανονικών εξετάσεων.Εκ του ασφαλούς,θα τα σχολιάσω αύριο,αφού πρώτα τα επεξεργαστώ.Πάντως αίσθηση μου έκανε το ζήτημα Α2.β.Εκτιμώ ότι θα «ξάφνιασε» τους πανελληνιομάχους που εξετάζονταν σήμερα στο συγκεκριμένο μάθημα.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #1 στις: 24 Ιούν 2014, 07:08:02 μμ »
Έλεος, τι πήγαν και έβαλαν...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #2 στις: 24 Ιούν 2014, 07:45:59 μμ »
Ας δούμε τις  λύσεις :

Θέμα Α

Α1. 1.Λ
      2.Λ (επειδή στις στατικές δομές δεν μπορούμε να κάνουμε  διαγραφή)
      3.Λ
      4.Σ
      5.Σ

Α2.α  θεωρία ορισμός σελ 8

Α2.β  όπως το παράδειγμα στην σελίδα 11 του σχολικού ( Απορώ για την επιλογή του συγκεκριμένου θέματος .
        Προσωπικά την θεωρώ άστοχη)

Α3.    Για  j από 1 μέχρι 6
                temp <-  A[2,j]
                A[2,j] <- A[5,j]                Δεν μπορεί να χρησιμοποιηθεί η εντολή Αντιμετάθεσε γιατί χρησιμοποιούμε ΓΛΩΣΣΑ
                A[5,j] <-  temp
         τέλος_επανάληψης



 
 
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #3 στις: 24 Ιούν 2014, 08:00:29 μμ »
Α4. Χρησιμοποιούμε στοίβα γιατί κατά την διαδοχική κλήση υποπρογραμμάτων (πχ αναδρομή) όταν ολοκληρωθεί το τρέχον υποπρόγραμμα θέλουμε να επιστρέφουμε στο τελευταίο που καλέσαμε και όχι στο πρώτο (αυτό θα συνεβαινε αν είχαμε χρησιμοποιήσει ουρά)

Α5. α   Ορισμός σελ 187 σχολικού

Α5. β    Αλγόριθμος Συνένωση
           Δεδομένα // Α,Ν,Β,Μ//
           Για i  από 1 μέχρι Ν
              Γ[ i ] <- Α [ i ]
           τέλος_επανάληψης
           Για i  από Ν+1 μέχρι Ν+Μ
              Γ[ i ] <- Β[ i - Ν ]                               
           τέλος_επανάληψης   
           Τέλος Συνένωση 
 
         Η δεύτερη επανάληψη μπορεί να γραφεί ισοδύναμα και ως εξής:

           Για i  από 1 μέχρι Μ
              Γ[ i + Ν ] <- Β[ i ]                               
           τέλος_επανάληψης   
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2784
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #4 στις: 24 Ιούν 2014, 08:13:07 μμ »
Α5. β    Αλγόριθμος Συνένωση
           Δεδομένα // Α,Ν,Β,Μ//
           Για i  από 1 μέχρι Ν
              Γ[ i ] <- Α [ i ]
           τέλος_επανάληψης
           Για i  από Ν+1 μέχρι Ν+Μ
              Γ[ i ] <- Β[ i - Ν ]                               
           τέλος_επανάληψης   
           Τέλος Συνένωση 
 
         Η δεύτερη επανάληψη μπορεί να γραφεί ισοδύναμα και ως εξής:

           Για i  από 1 μέχρι Μ
              Γ[ i + Ν ] <- Β[ i ]                               
           τέλος_επανάληψης   

"Συνένωση πινάκων" (2011):
http://alkisg.mysch.gr/steki/index.php?topic=3761

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #5 στις: 24 Ιούν 2014, 08:21:31 μμ »
Θέμα Γ

Αλγόριθμος Διοφαντική
 Δεδομένα //Α,Β,Γ,Δ//
 δ <- Ψευδής
 max <- 0
 Π <- 0
 Π1 <- 0
 Π2 <- 0
 Για x από -99 μέχρι 99
  Για y από -99 μέχρι 99
    Για z από -99 μέχρι 99
      Αν Α*x+B*y+Γ*z = Δ τότε
         εμφάνισε x,y,z
         δ <- Αληθής
         Αν x+y+z > max τότε
            max <- x+y+z
            λ[1] <- x
            λ[2] <- y
            λ[3] <- z
         τέλος_αν
         Π <- Π + 1
         Αν (x>0 και x mod 2 = 0 ) και (y>0 και y mod 2 = 0 ) και (z>0 και z mod 2 = 0 ) τότε
             Π2 <- Π2 + 1
         Τελος_αν 
         Αν (x= 0 και y<>0 και z<>0) ή (x<>0 και y=0 και z<>0) ή ( x<>0 και y<>0 και z=0) τότε
             Π1 <- Π1 + 1
         τέλος_αν
       τέλος_αν
     Τέλος_επανάληψης
   Τέλος_επανάληψης
 Αν δ = Ψευδής τότε
    Εμφάνισε " Δεν υπάρχουν τέτοιες λύσεις"
 αλλιώς 
    Εμφάνισε "Πρώτη λύση με το μεγαλύτερο άθροισμα", λ[1] , λ[2] , λ[3] 
    Εμφάνισε Π2
    ποσ <- (Π1/Π)*100
    Εμφάνισε ποσ
 Τέλος_αν
Τελος Διοφαντική
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #6 στις: 24 Ιούν 2014, 08:32:09 μμ »
Θέμα Δ

Αλγόριθμος Εκλογές
!Δ1
Αρχή_επανάληψης
  Σ <- 0
  Για i από 1  μέχρι 34 ! εκλογικά καταστήματα
      Αρχή_επανάληψης
          Διάβασε τμήματα
      Μέχρις_ότου τμήματα >0
      ΕκΚατ[ i ] <- τμήματα
      Σ <- Σ + ΕκΚατ[ i ]
   Τέλος_επανάληψης
Μέχρις_ότου Σ = 217     

 Για i από 1  μέχρι 65
    Διάβασε ον[ i ]
    Για j από 1 μέχρι 217
      Διάβασε Ψηφ[ i , j ]
    Τέλος_επανάληψης
 Τέλος_επανάληψης
 
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #7 στις: 24 Ιούν 2014, 08:34:27 μμ »
! Δ2
Για i από 1  μέχρι 65
    Σ[ i ] <- 0
    Για j από 1 μέχρι 217
      Σ[ i ] <- Σ [ i ] + Ψηφ[ i , j ]
    Τέλος_επανάληψης
    Εμφάνισε Σ[ i ]
 Τέλος_επανάληψης
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #8 στις: 24 Ιούν 2014, 08:40:24 μμ »
! Δ3
Για i από 1  μέχρι 65
    Εκλ2[ i ] <- 0
    Για j από ΕκΚατ[ 1 ] +1  μέχρι  ΕκΚατ[ 1] +ΕκΚατ[ 2 ]
     Εκλ2[ i ] <- Εκλ2[ i ] + Ψηφ[ i , j ]
    Τέλος_επανάληψης
Τέλος_επανάληψης
max <-  Εκλ2[ 1 ]
Για i από 2  μέχρι 65
  Αν Εκλ2[ i ] > max τότε
       max <- Εκλ2[ i ]
  τέλος_αν
Τέλος_επανάληψης
Για i από 1  μέχρι 65
 Αν Εκλ2[ i ] = max τότε
    Εμφάνισε ον[ i ]
 Τέλος_αν
Τέλος_επανάληψης
 
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #9 στις: 24 Ιούν 2014, 08:50:40 μμ »
!Δ4
Για i από 2  μέχρι 65
    Για j από 65 μέχρι i με_βήμα  -1
       Αν Σ[ j-1 ] < Σ [ j ] τότε
            Αντιμετάθεσε  Σ[ j -1 ], Σ [ j ]
            Αντιμετάθεσε  ον[ j - 1 ], ον[ J ]
       τέλος_αν
    Τέλος_επανάληψης
 Τέλος_επανάληψης
  Για i από 1 μέχρι 10
     Υπ [ i ] <- ον [ i ]   
  τέλος_επανάληψης
   Όσο Σ[ i ]  =  Σ [ 10 ] επανάλαβε
     Υπ [ i ] <- ον [ i ]
     i <- i +1
  Τέλος_επανάληψης
   Για λ από 2  μέχρι i
    Για j από i μέχρι λ με_βήμα  -1
       Αν Υπ[ j-1 ] > Υπ [ j ] τότε
           Αντιμετάθεσε Υπ [ j - 1 ], Υπ [ J ]
       Τέλος_αν
    Τέλος_επανάληψης
  Τέλος_επανάληψης
  Για i από 1 μέχρι Κ   
    Εμφάνισε Υπ [ i ]   
  τέλος_επανάληψης

Τέλος Εκλογές
« Τελευταία τροποποίηση: 25 Ιούν 2014, 01:50:46 πμ από amanou »
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #10 στις: 24 Ιούν 2014, 08:55:46 μμ »
Αυτά για σήμερα επειδή λύθηκαν γρήγορα μπορεί κάτι να μου έχει διαφύγει.

Δεν λύνω το Θεμα Β που είναι η συμπλήρωση ενός Πίνακα αφού είναι αρκετά χρονοβόρα διαδικασία και αποτελεί ίσως το μόνο θέμα που μπορούσε κάποιος να το λύσει σχετικά άνετα

Τέλος ένα σχόλιο για τα θέματα πολύ απαιτητικά και δεν μπορώ να καταλάβω τον λόγο
Μακάρι να μπορούσε η επιτροπή να μας απαντήσει

Καλό καλοκαίρι και καλα αποτελέσματα στους υποψήφιους
 
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #11 στις: 24 Ιούν 2014, 09:01:41 μμ »
Τα θέματα των επαναληπτικών είναι πάντα εξαιρετικής δυσκολίας
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Χαράλαμπος Κτενίδης

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #12 στις: 25 Ιούν 2014, 12:29:50 μμ »
Μου άρεσε αρκετά το ερώτημα Δ.3 όμως θεωρώ ότι δεν ταιριάζει στη συγκεκριμένη άσκηση και αυτό γιατί η εκφώνηση δεν περιγράφει καλά τη διαδικασία αρίθμησης των εκλογικών τμημάτων και είναι δύσκολο να κατανοηθεί από κάποιον. Μου θύμισε το περσινό 4ο θέμα των επαναληπτικών που ήταν δύσκολο λόγω του ότι η εκφώνηση ήταν πολύ συμπυκνωμένη και δεν καταλαβαίνεις εύκολα τι ζητάει. Όσο για το Α.2.β δεν μπορώ να καταλάβω το νόημα ύπαρξής του και το λόγο για τον οποίο πιάνει 6 μόρια.......

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #13 στις: 25 Ιούν 2014, 01:01:52 μμ »
Όσο για το Α.2.β δεν μπορώ να καταλάβω το νόημα ύπαρξής του και το λόγο για τον οποίο πιάνει 6 μόρια.......

Γιατί περιέχεται στο σχολικό εγχειρίδιο, όπως και οι κανόνες των εμφωλευμένων
ΔΥΣΤΥΧΩΣ
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3218
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Επαναληπτικές Εξετάσεις 2014
« Απάντηση #14 στις: 25 Ιούν 2014, 05:28:58 μμ »
Λογικά ήρθε η ώρα κάποιοι απο την επιτροπή εξετάσεων να καταλάβουν ότι δε χρειάζεται να ξαναβάλουν θέματα, παρά μόνο - σε εξαιρετική ανάγκη- στο σχολείο τους