Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 9305 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2450
  • I 'm not young enough to know everything
Θέμα Δ
« στις: 06 Ιούν 2014, 09:09:09 πμ »
Εδώ σχολιάζουμε το θέμα Δ

eara

  • Βετεράνος
  • ****
  • Μηνύματα: 79
Απ: Θέμα Δ
« Απάντηση #1 στις: 06 Ιούν 2014, 10:44:56 πμ »
Δ4. Ταπεινή μου άποψη: χρειάζεται διευκρίνηση προς βαθμολογητές για την κατανομή των 9 μονάδων, προς αποφυγή παρεξηγήσεων.

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #2 στις: 06 Ιούν 2014, 11:13:18 πμ »
Αλγόριθμος ΘέμαΔ
!Δ1
 Για ι από 1 μέχρι 10
    Διάβασε Ον[ι]
    Για j από 1 μέχρι 28
      Διάβασε Ε[i,j]
    τέλος_επανάληψης
τέλος_επανάληψης

!Δ2
Για ι από 1 μέχρι 10
    Σ<-0
    Για j από 1 μέχρι 28
      Σ<-Σ+ Ε[i,j]
    τέλος_επανάληψης
    εμφάνισε Ον[ι],Σ
τέλος_επανάληψης

!Δ3
δ<-ψευδής
 Για ι από 1 μέχρι 10
    Π<-0
    Για j από 1 μέχρι 28
      Αν Ε[ι,j] <=500 τότε Π<-Π+1
    τέλος_επανάληψης
    Αν Π=0 τότε
       εμφάνισε Ον[ι]
       δ<-αληθής
    τέλος_αν
τέλος_επανάληψης
Αν δ=ψευδής τότε εμφάνισε "δεν υπάρχει τέτοιος ιστότοπος"

Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #3 στις: 06 Ιούν 2014, 11:29:02 πμ »
!Δ4
Αρχή_επανάληψης
  Διάβασε ονομα
  δ <- ψευδής
  ι<- 1
  Όσο ι<=10 και  δ = ψευδής επανάλαβε
     Αν Ον[ι]=ονομα τότε
       δ<-αληθής
       ρ<- ι
      αλλιώς
       ι<- ι+1
      τέλος_αν
   τέλος_επανάληψης

Μέχρις_ότου δ= αληθής

Για ι από 1 μέχρι 4
  Κ <-(ι-1)*7
  Σ < - 0
  Για j από Κ+1 μέχρι Κ+7
    Σ <-  Σ + Ε[ρ,j]
  τέλος_επανάληψης
  Εβδ[ι] <- Σ
τέλος_επανάληψης

max <-Εβδ[1]
Για ι από 2 μέχρι 4
 Αν max <Εβδ[ι] τοτε
   max <-Εβδ[ι]
  τέλος_αν
τέλος_επαναληψης

Για ι από 1 μέχρι 4
 Αν max =Εβδ[ι] τοτε
   εμφάνισε ι 
τέλος_επαναληψης

Τέλος ΘεμαΔ
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

apanagio

  • ΟΔΕ
  • *
  • Μηνύματα: 163
Απ: Θέμα Δ
« Απάντηση #4 στις: 06 Ιούν 2014, 11:52:50 πμ »
Εγώ θα πρότεινα τρισδιαστατο πίνακα:

Αλγόριθμος ΘέμαΔ
!Δ1
 Για ι από 1 μέχρι 10
    Διάβασε Ον[ι]
    Για j από 1 μέχρι 4
        Για κ από 1 μέχρι 7
            Διάβασε Ε[i, j, κ]
      τέλος_επανάληψης
   τέλος_επανάληψης
τέλος_επανάληψης

!Δ2
Για ι από 1 μέχρι 10
    Σ<-0
    Για j από 1 μέχρι 4
        Για κ από 1 μέχρι 7
          Σ<-Σ+ Ε[i, j, κ]
      τέλος_επανάληψης
   τέλος_επανάληψης
    εμφάνισε Ον[ι],Σ
τέλος_επανάληψης

!Δ3
δ<- ψευδης
 Για ι από 1 μέχρι 10
    Για j από 1 μέχρι 4
        Για κ από 1 μέχρι 7
          Αν Ε[ι, j, κ] <=500 τότε Π<-Π+1
    τέλος_επανάληψης
    τέλος_επανάληψης
    Αν Π=0 τότε
       εμφάνισε Ον[ι]
       δ<-αληθής
    τέλος_αν
τέλος_επανάληψης
Αν δ=ψευδής τότε εμφάνισε "δεν υπάρχει τέτοιος ιστότοπος"

!Δ4
Αρχή_επανάληψης
  Διάβασε ονομα
  δ <- ψευδής
  ι<- 1
  Όσο ι<=10 και  δ = ψευδής επανάλαβε
     Αν Ον[ι]=ονομα τότε
       δ<-αληθής
       ρ<- ι
      αλλιώς
       ι<- ι+1
      τέλος_αν
   τέλος_επανάληψης

Μέχρις_ότου δ= αληθής

Για ι από 1 μέχρι 4
  Για j από 1 μέχρι 7
    Σ <-  Σ + Ε[ρ, i, j]
  τέλος_επανάληψης
  Εβδ[ρ] <- Σ
τέλος_επανάληψης

max <-Εβδ[1]
Για ι από 2 μέχρι 4
 Αν max <Εβδ[ι] τοτε
   max <-Εβδ[ι]
  τέλος_αν
τέλος_επαναληψης

Για ι από 1 μέχρι 4
 Αν max =Εβδ[ι] τοτε
   εμφάνισε ι
τέλος_επαναληψης

thanassis33

  • Οπαδός
  • **
  • Μηνύματα: 16
Απ: Θέμα Δ
« Απάντηση #5 στις: 06 Ιούν 2014, 12:01:15 μμ »
μπορεί να γίνει και με δισδιάστατο πίνακα και στην ΣΥΝΈΧΕΙΑ να δημιουργηθεί ένας νέος πίνακας ΕΒΔ[4]

georgetsiolis

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα Δ
« Απάντηση #6 στις: 06 Ιούν 2014, 01:58:23 μμ »
Εδώ σχολιάζουμε το θέμα Δ

σας παρακαλω απαντηστε μου λιγο. εγω ελυσα το θεμα Δ με τρισδιαστατο ! παρακαλω ελεγξτε το λιγο

chzisi

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Απ: Θέμα Δ
« Απάντηση #7 στις: 06 Ιούν 2014, 03:27:35 μμ »
Εχω ενα μαθητή που ελυσε με 1 μονοδιαστατο + 10 δισδιαστατους 4x7. του πηρε 6 σελίδες αλλά απάντησε σε όλα τα ερωτήματα. Τι λετε; θα χασει;

tiftikidis

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 7
Απ: Θέμα Δ
« Απάντηση #8 στις: 06 Ιούν 2014, 04:38:05 μμ »

!Δ4
Για ι από 1 μέχρι 4
   Σ<- 0
 Για j από 1 μέχρι 7
    Σ <-  Σ + Ε[ρ, i, j]
  τέλος_επανάληψης
  Εβδ[ρ] <- Σ
τέλος_επανάληψης

max <-Εβδ[1]
Για ι από 2 μέχρι 4
 Αν max <Εβδ[ι] τοτε
   max <-Εβδ[ι]
  τέλος_αν
τέλος_επαναληψης

Για ι από 1 μέχρι 4
 Αν max =Εβδ[ι] τοτε
   εμφάνισε ι
τέλος_επαναληψης

[/quote]

paoki4

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα Δ
« Απάντηση #9 στις: 06 Ιούν 2014, 08:32:07 μμ »
To ελυσα με τρισδιστατο και εγω!! Μπορει να μου το κοψουν ολο??? :-\ :-\

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #10 στις: 06 Ιούν 2014, 08:46:11 μμ »

Αν το έχεις σωστό θεωρώ ότι είναι δύσκολο να σου κόψουν, αλλά επειδή είναι ασυνήθιστο δεν μπορώ να στο πω με σιγουριά

To ελυσα με τρισδιστατο και εγω!! Μπορει να μου το κοψουν ολο??? :-\ :-\
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

tsakmaki

  • Οπαδός
  • **
  • Μηνύματα: 12
Απ: Θέμα Δ
« Απάντηση #11 στις: 06 Ιούν 2014, 10:23:53 μμ »
Συνάδελφοι βαθμολογητές, προσοχή στη λύση με τρισδιάστατο πίνακα. Απ ότι φαίνεται την έκαναν αρκετοί και πρέπει να βαθμολογηθεί κανονικά

patrick

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Θέμα Δ
« Απάντηση #12 στις: 06 Ιούν 2014, 11:24:09 μμ »
Συνάδελφοι βαθμολογητές, προσοχή στη λύση με τρισδιάστατο πίνακα. Απ ότι φαίνεται την έκαναν αρκετοί και πρέπει να βαθμολογηθεί κανονικά

+1

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 115
Απ: Θέμα Δ
« Απάντηση #13 στις: 07 Ιούν 2014, 12:00:08 πμ »

Πολύ χαίρομαι που βλέπω τη χρήση 3-διάστατου πίνακα, και στεναχωριέμαι που δε μού πέρασε κάτι τέτοιο από το μυαλό.

μία τέτοια λύση δείχνει ότι αυτός που την έκανε, έχει σχεδιάσει από την αρχή την κατάλληλη (την καταλληλότερη) δομή δεδομένων, που θα του χρησιμεύσει και θα τον διευκολύνει σε όλες του τις μελλοντικές επεξεργασίες...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #14 στις: 07 Ιούν 2014, 10:17:25 πμ »
νομίζω εκεί που έχεις ρ μήπως θέλει i?

Εγώ θα πρότεινα τρισδιαστατο πίνακα:

Κώδικας: Pascal
  1. Για ι από 1 μέχρι 4
  2.   Για j από 1 μέχρι 7
  3.     Σ <-  Σ + Ε[ρ, i, j]
  4.   τέλος_επανάληψης
  5.   Εβδ[i] <- Σ                                       ! αντί για Εβδ[ρ] <- Σ
  6. τέλος_επανάληψης
  7.  
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr