Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 9188 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Θέμα Δ
« στις: 06 Ιούν 2014, 09:09:09 πμ »
Εδώ σχολιάζουμε το θέμα Δ

eara

  • Βετεράνος
  • ****
  • Μηνύματα: 79
Απ: Θέμα Δ
« Απάντηση #1 στις: 06 Ιούν 2014, 10:44:56 πμ »
Δ4. Ταπεινή μου άποψη: χρειάζεται διευκρίνηση προς βαθμολογητές για την κατανομή των 9 μονάδων, προς αποφυγή παρεξηγήσεων.

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #2 στις: 06 Ιούν 2014, 11:13:18 πμ »
Αλγόριθμος ΘέμαΔ
!Δ1
 Για ι από 1 μέχρι 10
    Διάβασε Ον[ι]
    Για j από 1 μέχρι 28
      Διάβασε Ε[i,j]
    τέλος_επανάληψης
τέλος_επανάληψης

!Δ2
Για ι από 1 μέχρι 10
    Σ<-0
    Για j από 1 μέχρι 28
      Σ<-Σ+ Ε[i,j]
    τέλος_επανάληψης
    εμφάνισε Ον[ι],Σ
τέλος_επανάληψης

!Δ3
δ<-ψευδής
 Για ι από 1 μέχρι 10
    Π<-0
    Για j από 1 μέχρι 28
      Αν Ε[ι,j] <=500 τότε Π<-Π+1
    τέλος_επανάληψης
    Αν Π=0 τότε
       εμφάνισε Ον[ι]
       δ<-αληθής
    τέλος_αν
τέλος_επανάληψης
Αν δ=ψευδής τότε εμφάνισε "δεν υπάρχει τέτοιος ιστότοπος"

Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #3 στις: 06 Ιούν 2014, 11:29:02 πμ »
!Δ4
Αρχή_επανάληψης
  Διάβασε ονομα
  δ <- ψευδής
  ι<- 1
  Όσο ι<=10 και  δ = ψευδής επανάλαβε
     Αν Ον[ι]=ονομα τότε
       δ<-αληθής
       ρ<- ι
      αλλιώς
       ι<- ι+1
      τέλος_αν
   τέλος_επανάληψης

Μέχρις_ότου δ= αληθής

Για ι από 1 μέχρι 4
  Κ <-(ι-1)*7
  Σ < - 0
  Για j από Κ+1 μέχρι Κ+7
    Σ <-  Σ + Ε[ρ,j]
  τέλος_επανάληψης
  Εβδ[ι] <- Σ
τέλος_επανάληψης

max <-Εβδ[1]
Για ι από 2 μέχρι 4
 Αν max <Εβδ[ι] τοτε
   max <-Εβδ[ι]
  τέλος_αν
τέλος_επαναληψης

Για ι από 1 μέχρι 4
 Αν max =Εβδ[ι] τοτε
   εμφάνισε ι 
τέλος_επαναληψης

Τέλος ΘεμαΔ
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

apanagio

  • ΟΔΕ
  • *
  • Μηνύματα: 163
Απ: Θέμα Δ
« Απάντηση #4 στις: 06 Ιούν 2014, 11:52:50 πμ »
Εγώ θα πρότεινα τρισδιαστατο πίνακα:

Αλγόριθμος ΘέμαΔ
!Δ1
 Για ι από 1 μέχρι 10
    Διάβασε Ον[ι]
    Για j από 1 μέχρι 4
        Για κ από 1 μέχρι 7
            Διάβασε Ε[i, j, κ]
      τέλος_επανάληψης
   τέλος_επανάληψης
τέλος_επανάληψης

!Δ2
Για ι από 1 μέχρι 10
    Σ<-0
    Για j από 1 μέχρι 4
        Για κ από 1 μέχρι 7
          Σ<-Σ+ Ε[i, j, κ]
      τέλος_επανάληψης
   τέλος_επανάληψης
    εμφάνισε Ον[ι],Σ
τέλος_επανάληψης

!Δ3
δ<- ψευδης
 Για ι από 1 μέχρι 10
    Για j από 1 μέχρι 4
        Για κ από 1 μέχρι 7
          Αν Ε[ι, j, κ] <=500 τότε Π<-Π+1
    τέλος_επανάληψης
    τέλος_επανάληψης
    Αν Π=0 τότε
       εμφάνισε Ον[ι]
       δ<-αληθής
    τέλος_αν
τέλος_επανάληψης
Αν δ=ψευδής τότε εμφάνισε "δεν υπάρχει τέτοιος ιστότοπος"

!Δ4
Αρχή_επανάληψης
  Διάβασε ονομα
  δ <- ψευδής
  ι<- 1
  Όσο ι<=10 και  δ = ψευδής επανάλαβε
     Αν Ον[ι]=ονομα τότε
       δ<-αληθής
       ρ<- ι
      αλλιώς
       ι<- ι+1
      τέλος_αν
   τέλος_επανάληψης

Μέχρις_ότου δ= αληθής

Για ι από 1 μέχρι 4
  Για j από 1 μέχρι 7
    Σ <-  Σ + Ε[ρ, i, j]
  τέλος_επανάληψης
  Εβδ[ρ] <- Σ
τέλος_επανάληψης

max <-Εβδ[1]
Για ι από 2 μέχρι 4
 Αν max <Εβδ[ι] τοτε
   max <-Εβδ[ι]
  τέλος_αν
τέλος_επαναληψης

Για ι από 1 μέχρι 4
 Αν max =Εβδ[ι] τοτε
   εμφάνισε ι
τέλος_επαναληψης

thanassis33

  • Οπαδός
  • **
  • Μηνύματα: 16
Απ: Θέμα Δ
« Απάντηση #5 στις: 06 Ιούν 2014, 12:01:15 μμ »
μπορεί να γίνει και με δισδιάστατο πίνακα και στην ΣΥΝΈΧΕΙΑ να δημιουργηθεί ένας νέος πίνακας ΕΒΔ[4]

georgetsiolis

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα Δ
« Απάντηση #6 στις: 06 Ιούν 2014, 01:58:23 μμ »
Εδώ σχολιάζουμε το θέμα Δ

σας παρακαλω απαντηστε μου λιγο. εγω ελυσα το θεμα Δ με τρισδιαστατο ! παρακαλω ελεγξτε το λιγο

chzisi

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Απ: Θέμα Δ
« Απάντηση #7 στις: 06 Ιούν 2014, 03:27:35 μμ »
Εχω ενα μαθητή που ελυσε με 1 μονοδιαστατο + 10 δισδιαστατους 4x7. του πηρε 6 σελίδες αλλά απάντησε σε όλα τα ερωτήματα. Τι λετε; θα χασει;

tiftikidis

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 7
Απ: Θέμα Δ
« Απάντηση #8 στις: 06 Ιούν 2014, 04:38:05 μμ »

!Δ4
Για ι από 1 μέχρι 4
   Σ<- 0
 Για j από 1 μέχρι 7
    Σ <-  Σ + Ε[ρ, i, j]
  τέλος_επανάληψης
  Εβδ[ρ] <- Σ
τέλος_επανάληψης

max <-Εβδ[1]
Για ι από 2 μέχρι 4
 Αν max <Εβδ[ι] τοτε
   max <-Εβδ[ι]
  τέλος_αν
τέλος_επαναληψης

Για ι από 1 μέχρι 4
 Αν max =Εβδ[ι] τοτε
   εμφάνισε ι
τέλος_επαναληψης

[/quote]

paoki4

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα Δ
« Απάντηση #9 στις: 06 Ιούν 2014, 08:32:07 μμ »
To ελυσα με τρισδιστατο και εγω!! Μπορει να μου το κοψουν ολο??? :-\ :-\

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #10 στις: 06 Ιούν 2014, 08:46:11 μμ »

Αν το έχεις σωστό θεωρώ ότι είναι δύσκολο να σου κόψουν, αλλά επειδή είναι ασυνήθιστο δεν μπορώ να στο πω με σιγουριά

To ελυσα με τρισδιστατο και εγω!! Μπορει να μου το κοψουν ολο??? :-\ :-\
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

tsakmaki

  • Οπαδός
  • **
  • Μηνύματα: 12
Απ: Θέμα Δ
« Απάντηση #11 στις: 06 Ιούν 2014, 10:23:53 μμ »
Συνάδελφοι βαθμολογητές, προσοχή στη λύση με τρισδιάστατο πίνακα. Απ ότι φαίνεται την έκαναν αρκετοί και πρέπει να βαθμολογηθεί κανονικά

patrick

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Θέμα Δ
« Απάντηση #12 στις: 06 Ιούν 2014, 11:24:09 μμ »
Συνάδελφοι βαθμολογητές, προσοχή στη λύση με τρισδιάστατο πίνακα. Απ ότι φαίνεται την έκαναν αρκετοί και πρέπει να βαθμολογηθεί κανονικά

+1

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 115
Απ: Θέμα Δ
« Απάντηση #13 στις: 07 Ιούν 2014, 12:00:08 πμ »

Πολύ χαίρομαι που βλέπω τη χρήση 3-διάστατου πίνακα, και στεναχωριέμαι που δε μού πέρασε κάτι τέτοιο από το μυαλό.

μία τέτοια λύση δείχνει ότι αυτός που την έκανε, έχει σχεδιάσει από την αρχή την κατάλληλη (την καταλληλότερη) δομή δεδομένων, που θα του χρησιμεύσει και θα τον διευκολύνει σε όλες του τις μελλοντικές επεξεργασίες...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #14 στις: 07 Ιούν 2014, 10:17:25 πμ »
νομίζω εκεί που έχεις ρ μήπως θέλει i?

Εγώ θα πρότεινα τρισδιαστατο πίνακα:

Κώδικας: Pascal
  1. Για ι από 1 μέχρι 4
  2.   Για j από 1 μέχρι 7
  3.     Σ <-  Σ + Ε[ρ, i, j]
  4.   τέλος_επανάληψης
  5.   Εβδ[i] <- Σ                                       ! αντί για Εβδ[ρ] <- Σ
  6. τέλος_επανάληψης
  7.  
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

kostas.o

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Θέμα Δ
« Απάντηση #15 στις: 07 Ιούν 2014, 08:31:03 μμ »
Καλησπερα. Εγω το ελυσα με 1 δισδιαστατο (10x28 για τις επισκεψεις) και 1 μονοδιαστατο, για τα αθροισματα των εβδομαδων. Δειτε αυτο που εγραψα και πειτε μου αν εντοπισατε καποιο λαθος.

Προσπαθησα να σκεφτω κατι ποιο "γρηγορο" για το Δ4 απο το να γραψω 4 επαναληψης ΓΙΑ.

!Δ3

βρεθηκε<-ψευδης
Για i απο 1 μεχρι 10
  j<-0
  Αρχη_επαναληψης
    j<-j+1
  Μεχρις_οτου ΕΠ[i,j]<=500 'Η j=28
  Αν j=28 ΚΑΙ ΕΠ[i,28]>500 τοτε
    Γραψε "ο ιστοτοπος", ον[ i]
    βρεθηκε<-αληθης
  τελος_αν
Τελος_επαναληψης
Αν βρεθηκε=ψευδης τοτε
  γραψε "δεν βρεθηκε ιστοτοπος"
τελος_αν

!Δ4

βρεθηκε<-Ψευδης
Οσο βρεθηκε=ψευδης επαναλαβε
   Διαβασε ονομα
   i<-1
   Οσο i<=10 και βρεθηκε=ψευδης επαναλαβε
      Αν Ον[ i]=ονομα τοτε
         βρεθηκε<-αληθης
         θ<-i
      αλλιως
         i<-i+1
      τελος_αν
   τελος_επαναληψης
τελος_επαναληψης


!Για να υπολογισω τα αθροισματα τις καθε εβδομαδας εγραψα χρησιμοποιησα μονοδιαστατο πινακα 4 θεσεων.

Για i απο 1 μεχρι 4
   sum_εβδ[ i ]<-0
   Για j απο ((i-1)*7 + 1) μεχρι i*7
      sum_εβδ[ i ]<-sum_εβδ[ i ]+EΠ[θ,j]
   τελος_επαναληψης
τελος_επαναληψης

max <-sum_εβδ[1]
Για i από 2 μέχρι 4
 Αν max <sum_εβδ[ i ] τοτε
   max <-sum_εβδ[ i ]
  τέλος_αν
τέλος_επαναληψης

Για i από 1 μέχρι 4
 Αν max =sum_εβδ[ i ] τοτε
   εμφάνισε i
τέλος_επαναληψης

Rathaniel

  • Βετεράνος
  • ****
  • Μηνύματα: 77
  • Έπρεπε να είχα γίνει Χημικός......
Απ: Θέμα Δ
« Απάντηση #16 στις: 07 Ιούν 2014, 11:53:14 μμ »
Σας παραθέτω πως έγινε η βαθμολόγηση για το ΘΕΜΑ Δ για τους σημερινούς Φ.Α. μετά από αρκετή κουβέντα με τους 27 συναδέλφους των επιτροπών (Συγχωρήστε αν γράφω τα προφανή):

Δ1. Διάβασμα ονομάτων  πήρε 1 μονάδα
       Διάβασμα αριθμού επισκέψεων πήρε 1 μονάδα.

Δ2.Ο υπολογισμός πήρε 2 μονάδες.
      Η εμφάνιση 1 μονάδα.

Δ3.Η σάρωση του πίνακα για μεγαλύτερα του 500 και αύξηση μετρητή πήρε 3 μονάδες.
      Η χρήση και ο έλεγχος ενός flag για περίπτωση μηδενική πήρε μία μονάδα.
      Η εμφάνιση των ονομάτων πήρε μία μονάδα, και άλλη μία η περίπτωση να μην υπάρχουν τέτοιοι ιστότοποι.

Δ4. Χωρίστηκε σε τρία κομμάτια , το κάθε ένα αξίας 3 μονάδων:
      - 1o : Αναζήτηση και έμμεσος έλεγχος εγκυρότητας
      -  2ο: Ο υπολογισμός εβδομαδιαίων επισκέψεων (πίνακας τεσσάρων στοιχείων ή τέσσερις μεταβλήτές)
      - 3ο: Η εύρεση του max από το 2ο, και η εύρεση των ίσων με το max, και εμφάνιση.

Σημείωσεις: Την λύση με τρισδιάστατο τη θεωρήσαμε σωστή.
                  Στο Δ2 δεν ήταν απαραίτητη η χρήση πίνακα.

Ερώτηση προς τους πιο έμπειρους: Πόσα θα χάσει ένας μαθητής εδώ αν τα έκανε όλα "σωστά" χωρίς τη χρήση πίνακα;
                 
Χρηστίδης Αλέξανδρος,
Μηχανικός Επ/κών και Πλη/κών Συστημάτων,
Msc Στα Προηγμένα Συστήματα Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #17 στις: 08 Ιούν 2014, 12:22:37 πμ »
Το Δ χωρίς πίνακα δεν γίνεται. Πιο συγκεκριμένα το Δ4 είναι που χρειάζεται πίνακα, και όσον αφορά την αναζήτηση αλλά και όσον αφορά την εύρεση αυτών με το μέγιστο.
Τα υπόλοιπα ερωτήματα νομίζω χωρίς πίνακα βγαίνουν μια χαρά. Άρα σε αυτά παίρνει όλες τις μονάδες και στο Δ4 εξαρτάται πως θα το κάνει.

Πόσα θα χάσει ένας μαθητής εδώ αν τα έκανε όλα "σωστά" χωρίς τη χρήση πίνακα;                 
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Θέμα Δ
« Απάντηση #18 στις: 08 Ιούν 2014, 12:31:44 πμ »
Σχόλιο για το μάθημα "Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον"

Από πατέρα μαθητή που έλυσε το Θέμα Δ με τρισδιάστατο...

Mathitis14

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Θέμα Δ
« Απάντηση #19 στις: 08 Ιούν 2014, 01:42:20 μμ »
Το Δ4 το ελυσα με 2 τροπους γιατι δεν μπορουσα να καταλαβω τι ζηταγε το 2ο υποερωτημα . Συγκεκριμενα ο πρωτος τροπος ηταν αυτος που ειναι ο σωστος και ο δευτερος  πηγα και βρηκα για ολα τα σαιτ την επισκεψημοτητα τους για καθε βδομαδα και τα συνεκρινα με το ζητουμενο σαιτ και οταν το σαιτ το ζητουμενο ειχε την πιο μεγαλη επισκεψημοτητα το εμφανιζα . Αλλα εγραψα με !σχολια στον βαθμολογητη οτι δεν μπορουμε να καταλαβω τι μου ζητουσαν και εκανα και τους 2 τροπους για καθε περιπτωση . Σε ενα διαγωνισμα μεσα στην ταξη ο καθηγητης θα μου ειχε πει τι ηθελε να κανω . Στις πανελληνιες μετα τις 10:30 μονο ο θεος μπορει να σου πει . Ποσο λετε να μου κοψουν ??? Ας αναλογιστουν οτι δεν μπορουσα να ρισκαρω τις 6 μοναδες !!!

kikilymp

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Θέμα Δ
« Απάντηση #20 στις: 08 Ιούν 2014, 11:22:45 μμ »
Ο γιος της φίλης μου το έλυσε χρησιμοποιώντας μόνο ένα πίνακα 10Χ4.  ;) Δείτε το!!!
Το έτρεξα και στο www.pseudoglossa.gr  :) και είναι ολόσωστο!!!
Αλγόριθμος D
Για i από 1 μέχρι 10
   ON[i ] ← " "
     Για j από 1 μέχρι 4
   B[i,j]← 0
     Τέλος_επανάληψης
Τέλος_επανάληψης
λ← 0
Για i από 1 μέχρι 10
   Διάβασε ON[i ]
   k← 1
   m← 0
   S← 0
   Για j από 1 μέχρι 28
      Διάβασε Αρ_Επ
      S← S+ Αρ_Επ
      Αν Αρ_Επ>500 τότε
         m← m+1
      Τέλος_αν
                   B[i,k] ← B[i,k] + Αρ_Επ   
                          Αν j mod 7 =0 τότε
      k← k+1
                         Τέλος_αν
   Τέλος_επανάληψης
      Εμφάνισε ON[i ],S
      Αν m=28 τότε
           Εμφάνισε  ON[i ]
           λ← 1
      Τέλος_αν
Τέλος_επανάληψης
   Αν λ<>1 τότε
                     Εμφάνισε "Δεν υπάρχουν τέτοιοι ιστότοποι"
   Τέλος_αν
                 w← 0
              Αρχή_επανάληψης
      Διάβασε ONOMA
        Για i από 1 μέχρι 10
      Αν ON[i ]=ONOMA τότε
           w← 1
          pos← i
      Τέλος_αν
        Τέλος_επανάληψης
   Μέχρις_ότου w=1
   max← 0
   Για i από 1 μέχρι 4
      Αν B[pos,i]> max τότε
           max← B[pos,i]
      Τέλος_αν
   Τέλος_επανάληψης
   Για i από 1 μέχρι 4
      Αν B[pos,i]= max τότε
           Εμφάνισε i
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος D
« Τελευταία τροποποίηση: 09 Ιούν 2014, 01:00:00 πμ από kikilymp »

Άρης Κεσογλίδης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: Θέμα Δ
« Απάντηση #21 στις: 09 Ιούν 2014, 11:36:46 μμ »
Το Δ4 το ελυσα με 2 τροπους γιατι δεν μπορουσα να καταλαβω τι ζηταγε το 2ο υποερωτημα . Συγκεκριμενα ο πρωτος τροπος ηταν αυτος που ειναι ο σωστος και ο δευτερος  πηγα και βρηκα για ολα τα σαιτ την επισκεψημοτητα τους για καθε βδομαδα και τα συνεκρινα με το ζητουμενο σαιτ και οταν το σαιτ το ζητουμενο ειχε την πιο μεγαλη επισκεψημοτητα το εμφανιζα . Αλλα εγραψα με !σχολια στον βαθμολογητη οτι δεν μπορουμε να καταλαβω τι μου ζητουσαν και εκανα και τους 2 τροπους για καθε περιπτωση . Σε ενα διαγωνισμα μεσα στην ταξη ο καθηγητης θα μου ειχε πει τι ηθελε να κανω . Στις πανελληνιες μετα τις 10:30 μονο ο θεος μπορει να σου πει . Ποσο λετε να μου κοψουν ??? Ας αναλογιστουν οτι δεν μπορουσα να ρισκαρω τις 6 μοναδες !!!

Αυτό το πρόβλημα ασάφειας θεώρησα κι εγώ ότι υπάρχει.

Όταν λέει δηλαδή
"Να εμφανίζει τους αριθμούς των εβδομάδων (1-4) κατά τη διάρκεια των οποίων ο συνολικός (εβδομαδιαίος) αριθμός επισκέψεων στον ιστότοπο αυτό είχε τη μέγιστη τιμή."

δεν εξηγεί τη εννοεί με το μέγιστη.
Μέγιστη δική του στις 4 εβδομάδες, ή μέγιστη από τους ιστοτόπους σε κάθε εβδομάδα;;
Εγώ κατάλαβα το 2ο και λέω "να ένα καλό ερώτημα για 3 επαναλήψεις!"...

Και λέω:
----------------
ΓΙΑ  κ  ΑΠΟ  1  ΜΕΧΡΙ  4
      αρχή ← 1

      μεγ ← -1
      ΓΙΑ  i  ΑΠΟ  i  ΜΕΧΡΙ  10
            ΣΕ[ i ] ← 0                                  ! 10 σύνολα της τρέχουσας κ εβδομάδας
            ΓΙΑ  j  ΑΠΟ  αρχή  ΜΕΧΡΙ  αρχή+6
                  ΣΕ[ i ] ← ΣΕ + ΕΠ[i, j]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

            ΑΝ  ΣΕ[ i ] > μεγ  ΤΟΤΕ
                  μεγ ← ΣΕ[ i ]
            ΤΕΛΟΣ_ΑΝ

            ΑΝ  ΣΕ[θ] = μεγ  ΤΟΤΕ         ! ΣΕ[θ]: το σύνολο του ζητούμενου ιστοτόπου
                  ΕΜΦΑΝΙΣΕ  "Εβδομάδα: " , κ
            ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

      αρχή ← αρχή + 7
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
-------------------------------
« Τελευταία τροποποίηση: 10 Ιούν 2014, 12:42:10 πμ από Άρης Κεσογλίδης »
Άρης Κεσογλίδης
Μαθηματικός
Μεταπτυχιακό στη "Θεωρητική Πληροφορική και Θεωρία Συστημάτων και Ελέγχου"

Άρης Κεσογλίδης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: Θέμα Δ
« Απάντηση #22 στις: 09 Ιούν 2014, 11:40:13 μμ »
Γιατί δεν μου εμφανίζονται όλοι οι δείκτες στις αγκύλες;;...  :-\
Μου τρώει το i ...
Άρης Κεσογλίδης
Μαθηματικός
Μεταπτυχιακό στη "Θεωρητική Πληροφορική και Θεωρία Συστημάτων και Ελέγχου"

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Θέμα Δ
« Απάντηση #23 στις: 10 Ιούν 2014, 12:32:07 πμ »
Γιατί δεν μου εμφανίζονται όλοι οι δείκτες στις αγκύλες;;...  :-\
Μου τρώει το i ...

Δοκίμασε κενό πριν και μετά το i  [ i ]

vigor

  • Βετεράνος
  • ****
  • Μηνύματα: 73
Απ: Θέμα Δ
« Απάντηση #24 στις: 11 Ιούν 2014, 01:14:50 πμ »
Συνάδελφοι απ' ότι είδα τόσο στο παραπάνω ποστ της kikylimp, όσο και από το πρόσφατο παρελθόν σε μια άσκηση που έβαλε να λύσουν τα παιδιά μια φοιτήτρια που είχε έρθει από ΑΣΟΕΕ στο σχολείο μου για πρακτική άσκηση, κάποιοι μαθητές αποφεύγουν την χρήση λογικής μεταβλητής (flag) και επιλέγουν μια ακέραια μεταβλητή. Στο Δ4, για παράδειγμα εκχωρούνε σ'αυτή μια αρχική ακέραια τιμή και την αλλάζουν μετά στην συνθήκη διακοπής, αν επιλέξουν Μέχρις ότου ή την βάζουν στην Οσο μαζί με την ι<=10.

Είναι σωστός αυτός ο τρόπος λύσης με την χρήση της ακέραιας μεταβλητής ? Υποθέτω ότι θα εμφανισθούν γραπτά με αυτόν τον τρόπο λύσης.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Θέμα Δ
« Απάντηση #25 στις: 11 Ιούν 2014, 02:10:41 πμ »
Συνάδελφοι απ' ότι είδα τόσο στο παραπάνω ποστ της kikylimp, όσο και από το πρόσφατο παρελθόν σε μια άσκηση που έβαλε να λύσουν τα παιδιά μια φοιτήτρια που είχε έρθει από ΑΣΟΕΕ στο σχολείο μου για πρακτική άσκηση, κάποιοι μαθητές αποφεύγουν την χρήση λογικής μεταβλητής (flag) και επιλέγουν μια ακέραια μεταβλητή. Στο Δ4, για παράδειγμα εκχωρούνε σ'αυτή μια αρχική ακέραια τιμή και την αλλάζουν μετά στην συνθήκη διακοπής, αν επιλέξουν Μέχρις ότου ή την βάζουν στην Οσο μαζί με την ι<=10.

Είναι σωστός αυτός ο τρόπος λύσης με την χρήση της ακέραιας μεταβλητής ? Υποθέτω ότι θα εμφανισθούν γραπτά με αυτόν τον τρόπο λύσης.

Γιατί όχι; Πλάκα πλάκα και στη C δεν υπάρχει λογικός τύπος. Μέσω ακεραίων υπολογίζονται οι λογικές εκφράσεις!

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #26 στις: 11 Ιούν 2014, 04:23:33 μμ »
Έλεγα να γράψω ξεχωριστό thread με τίτλο πως ένας μαθητής ξεφτιλίζει εντελώς το θέμα Δ.
αλλά ας το γράψω εδώ

Πως έκανε την αναζήτηση
Κώδικας: Pascal
  1.  
  2. Αρχή Επανάληψης
  3.      Διάβασε Ονομα
  4. Μέχρις_ότου ([1]=Όνομα ή Oν[2]=Όνομα ή Oν[3]=Όνομα ή Oν[4]=Όνομα ή Oν[5]=Όνομα ή Oν[6]=Όνομα ή Oν[7]=Όνομα ή Oν[8]=Όνομα ή Oν[9]=Όνομα ή Oν[10]=Όνομα)
  5.  
μετά ξανακάνει μια απλή αναζήτηση με Για αφού ξέρει ότι υπάρχει και βρίσκει τη θέση
και έρχεται ο ίδιος πάλι στο Δ4

Κώδικας: Pascal
  1. Σ[1] <- Σ[2] <- Σ[3] <-Σ[4] <- 0
  2. Για j από 1 μέχρι 28
  3.     Αν ι<=7  Τότε   Σ[1] <- Σ[1] + Ε[1,j]
  4.     Αλλιώς_αν  ι<=14 Τότε Σ[2] <- Σ[2] + Ε[2,j]
  5.     Αλλιώς_αν  ι<=21 Τότε Σ[3] <- Σ[3] + Ε[3,j]
  6.     Αλλιώς
  7.                 Σ[4] <- Σ[4] + Ε[4,j]
  8. Τέλος_Επανάληψης
  9. max <-- Σ[1]
  10. Αν Σ[2] > max Τότε max <-- Σ[2]
  11. Αν Σ[3] > max Τότε max <-- Σ[3]
  12. Αν Σ[4] > max Τότε max <-- Σ[4]
  13.  
  14. Αν max = Σ[1] Τότε Εμφάνισε "1"     // Το εμφανίζει και σε αυτάκια!!!!
  15. Αν max = Σ[2] Τότε Εμφάνισε "2"
  16. Αν max = Σ[3] Τότε Εμφάνισε "3"
  17. Αν max = Σ[4] Τότε Εμφάνισε "4"
  18.  
respect στο παιδί

Ο συγκεκριμένος μαθητής που έχει άριστα το Δ και το Β κατάλαβε ότι στο Γ υπάρχει ένας λογαριασμός για κάθε προιον και όχι ένας τελικός και την πάτησε εκεί και κλασικά έχασε στο θέμα Α τους κανόνες του Για και 2 ΣΛ.

Ωστόσο στα εσπερινά στο θέμα Γ χρησιμοποιεί την έκφραση τελικός λογαριασμός και όχι σκέτο λογαριασμός. Από ότι φαίνεται η αλλαγή θα έγινε τελευταία στιγμή το πρωί όπου θα είχαν χάσει τα αυγά και τα πασχάλια και θα τροποποίησαν μόνο το αρχείο των εσπερινών και όχι των ημερησίων. Τέτοιο λάθος είναι ανθρώπινο πάντως σε σχέση με τα άλλα, για να είμαστε δίκαιοι

κατά τα άλλα τα θέματα Γ και Δ ήταν πολύ καλά σχεδιασμένα και διατυπωμένα....
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Θέμα Δ
« Απάντηση #27 στις: 11 Ιούν 2014, 04:32:48 μμ »
Ωραίος!
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #28 στις: 11 Ιούν 2014, 07:05:28 μμ »
Και συνεχίζω με άλλη μια επιστημονικά τεκμηριωμένη διαπόμπευση του Δ4

Κώδικας: [Επιλογή]
S1 <-- επ[θ, 1] + επ[θ,2] + επ[θ,3] + επ[θ,4] + επ[θ,5] + επ[θ,6] + επ[θ,7]
S2 <-- επ[θ, 8] + επ[θ,9] + επ[θ,10] + επ[θ,11] + επ[θ,12] + επ[θ,13] + επ[θ,14]
S3 <-- επ[θ, 15] + επ[θ,16] + επ[θ,17] + επ[θ,18] + επ[θ,19] + επ[θ,20] + επ[θ,21]
S4 <-- επ[θ, 22] + επ[θ,23] + επ[θ,24] + επ[θ,25] + επ[θ,26] + επ[θ,27] + επ[θ,28]

ελπίζω να μην κόψει κανένας επειδή δε μηδένισε του αθροιστές :D
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 511
Απ: Θέμα Δ
« Απάντηση #29 στις: 12 Ιούν 2014, 05:07:49 μμ »

Ωστόσο στα εσπερινά στο θέμα Γ χρησιμοποιεί την έκφραση τελικός λογαριασμός και όχι σκέτο λογαριασμός. Από ότι φαίνεται η αλλαγή θα έγινε τελευταία στιγμή το πρωί όπου θα είχαν χάσει τα αυγά και τα πασχάλια και θα τροποποίησαν μόνο το αρχείο των εσπερινών και όχι των ημερησίων. Τέτοιο λάθος είναι ανθρώπινο πάντως σε σχέση με τα άλλα, για να είμαστε δίκαιοι


Και αν βεβαιώσω ότι έφτασε τη εξής ερώτημα στην επιτροπή: "ΑΕΠΠ Ημερήσια, Σχολειο ΧΧΧ, Γ2": Λογαριασμός τελικός ή τρέχων; και ήρθε η κλασσική απάντηση: ΚΑΜΙΑ ΑΠΑΝΤΗΣΗ;
Καταλαβαίνω ότι οι άνθρωποι περνούν μια πολύ δύσκολη νύχτα και ημέρα, αλλά η ερώτηση ήταν εντελώς ξεκάθαρη, νομίζω ότι με μια μικρή ματιά γινόταν αντιληπτό το ασαφές...


Ίσως θα έπρεπε να υπάρχει ένας νόμος τύπου "νόμος evry" στην επιτροπή μας:
Στο μάθημα ΑΕΠΠ αν σε ένα ερώτημα υπάρχουν πάνω από 20 αιτήματα ξανακοιτάξτε με προσοχή το ερώτημα



Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3177
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Δ
« Απάντηση #30 στις: 12 Ιούν 2014, 05:44:08 μμ »
Και αν βεβαιώσω ότι έφτασε τη εξής ερώτημα στην επιτροπή: "ΑΕΠΠ Ημερήσια, Σχολειο ΧΧΧ, Γ2": Λογαριασμός τελικός ή τρέχων; και ήρθε η κλασσική απάντηση: ΚΑΜΙΑ ΑΠΑΝΤΗΣΗ;
Καταλαβαίνω ότι οι άνθρωποι περνούν μια πολύ δύσκολη νύχτα και ημέρα, αλλά η ερώτηση ήταν εντελώς ξεκάθαρη, νομίζω ότι με μια μικρή ματιά γινόταν αντιληπτό το ασαφές...

Ίσως θα έπρεπε να υπάρχει ένας νόμος τύπου "νόμος evry" στην επιτροπή μας:
Στο μάθημα ΑΕΠΠ αν σε ένα ερώτημα υπάρχουν πάνω από 20 αιτήματα ξανακοιτάξτε με προσοχή το ερώτημα

Υπάρχει Βαγγέλη και ο νόμος του παγωνιού, κάποιοι της επιτροπής θα πρέπει να χαμηλώνουν που και που τη μύτη τους

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #31 στις: 12 Ιούν 2014, 06:58:58 μμ »
Βαγγέλη θα σου πω ένα σενάριο:
Παίρνουν το ερώτημά σου όπως και άλλα που σίγουρα θα υπήρχαν για το ίδιο θέμα. Έχουν μπροστά τους κάποια θέματα και τα κοιτάνε και βλέπουν τι λέξη "τελικός". Σου λέει οκ κανένα σχόλιο.
Μόνο που αυτά που κοίταγαν ήταν των εσπερινών!!!
Φαντάσου ότι μετά από αλλεπάληλες διορθώσεις γίνεται ένας πανικός πάνω στο γραφείο που έχουν άπειρα χαρτιά

Δεν μπορώ να σκεφτώ άλλη εξήγηση αφού το διόρθωσαν στα εσπερινά

Και αν βεβαιώσω ότι έφτασε τη εξής ερώτημα στην επιτροπή: "ΑΕΠΠ Ημερήσια, Σχολειο ΧΧΧ, Γ2": Λογαριασμός τελικός ή τρέχων; και ήρθε η κλασσική απάντηση: ΚΑΜΙΑ ΑΠΑΝΤΗΣΗ;
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

arisbasil

  • Θαμώνας
  • ***
  • Μηνύματα: 28
  • 1+1=10
Απ: Θέμα Δ
« Απάντηση #32 στις: 12 Ιούν 2014, 08:33:00 μμ »
Βαγγέλη θα σου πω ένα σενάριο:
Παίρνουν το ερώτημά σου όπως και άλλα που σίγουρα θα υπήρχαν για το ίδιο θέμα. Έχουν μπροστά τους κάποια θέματα και τα κοιτάνε και βλέπουν τι λέξη "τελικός". Σου λέει οκ κανένα σχόλιο.
Μόνο που αυτά που κοίταγαν ήταν των εσπερινών!!!
Φαντάσου ότι μετά από αλλεπάληλες διορθώσεις γίνεται ένας πανικός πάνω στο γραφείο που έχουν άπειρα χαρτιά

Δεν μπορώ να σκεφτώ άλλη εξήγηση αφού το διόρθωσαν στα εσπερινά


Δηλαδή τα αρχικά θέματα στα εσπερινά δεν είχαν τη λέξη "τελικός";  ??? Δεν καταλαβαίνω...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #33 στις: 12 Ιούν 2014, 09:14:28 μμ »
όχι, εννοώ ότι μπορεί να το διορθωσαν στι 5 το πρωι
κάποιος ξέχασε να πατήσει το save ή το save as
κάποια πάτησε πολλές φορές το backspace
αυτό εννοώ

Δηλαδή τα αρχικά θέματα στα εσπερινά δεν είχαν τη λέξη "τελικός";  ??? Δεν καταλαβαίνω...

ότι κάποια στιγμή έγινε αλλαγή αλλά αυτή δεν πέρασε στο αρχείο των ημερησίων, τώρα γιατί ένας θεός ξέρει
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

demy pap

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέμα Δ
« Απάντηση #34 στις: 12 Ιούν 2014, 11:56:18 μμ »
Θα ήταν τόσο εξωπραγματικό να περιμένω κάποιος από την επιτροπή, κάποια φορά να πει κάτι; Εκτός αν υπογράφουν κάποια confidentiality agreement με το που γίνονται μέλη της επιτροπής.

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3177
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Δ
« Απάντηση #35 στις: 13 Ιούν 2014, 10:55:44 πμ »
Βαγγέλη θα σου πω ένα σενάριο:
Παίρνουν το ερώτημά σου όπως και άλλα που σίγουρα θα υπήρχαν για το ίδιο θέμα. Έχουν μπροστά τους κάποια θέματα και τα κοιτάνε και βλέπουν τι λέξη "τελικός". Σου λέει οκ κανένα σχόλιο.
Μόνο που αυτά που κοίταγαν ήταν των εσπερινών!!!
Φαντάσου ότι μετά από αλλεπάληλες διορθώσεις γίνεται ένας πανικός πάνω στο γραφείο που έχουν άπειρα χαρτιά

Δεν μπορώ να σκεφτώ άλλη εξήγηση αφού το διόρθωσαν στα εσπερινά


Το άλλο σενάριο είναι οτι δε θέλουν να στείλουν διόρθωση που θα σήμαινε ότι δεν ήταν οκ, το αρχικό κείμενο.
Όπως και να το κάνουμε, σε όλους μας συμβαίνει συνεχώς, μια διόρθωση σημαίνει αναγνώριση λάθους

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #36 στις: 13 Ιούν 2014, 01:49:26 μμ »
Μάλλον είναι αυτό που λένε:

Εγώ ποτέ δεν κάνω λάθος. Μια φόρα νόμιζα ότι είχα κάνει λάθος, αλλά τελικά...... είχα κάνει λάθος  >:D

Το άλλο σενάριο είναι οτι δε θέλουν να στείλουν διόρθωση που θα σήμαινε ότι δεν ήταν οκ, το αρχικό κείμενο.
Όπως και να το κάνουμε, σε όλους μας συμβαίνει συνεχώς, μια διόρθωση σημαίνει αναγνώριση λάθους
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

batos

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Τρισδιάστατοι και ....
« Απάντηση #37 στις: 15 Ιούν 2014, 12:06:53 μμ »
Εμφανίστηκε γραπτό με χρήση τρισδιάστατου. Κανένα πρόβλημα.
Το καταπληκτικό ήταν όμως ότι στα υποερωτήματα έκανε εκτεταμένες κλήσεις σε συναρτήσεις (!) (που είχε φτιάξει ο ίδιος-αναζητήσεις, εύρεση μεγίστων, κτλ) παρ΄όλο που βρισκόταν μέσα σε Αλγόριθμο. [Εντάξει. "Κάθε λύση επιστημονικά ..." ακόμα και το βιβλίο κάνει χρήση "διαδικασιών" στους αλγορίθμους (βλ.ταξινόμηση "αντιμετάθεσε") και μάλιστα χωρίς να διευκρινίζει πως γίνεται]. 

Ο τύπος ήξερε απολύτως τι έκανε! Η απόλυτη λύση. Ούτε πρόχειρο χρησιμοποίησε, ούτε μουντζούρες, τίποτα..... Κατ' ευθείαν ποίημα. ;-)

ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 120
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #38 στις: 15 Ιούν 2014, 01:41:20 μμ »
Εμφανίστηκε γραπτό με χρήση τρισδιάστατου. Κανένα πρόβλημα.
Το καταπληκτικό ήταν όμως ότι στα υποερωτήματα έκανε εκτεταμένες κλήσεις σε συναρτήσεις (!) (που είχε φτιάξει ο ίδιος-αναζητήσεις, εύρεση μεγίστων, κτλ) παρ΄όλο που βρισκόταν μέσα σε Αλγόριθμο. [Εντάξει. "Κάθε λύση επιστημονικά ..." ακόμα και το βιβλίο κάνει χρήση "διαδικασιών" στους αλγορίθμους (βλ.ταξινόμηση "αντιμετάθεσε") και μάλιστα χωρίς να διευκρινίζει πως γίνεται]. 

Ο τύπος ήξερε απολύτως τι έκανε! Η απόλυτη λύση. Ούτε πρόχειρο χρησιμοποίησε, ούτε μουντζούρες, τίποτα..... Κατ' ευθείαν ποίημα. ;-)

πόσο βαθμολογήθηκε το συγκεκριμένο γραπτό;

batos

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Δ
« Απάντηση #39 στις: 15 Ιούν 2014, 03:23:09 μμ »
είπαμε. :angel: ... ποίημα  ;)

Άρης Κεσογλίδης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: Θέμα Δ
« Απάντηση #40 στις: 15 Ιούν 2014, 07:56:36 μμ »
Το καταπληκτικό ήταν όμως ότι στα υποερωτήματα έκανε εκτεταμένες κλήσεις σε συναρτήσεις (!) (που είχε φτιάξει ο ίδιος-αναζητήσεις, εύρεση μεγίστων, κτλ) παρ΄όλο που βρισκόταν μέσα σε Αλγόριθμο. [Εντάξει. "Κάθε λύση επιστημονικά ..." ακόμα και το βιβλίο κάνει χρήση "διαδικασιών" στους αλγορίθμους (βλ.ταξινόμηση "αντιμετάθεσε") και μάλιστα χωρίς να διευκρινίζει πως γίνεται]. 

Η "αντιμετάθεσε" είναι εντολή, δεν είναι διαδικασία στη ΓΛΩΣΣΑ.
Εγώ δεν καταλαβαίνω γιατί να μην κοπούν μονάδες όταν μπλέκει υποπρογράμματα στην ψευδογλώσσα...
Άλλο να γράψεις απλά ΓΡΑΨΕ αντί για ΕΜΦΑΝΙΣΕ, και άλλο αυτό. Έκανε και δήλωση μεταβλητών;
Άρης Κεσογλίδης
Μαθηματικός
Μεταπτυχιακό στη "Θεωρητική Πληροφορική και Θεωρία Συστημάτων και Ελέγχου"

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #41 στις: 15 Ιούν 2014, 09:25:50 μμ »
στην ψευδογλώσσα μπορείς να έχεις κλήση αλγορίθμου από αλγόριθμο, δες το αναδρομικό παράδειγμα της δυαδικής αναζήτησης μέσα από το βιβλίο.
Δήλωση μεταβλητών δε χρειάζεται.
Εγώ δεν καταλαβαίνω γιατί να μην κοπούν μονάδες όταν μπλέκει υποπρογράμματα στην ψευδογλώσσα...
Άλλο να γράψεις απλά ΓΡΑΨΕ αντί για ΕΜΦΑΝΙΣΕ, και άλλο αυτό. Έκανε και δήλωση μεταβλητών;

Αν ο μαθητής δεν "κλέβει", δηλαδή δεν χρησιμοποιεί υπό-αλγορίθμους για να ξεγλιστρήσει από ένα δύσκολο σημείο της άσκησης, τότε δε νομίζω ότι πρέπει να του κοπεί κάτι.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

batos

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Δ
« Απάντηση #42 στις: 15 Ιούν 2014, 09:52:37 μμ »
Η "αντιμετάθεσε" είναι εντολή, δεν είναι διαδικασία στη ΓΛΩΣΣΑ.
Εγώ δεν καταλαβαίνω γιατί να μην κοπούν μονάδες όταν μπλέκει υποπρογράμματα στην ψευδογλώσσα...
Άλλο να γράψεις απλά ΓΡΑΨΕ αντί για ΕΜΦΑΝΙΣΕ, και άλλο αυτό. Έκανε και δήλωση μεταβλητών;

Η "αντιμετάθεσε" είναι εντολή (σύμφωνα με το βιβλίο) στην ψευδογλώσσα που γράφονται οι Αλγόριθμοι στο πρώτο μέρος του βιβλίου και όχι στην ΓΛΩΣΣΑ (Δεν χρησιμοποιείται στα κεφ.7,8,..). Όπου χρειάζεται σε ΓΛΩΣΣΑ, αντιμετάθεση, υλοποιείται με την συνηθισμένη τριπλέτα εντολών (βλέπε και σελ.189). Για να μην μπερδεύονται οι μαθητές, τους προτείνω να γράφουν πάντα την τριπλέτα εντολών. Δικό μου το λάθος που χαρακτήρισα την "αντιμετάθεσε" διαδικασία.
Σε κάθε περίπτωση, λύση που υλοποιεί τμηματικό προγραμματισμό, βρίσκεται σε άλλο επίπεδο, άλλη κλάση.....

Άρης Κεσογλίδης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: Θέμα Δ
« Απάντηση #43 στις: 15 Ιούν 2014, 09:56:33 μμ »
στην ψευδογλώσσα μπορείς να έχεις κλήση αλγορίθμου από αλγόριθμο, δες το αναδρομικό παράδειγμα της δυαδικής αναζήτησης μέσα από το βιβλίο.
Δήλωση μεταβλητών δε χρειάζεται.

Αυτό πάλι;... Δηλαδή ένας να ξέρει αναδρομικότητα εκτός ύλης, και να μη χρειάζεται να δηλώσει μεταβλητές, και ο άλλος που προσπαθεί να διαβάσει μέσα στην ύλη, να πάει να δηλώσει μεταβλητές και να κάνει λάθος εκεί και να του κοπούν μονάδες...  :-\

Η "αντιμετάθεσε" είναι εντολή (σύμφωνα με το βιβλίο) στην ψευδογλώσσα που γράφονται οι Αλγόριθμοι στο πρώτο μέρος του βιβλίου και όχι στην ΓΛΩΣΣΑ (Δεν χρησιμοποιείται στα κεφ.7,8,..).
Ναι, "ψευδογλώσσα" ήθελα να γράψω.
Άρης Κεσογλίδης
Μαθηματικός
Μεταπτυχιακό στη "Θεωρητική Πληροφορική και Θεωρία Συστημάτων και Ελέγχου"

batos

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Δ
« Απάντηση #44 στις: 15 Ιούν 2014, 10:16:26 μμ »
Όταν ζητείται αλγόριθμος, ποιος διορθωτής κοιτάει δηλώσεις μεταβλητών;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #45 στις: 16 Ιούν 2014, 12:17:35 πμ »
Ενώ όταν ζητείται πρόγραμμα πιστεύεις ότι τις κοιτάνε?  ;)

Όταν ζητείται αλγόριθμος, ποιος διορθωτής κοιτάει δηλώσεις μεταβλητών;
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #46 στις: 16 Ιούν 2014, 12:33:14 πμ »
Αυτό πάλι;... Δηλαδή ένας να ξέρει αναδρομικότητα εκτός ύλης, και να μη χρειάζεται να δηλώσει μεταβλητές, και ο άλλος που προσπαθεί να διαβάσει μέσα στην ύλη, να πάει να δηλώσει μεταβλητές και να κάνει λάθος εκεί και να του κοπούν μονάδες...  :-\
Δηλαδή για να χρησιμοποιήσει κάποιος κλήση αλγορίθμου από αλγόριθμο πρέπει να ξέρει αναδρομή?
Η κοινή λογική δεν μετράει? τόσο φοβερό είναι? κανείς δεν έχει αναρωτηθεί ποτέ ποιος είναι ο ρόλος των Δεδομένων και των Αποτελεσμάτων?

Επίσης τι μανία είναι αυτή με αναφορές για εντός και εκτός ύλης? Ιστορία κάνουμε?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Άρης Κεσογλίδης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: Θέμα Δ
« Απάντηση #47 στις: 16 Ιούν 2014, 01:16:31 πμ »
Δηλαδή για να χρησιμοποιήσει κάποιος κλήση αλγορίθμου από αλγόριθμο πρέπει να ξέρει αναδρομή?
Η κοινή λογική δεν μετράει? τόσο φοβερό είναι? κανείς δεν έχει αναρωτηθεί ποτέ ποιος είναι ο ρόλος των Δεδομένων και των Αποτελεσμάτων?
Αυτό που λες δεν υπάρχει... "Κοινή λογική" σε μαθητές, και να το σκεφτούν μόνοι τους;; Χωρίς να λέει τίποτα το βιβλίο στην ύλη που διδάσκονται;; Καμία πιθανότητα δεν δίνω.
Και όταν τελικά φτάσουμε στον Τημηματικό Προγραμματισμό και ρωτήσει κάποιος αν υπάρχει περίπτωση να γράψει κάτι αντίστοιχο στην Ψευδογλώσσα, του λέμε όχι! Άλλο θέμα το ότι εξηγούμε πως οι εντολές Δεδομένα και Αποτελέσματα έχουν μεταβλητές που μοιάζουν με τις παραμέτρους των υποπρογραμμάτων.

Επίσης τι μανία είναι αυτή με αναφορές για εντός και εκτός ύλης? Ιστορία κάνουμε?
Να επιστρέψουμε στο θέμα των δυναμικών δομών τότε, και να τις χρησιμοποιούμε σε κάθε άσκηση αντί να σπάμε το κεφάλι μας αν πρέπει να χρησιμοποιήσουμε ή όχι στατικούς πίνακες;......
Άρης Κεσογλίδης
Μαθηματικός
Μεταπτυχιακό στη "Θεωρητική Πληροφορική και Θεωρία Συστημάτων και Ελέγχου"

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #48 στις: 16 Ιούν 2014, 11:35:46 πμ »
Αυτό που λες δεν υπάρχει... "Κοινή λογική" σε μαθητές, και να το σκεφτούν μόνοι τους;; Χωρίς να λέει τίποτα το βιβλίο στην ύλη που διδάσκονται;; Καμία πιθανότητα δεν δίνω.
Φαίνεσαι πολύ βέβαιος και απόλυτος για κάτι που δεν ισχύει.
Πως εξηγείς τότε ότι φέτος πολλοί μαθητές χρησιμοποιήσαν ήδη
1) Πίνακες τριών διαστάσεων που δεν είχαν διδαχθεί
2) Δυναμικούς πίνακες
3) Κλήση αλγορίθμου από αλγόριθμο

τα οποία είναι θέματα εκτός ύλης που δεν έχουν διδαχθεί?

Αυτό δεν αναιρεί το παραπάνω σκεπτικό σου?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Άρης Κεσογλίδης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: Θέμα Δ
« Απάντηση #49 στις: 16 Ιούν 2014, 01:21:37 μμ »
Η χρήση τρισδιάστατων αυτών εξηγείται
- είτε με το ότι κάποιος καθηγητής τους τους τα δίδαξε,
- είτε με το ότι ασχολούνται γενικά εκτός σχολείου ήδη με προγραμματισμό.
Αλλά να το σκέφτηκε μόνος του κάποιος μαθητής έτσι απλά με "κοινή λογική", αυτό μου φαίνεται απίθανο...
Άντε, να αφήσω 1 πιθανότητα στις 100000 για να μην είμαι τόσο απόλυτος...  :)
Άρης Κεσογλίδης
Μαθηματικός
Μεταπτυχιακό στη "Θεωρητική Πληροφορική και Θεωρία Συστημάτων και Ελέγχου"

batos

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Δ
« Απάντηση #50 στις: 16 Ιούν 2014, 07:21:26 μμ »
Δηλαδή για να χρησιμοποιήσει κάποιος κλήση αλγορίθμου από αλγόριθμο πρέπει να ξέρει αναδρομή?
Η κοινή λογική δεν μετράει? τόσο φοβερό είναι? κανείς δεν έχει αναρωτηθεί ποτέ ποιος είναι ο ρόλος των Δεδομένων και των Αποτελεσμάτων?

Συμφωνώ.
Έχουμε ένα μάθημα που ξεκινάει με ψευδογλώσσα και διαγράμματα ροής, και καταλήγει με ΓΛΩΣΣΑ και υποπρογράμματα.
Η αντιστοιχία αλγορίθμων με ΔΕΔΟΜΕΝΑ και ΑΠΟΤΕΛΕΣΜΑΤΑ, με τα υποπρογράμματα είναι απαραίτητη όταν διδάσκεται η μετάβαση στον τμηματικό προγραμματισμό. Στο βιβλίο τονίζονται συνέχεια τα πλεονεκτήματα του τμηματικού προγραμματισμού.
Κάποιος υλοποιεί τμηματικό προγραμματισμό με αλγορίθμους (γιατί η ανάγκη του προβλήματος το επιβάλλει) και χρησιμοποιεί μια ανάμικτη σύνταξη ορισμού υποπρογράμματος και κλήσης του, γιατί το βιβλίο δεν λέει πώς γίνεται αυτό (υπο-αλγόριθμος;).
Όταν ένα θέμα όπως το Δ, εξετάζει ουσιαστικά αλγοριθμική λογική (και ο εξεταζόμενος την δίνει σωστά), τότε δεν υπάρχει κάτι αρνητικό στην παραπάνω προσέγγιση.

apoldem

  • Βετεράνος
  • ****
  • Μηνύματα: 86
Απ: Θέμα Δ
« Απάντηση #51 στις: 17 Ιούν 2014, 11:29:04 πμ »
Η σύγχρονη αντίληψη για την εκμάθηση αλγορίθμων είναι ότι ο τμηματικός προγραμματισμός διδάσκεται μαζί με τις τρεις δομές (ακολουθία, επιλογή και επανάληψη). Ουσιαστικά ο τμηματικός προγραμματισμός είναι η τέταρτη δομή αφού αλλάζει δραματικά τον τρόπο που γράφεται ο κώδικας. Μπορεί (και πρέπει) να διδάσκεται πριν ακόμη την δομή επανάληψης. Δείτε για παράδειγμα το light-bot από την ώρα του κώδικα http://light-bot.com/hocflash.html, για παιδιά δημοτικού. Πρώτα διδάσκονται τις διαδικασίες και μετά η επανάληψη έρχεται σαν φυσικό επακόλουθο. Από προσωπική εμπειρία σας διαβεβαιώνω ότι τα 10χρονα παιδάκια δεν έχουν κανένα πρόβλημα να καταλάβουν αμέσως τι είναι το υποπρόγραμμα.