Αποστολέας Θέμα: ΘΕΜΑ Γ  (Αναγνώστηκε 15210 φορές)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: ΘΕΜΑ Γ
« Απάντηση #15 στις: 06 Ιούν 2014, 11:41:22 πμ »
Ο λογαριασμός είναι μετά το τέλος της επανάληψης
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 673
Απ: ΘΕΜΑ Γ
« Απάντηση #16 στις: 06 Ιούν 2014, 12:04:24 μμ »
τα διαβασε εκτός από τον κωδικό θεωρώ πρέπει να μπουν μια φορά μέσα στην επανάληψη..ώστε αν δίνει κωδικό  0 να σταματάει κ να μην διαβάζει τεμάχια και τιμή..
τον λογ τον ελέγχεις αφού τελειώσει τα ψώνια του ...

μια μικρή παρατήρηση....όταν βρει max,
Αν τιμη>max τότε
      smax<- 0
   αλλιώς αν τιμη=max τοτε
      smax<- smax+αρτεμ
   Τέλος αν

τότε smax<--1 και όχι 0....έχω ένα μέγιστο....σωστά???

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: ΘΕΜΑ Γ
« Απάντηση #17 στις: 06 Ιούν 2014, 12:08:21 μμ »
τότε smax<--1 και όχι 0....έχω ένα μέγιστο....σωστά???

αν βρεθεί maxτιμη μεγαλύτερη από αυτή που είχα μέχρι τώρα ,το smax να γίνει ο τρέχον αριθμός τεμαχίων και να αλλάξει η τιμή του maxτιμη
και αν τιμή είναι ίση με την maxτιμη να προσθέτει τον αριθμό των τεμαχίων

   Αν τιμη>maxτιμη τότε
      maxτιμη<- τιμη
      smax<- αρτεμ
   αλλιώς αν τιμη=maxτιμη τοτε
      smax<- smax+αρτεμ
   Τέλος αν

« Τελευταία τροποποίηση: 06 Ιούν 2014, 12:28:50 μμ από pstasinos »

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 673
Απ: ΘΕΜΑ Γ
« Απάντηση #18 στις: 06 Ιούν 2014, 12:10:58 μμ »
Σωστά συν πόσότητα

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: ΘΕΜΑ Γ
« Απάντηση #19 στις: 06 Ιούν 2014, 12:16:28 μμ »
 .

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #20 στις: 06 Ιούν 2014, 01:33:39 μμ »
μπορεί το θέμα Γ να λυθεί με πίνακες??

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: ΘΕΜΑ Γ
« Απάντηση #21 στις: 06 Ιούν 2014, 01:34:24 μμ »
Δεν υπάρχει μέγεθος πίνακα όταν έχουμε άγνωστο αριθμό επαναλήψεων κι επειδή ο πίνακας είναι στατική δομή, είναι λάθος
Αντίστοιχο θέμα είχε δημιουργηθεί με το 3ο θέμα του 2010, όπου μάλιστα η άσκηση ήταν με Για
Τελικά, για λύση με πίνακα κόπηκαν 2 μονάδες
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #22 στις: 06 Ιούν 2014, 01:40:20 μμ »
Δηλαδή αν η άσκηση λυθεί με πίνακες θα χαθούν όλες οι μονάδες και αν οχι τότε πόσες περίπου?

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: ΘΕΜΑ Γ
« Απάντηση #23 στις: 06 Ιούν 2014, 01:41:34 μμ »
Θα κριθεί από το βαθμολογικό κέντρο αυτό, ας απαντήσει κάποιος πιο έμπειρος
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #24 στις: 06 Ιούν 2014, 01:42:38 μμ »
αν γίνεται ας απαντήσει κάποιος ευχαριστώ..

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #25 στις: 06 Ιούν 2014, 01:52:44 μμ »
είναι λάθος αυτό;;

Αλγόριθμος κπ
ι ← 1
π ← 0
Διάβασε Κ[ι]
Αρχή_επανάληψης
  ι ← ι + 1
  π ← π + 1
  Διάβασε Κ[ι]
Μέχρις_ότου Κ[ι] = 0
Για ι από 1 μέχρι π
  Εμφάνισε Κ[ι]
Τέλος_επανάληψης
Τέλος κπ

spantoulis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 109
Απ: ΘΕΜΑ Γ
« Απάντηση #26 στις: 06 Ιούν 2014, 02:19:28 μμ »
" Δηλαδή αν η άσκηση λυθεί με πίνακες θα χαθούν όλες οι μονάδες και αν οχι τότε πόσες περίπου? "

η εμπειρία λέει ότι σε ανάλογες περιπτώσεις η γραμμή είναι 1 με 2 μόρια ποινή, ακόμη και όταν υπάρχει οδηγία από την ΚΕΕ να κοπούν οι μισές μονάδες
Φυσικά ο κάθε βαθμολογητής έχει την ελευθερία να βαθμολογήσει κατά βούληση.
« Τελευταία τροποποίηση: 06 Ιούν 2014, 04:30:56 μμ από spantoulis »
Η χρήση υπολογιστών ΔΕΝ είναι πληροφορική

tsabatman

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 108
Απ: ΘΕΜΑ Γ
« Απάντηση #27 στις: 06 Ιούν 2014, 02:45:35 μμ »
είναι κρίμα ένας μαθητής που έχει αποκτήσει τέτοια ευχέρεια να δημιουργεί πίνακα και να χάσει μονάδες επειδή οι πίνακες είναι στατική δομή.
Βαθμολογούμε την αλγοριθμική σκέψη του παιδιού τελικά ή όχι???

parasxoum

  • Νέος
  • *
  • Μηνύματα: 6
Απ: ΘΕΜΑ Γ
« Απάντηση #28 στις: 06 Ιούν 2014, 02:56:19 μμ »
...σας στέλνω και όλη την επίλυση και ο θεός ή (μάλλον ο διορθωτής) ας βάλει το χέρι του .. :'( :'(

Αλγόριθμος Θεμα4_ΠΑΝ2014_Β_ΤΡΟΠΟΣ
ι ← 1
π ← 0
Διάβασε κ[ι]
Αρχή_επανάληψης
  Αν κ[ι] ≠ 0 τότε
    Αρχή_επανάληψης
      Διάβασε α[ι]
    Μέχρις_ότου α[ι] > 0 και α[ι] = Α_Μ(α[ι])
    Αρχή_επανάληψης
      Διάβασε τ[ι]
    Μέχρις_ότου τ[ι] > 0
    ι ← ι + 1
    π ← π + 1
    Διάβασε κ[ι]
  Τέλος_αν
Μέχρις_ότου κ[ι] = 0
λογαριασμος ← 0
Για ι από 1 μέχρι π
  λογαριασμος ← λογαριασμος + (τ[ι] + α[ι])
Τέλος_επανάληψης
Αν λογαριασμος ≤ 500 τότε
  Εμφάνισε "μετρητα"
αλλιώς
  σ ← 0
  δοση ← 20
  ν ← 0
  Όσο σ < λογαριασμος επανάλαβε
    σ ← σ + δοση
    ν ← ν + 1
    δοση ← δοση + 5
  Τέλος_επανάληψης
  Εμφάνισε "αριθμός δόσεων:", ν
Τέλος_αν

σ ← 0
μαξ ← -1
Για ι από 1 μέχρι π
  Αν τ[ι] > 10 τότε
    σ ← σ + α[ι]
  Τέλος_αν
  Αν τ[ι] > μαξ τότε
    μαξ ← τ[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε "συνολικος αριθμος τεμαχιων με τιμη μεγαλυτερη των 10:", σ
σ ← 0
Για ι από 1 μέχρι π
  Αν τ[ι] = μαξ τότε
    σ ← σ + α[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε "συνολικος αριθμοσ τεμαχιων με την μεγιστη τιμη:", σ
Τέλος Θεμα4_ΠΑΝ2014_Β_ΤΡΟΠΟΣ





petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: ΘΕΜΑ Γ
« Απάντηση #29 στις: 06 Ιούν 2014, 03:04:02 μμ »
Μια προφανής ανοησία που υπάρχει στην εκφώνηση του θέματος είναι ότι οι δόσεις, ενώ είναι άτοκες, θα ξεπεράσουν τελικά σαν σύνολο το ποσό του λογαριασμού. Ίσως θα έπρεπε να δοθεί οδηγία να αφαιρείται η διαφορά από την τελευταία δόση, αν και το ερώτημα ήταν μόνο ο αριθμός των δόσεων
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής